Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Ενότητα Α.4. Δομημένος Προγραμματισμός Επιμόρφωση Εκπαιδευτικών Πληροφορικής.

Παρόμοιες παρουσιάσεις


Παρουσίαση με θέμα: "Ενότητα Α.4. Δομημένος Προγραμματισμός Επιμόρφωση Εκπαιδευτικών Πληροφορικής."— Μεταγράφημα παρουσίασης:

1 Ενότητα Α.4. Δομημένος Προγραμματισμός Επιμόρφωση Εκπαιδευτικών Πληροφορικής

2 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 2 Αλγόριθμοι Βασικές Έννοιες Αλγορίθμων Αλγοριθμικές Δομές Περιεχόμενα

3 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 3 Ορισμός Χαρακτηριστικά Τρόποι Αναπαράστασης Αλγόριθμοι

4 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 4 Ορισμός Αλγόριθμος είναι μία πεπερασμένη σειρά ενεργειών, αυστηρά καθορισμένων και εκτελέσιμων σε πεπερασμένο χρόνο, που στοχεύουν στην επίλυση ενός προβλήματος Παράδειγμα Λύση Δευτεροβάθμιας εξίσωσης: αx2+βx+γ=0. Δίνονται οι συντελεστές α,β,γ Υπολογίζεται η Διακρίνουσα Δ ως: β2-4.α.γ Αν Δ>0 υπολογίζονται και εμφανίζονται οι 2 πραγματικές ρίζες από τη σχέση : Αν Δ=0 υπολογίζεται και εμφανίζεται η διπλή πραγματική ρίζα από τη σχέση : Αν Δ<0 ενημερώνουμε ότι δεν υπάρχουν πραγματικές ρίζες. Αλγόριθμοι

5 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 5 Χαρακτηριστικά των Αλγορίθμων Είσοδος (input) : Καμία, μία ή περισσότερες τιμές δεδομένων πρέπει να δίνονται ως είσοδοι στον αλγόριθμο. Έξοδος (output) : τουλάχιστον μία τιμή ως αποτέλεσμα προς το χρήστη ή προς ένα άλλο αλγόριθμο Καθοριστικότητα (defineteness) : κάθε εντολή καθορίζεται πολύ συγκεκριμένα για τον τρόπο εκτέλεσής της (π.χ. διαίρεση) Περατότητα (finiteness) : ο αλγόριθμος τελειώνει μετά από πεπερασμένα βήματα εκτέλεσης. Αλλιώς ονομάζεται υπολογιστική διαδικασία Αποτελεσματικότητα (effectiveness) : ο αλγόριθμος αποτελείται από μεμονωμένες απλές εντολές Αλγόριθμοι

6 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 6 Αναπαράσταση αλγορίθμων Ελεύθερο κείμενο (free text): ανεπεξέργαστος και αδόμητος τρόπος παρουσίασης αλγορίθμου (παραβίαση αποτελεσματικότητας) Διαγραμματικές τεχνικές (diagramming techniques): γραφικός τρόπος παρουσίασης του αλγορίθμου (διάγραμμα ροής) Φυσική γλώσσα (natural language): περιγραφή κατά βήματα (παραβίαση της καθοριστικότητας) Κωδικοποίηση (coding): πρόγραμμα γραμμένο είτε σε ψευδογλώσσα είτε σε προγραμματιστικό περιβάλλον που όταν εκτελεσθεί θα δώσει τα ίδια αποτελέσματα με τον αλγόριθμο Αλγόριθμοι

7 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 7 Σύμβολα διαγράμματος ροής Αλγόριθμοι

8 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 8 ΤΕΛΟΣ ΑΡΧΗ Διάβασε a a > 0 ΝΑΙ ΟΧΙ Παράδειγμα αναπαράστασης αλγορίθμου με διάγραμμα ροής Αλγόριθμοι Γράψε a

9 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 9 Παράδειγμα αναπαράστασης αλγορίθμου με κωδικοποίηση σε ψευδογλώσσα Αλγόριθμος Παράδειγμα Διάβασε a, b Αν a < b τότε c  a+ b αλλιώς c  a * b Τέλος_αν Εκτύπωσε c Τέλος Παράδειγμα Αλγόριθμοι

10 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 10 Σταθερές Μεταβλητές Εκφράσεις Πράξεις Εντολές Βασικές Έννοιες αλγορίθμων

11 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 11 Βασικές Έννοιες Αλγορίθμων Τα δεδομένα και τα ζητούμενα σε ένα πρόβλημα μπορεί να είναι:  Αριθμητικά, και πιο συγκεκριμένα Πραγματικά, π.χ Ακέραια, π.χ  Αλφαριθμητικά ή Χαρακτήρες, π.χ. ‘Μαρκέλλα’  Λογικά που παίρνουν μόνο δύο τιμές Αληθής και Ψευδής Τα παραπάνω αποτελούν τους τύπους των δεδομένων και η ακριβής κωδικοποίησή τους ποικίλει από Γλώσσα σε Γλώσσα Για να εκφράσουμε και να υπολογίσουμε δεδομένα και ζητούμενα σε ένα αλγόριθμο χρησιμοποιούμε σταθερές, μεταβλητές και εκφράσεις

12 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 12 Βασικές Έννοιες Αλγορίθμων Σταθερά: Μια ποσότητα που έχει προκαθορισμένη τιμή που δε μεταβάλλεται κατά τη διάρκεια εκτέλεσης ενός αλγορίθμου/προγράμματος Παράδειγμα  Αλφαριθμητική σταθερά : ‘Καλημέρα’  Αριθμητική σταθερά: 20 Μία σταθερά μπορεί να πάρει ένα συμβολικό όνομα σε ένα πρόγραμμα και χρησιμοποιείται για να αποθηκεύει παγκόσμιες σταθερές (πχ π=3.14, g=9.81) ή δεδομένα που δεν αλλάζουν για το συγκεκριμένο πρόβλημα (πχ φπα=0.19, Ν=100) Η δήλωση και η χρήση συμβολικών ονομάτων αντί των αντίστοιχων σταθερών τιμών είναι προαιρετική, κάνει όμως πιο ευανάγνωστο και κατανοητό το πρόγραμμά μας.

13 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 13 Βασικές Έννοιες Αλγορίθμων Μεταβλητή :Μια ποσότητα που η τιμή της μπορεί να μεταβάλλεται. Αποτελεί ένα γλωσσικό αντικείμενο, που χρησιμοποιείται για να παραστήσει ένα στοιχείο δεδομένου (ή ζητουμένου). Οι μεταβλητές αντιστοιχίζονται από τον μεταγλωττιστή κάθε γλώσσας σε συγκεκριμένες θέσεις μνήμης του υπολογιστή. Το όνομα και ο τύπος καθορίζεται στην αρχή και δεν αλλάζει κατά την εκτέλεση του αλγορίθμου, ενώ η τιμή της μπορεί να αλλάξει.

14 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 14 Βασικές Έννοιες Αλγορίθμων Έκφραση:Συνδυασμός τελεστών (σύμβολα πράξεων) και ορισμάτων – τελεστέων (μεταβλητές, σταθερές) καθώς και παρενθέσεων, με συγκεκριμένο νόημα.  Η διεργασία αποτίμησης μίας έκφρασης γίνεται με αντικατάσταση των μεταβλητών από τις τιμές τους και εκτέλεση των πράξεων  Η τελική τιμή μιας έκφρασης εξαρτάται από την ιεραρχία των πράξεων και τη χρήση των παρενθέσεων  Π.χ. Η έκφραση (α+β)/2, για α=10 και β=2 έχει τιμή 6. Η έκφραση α>β+5, για α=10 και β=2 έχει τιμή Αληθής  Το αποτέλεσμα μιας έκφρασης είναι πάντα μία τιμή.

15 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 15 Βασικές Έννοιες Αλγορίθμων Πράξεις  Στον αλγόριθμο οι πράξεις κωδικοποιούνται με ειδικό τρόπο προκειμένου να γίνονται κατανοητές. Δίπλα παρουσιάζονται οι πράξεις που υποστηρίζει η ΓΛΩΣΣΑ και η ιεραρχία τους  Πράξεις ίδιας ιεραρχίας εκτελούνται από αριστερά προς τα δεξιά.

16 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 16 Αριθμητικές εκφράσεις

17 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 17 Βασικές Έννοιες Αλγορίθμων

18 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 18 Βασικές Έννοιες Αλγορίθμων Ονοματολογία μεταβλητών & σταθερών στη αλγοριθμική ΓΛΩΣΣΑ Υποχρεωτικοί κανόνες  Περιλαμβάνουν μόνο Περιλαμβάνουν μόνο Ελληνικούς ή αγγλικούς χαρακτήρες Αριθμητικά ψηφία τον χαρακτήρα _ (κάτω παύλα)  Ξεκινάνε πάντα με γράμμα και όχι με αριθμητικό ψηφίο ή κάτω παύλα  Δεν ταυτίζονται με «δεσμευμένες» λέξεις (λέξεις που έχουν κάποια ειδική χρήση στον αλγόριθμο ή το πρόγραμμα) Προαιρετικοί κανόνες  Συνήθως το όνομα τους έχει σχέση με το δεδομένο ή το ζητούμενο που εκφράζουν  Συνήθως χρησιμοποιούνται μικρά σε μέγεθος ονόματα (πχ. Μο αντί για μέσος_όρος)  Συνήθως το πρώτο γράμμα είναι κεφαλαίο και τα υπόλοιπα μικρά

19 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 19 Βασικές Έννοιες Αλγορίθμων Εντολή: Λέξη της ψευδογλώσσας ή της Γλώσσας Προγραμματισμού που προσδιορίζει μία σαφή ενέργεια.  Οι εντολές χαρακτηρίζονται ως: Δηλωτικές Εντολές (π.χ. Αλγόριθμος, Τέλος, κλπ) και Εκτελεστέες Εντολές (π.χ. Διάβασε, Γράψε, Αν, κλπ).  Κατηγοριοποιούνται σε τρεις Αλγοριθμικές Δομές.  Μία εντολή μπορεί να έχει λάθη: Συντακτικά: οφείλονται σε αναγραμματισμούς ονομάτων εντολών, παράληψη δήλωσης δεδομένων, λανθασμένη σύνταξη εντολών και πρέπει να διορθωθούν για να εκτελεστεί το πρόγραμμα. Λογικά: Είναι τα πλέον σοβαρά και δύσκολα στη διόρθωσή τους και οφείλονται σε σφάλματα κατά την υλοποίηση του αλγορίθμου.

20 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 20 Αποτελείται από ένα σύνολο εντολών που τοποθετούνται η μία κάτω από την άλλη. Χρησιμοποιείται για την επίλυση πολύ απλών προβλημάτων όπου η σειρά εκτέλεσης ενός συνόλου ενεργειών είναι δεδομένη. Στη δομή αυτή ανήκουν οι εντολές:  Εκχώρησης Τιμής  Εισόδου  Εξόδου Δομή Ακολουθίας

21 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 21 Εντολή εκχώρησης τιμής Χρησιμοποιείται για την απόδοση τιμών στις μεταβλητές, κατά τη διάρκεια εκτέλεσης του αλγορίθμου. Σύνταξη:  μεταβλητή < ─ Έκφραση Πως δουλεύει:  Πραγματοποιούνται οι πράξεις στο δεξιό τμήμα της εντολής (υπολογίζεται δηλαδή η έκφραση δεξιά της εντολής) και το αποτέλεσμα που προκύπτει (η τιμή της έκφρασης) εκχωρείται στη μεταβλητή αριστερά της εντολής. Παραδείγματα:  x < ─ y ^  Όνομα < ─ ‘Ιωάννου’  παντρεμένος < ─ αληθής Παρατηρήσεις:  Η εντολή δεν πρέπει να εκλαμβάνεται ως εξίσωση. Π.χ. η εντολή x < ─ x + 2 αυξάνει το x κατά 2  Η μεταβλητή αριστερά και η έκφραση δεξιά πρέπει να είναι του ίδιου τύπου Δομή Ακολουθίας

22 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 22 Δομή Ακολουθίας Εντολή εισόδου στη ΓΛΩΣΣΑ Για την εισαγωγή δεδομένων από το χρήστη σε μία ή περισσότερες μεταβλητές χρησιμοποιείται η εντολή ΔΙΑΒΑΣΕ Σύνταξη:  ΔΙΑΒΑΣΕ λίστα μεταβλητών που χωρίζονται με κόμμα μεταξύ τους Πως δουλεύει:  Διακόπτεται η εκτέλεση του προγράμματος και το πρόγραμμα περιμένει την εισαγωγή (από το πληκτρολόγιο) τιμών, που θα εκχωρηθούν στις μεταβλητές. Παράδειγμα:  ΔΙΑΒΑΣΕ όνομα, ηλικία  Ζητάει από το χρήστη να δώσει 2 τιμές. Η πρώτη μπαίνει στη μεταβλητή όνομα και η δεύτερη στην ηλικία

23 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 23 Εντολή εξόδου  Για την εμφάνιση των αποτελεσμάτων σε μία καθορισμένη μονάδα εξόδου αποτελεσμάτων (π.χ. Οθόνη, Εκτυπωτής, αρχείο κειμένου, βοηθητική μνήμη) η εντολή ΓΡΑΨΕ  Σύνταξη:  ΓΡΑΨΕ λίστα σταθερών, μεταβλητών(,εκφράσεων) που χωρίζονται με κόμμα μεταξύ τους  Παράδειγμα:  ΓΡΑΨΕ όνομα, ‘είσαι ’, ηλικία, ‘ετών’  Θα εμφανίσει στην καθορισμένη μονάδα εξόδου την τιμή της μεταβλητής όνομα, το σταθερό μήνυμα ‘είσαι’, την τιμή της μεταβλητής ηλικία και το σταθερό μήνυμα ‘ετών’ Δομή Ακολουθίας

24 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 24 Βασικές Έννοιες Αλγορίθμων Όλα μαζί Παράδειγμα1 : Με δεδομένη την ακτίνα ενός κύκλου, να υπολογισθεί η περίμετρος και το εμβαδόν του. ΠΡΟΓΡΑΜΜΑ Κύκλος ΣΤΑΘΕΡΕΣ π=3.14 ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: Ακτ, Εμβ, Περ ΑΡΧΗ ΔΙΑΒΑΣΕ Ακτ Περ<- 2*π*Ακτ Εμβ<- π*Ακτ^2 ΓΡΑΨΕ ‘Η Περίμετρο είναι:’, Περ, ‘. Το εμβαδό:’, Εμβ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

25 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 25 Δομή Ακολουθίας

26 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 26 Η ακολουθιακή δομή εντολών (σειριακών βημάτων) χρησιμοποιείται για την αντιμετώπιση απλών προβλημάτων, όπου είναι δεδομένη η σειρά εκτέλεσης ενός συνόλου ενεργειών. Παράδειγμα 1 : Να διαβασθούν δύο αριθμοί, να υπολογισθεί και να εκτυπωθεί το άθροισμά τους Αλγόριθμος Παράδειγμα_1 Διάβασε a, b c  a + b Εκτύπωσε c Τέλος Παράδειγμα _1 Δομή Ακολουθίας

27 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 27 Óôïí ðñïçãïýìåíï áëãüñéèìï ïé ìåôáâëçôÝò a êáé b åßíáé ôá äåäïìÝíá ðïõ áðïôåëïýí ôçí åßóïäï Η ìåôáâëçôÞ c áíôéðñïóùðåýåé ôï áðïôÝëåóìá, äçëáäÞ ôçí Ýîïäï ôïõ áëãïñßèìïõ O áëãüñéèìïò Ý÷åé áðïëýôùò êáèïñéóìÝíç ôçí êÜèå åíôïëÞ (êáèïñéóôéêüôçôá) Tåëåéþíåé ìåôÜ áðü óõãêåêñéìÝíï áñéèìü âçìÜôùí (ðåñáôüôçôá) KÜèå åíôïëÞ ôïõ åßíáé éäéáßôåñá óáöÞò êáé áðëÞ (áðïôåëåóìáôéêüôçôá) Δομή Ακολουθίας

28 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 28  Χρησιμοποιείται σε προβλήματα όπου χρειάζεται να ληφθούν κάποιες αποφάσεις με βάση κάποια δεδομένα κριτήρια.  Η διαδικασία της επιλογής περιλαμβάνει τον έλεγχο κάποιας συνθήκης με δύο δυνατές τιμές (αληθής, ψευδής) και στη συνέχεια την απόφαση εκτέλεσης κάποιας εντολής ανάλογα με τη συνθήκη.  Τη συναντάμε σε τρεις μορφές Απλή Επιλογή Σύνθετη Επιλογή Πολλαπλή Επιλογή  Εμφωλευμένες Επιλογές Δομή Επιλογής

29 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 29 Δομή Επιλογής Απλή ΑΝ  Σύνταξη: ΑΝ Συνθήκη ΤΟΤΕ Εντολή1 ….. ΤΕΛΟΣ_ΑΝ  Πως λειτουργεί: Ελέγχεται η τιμή της συνθήκης και αν αυτή ισχύει (είναι αληθής), τότε εκτελούνται οι εντολές στο τμήμα του ΤΟΤΕ (μέχρι το ΤΕΛΟΣ_ΑΝ). Αν η συνθήκη είναι ψευδής οι εντολές αυτές αγνοούνται και η εκτέλεση του προγράμματος συνεχίζεται με την εντολή που ακολουθεί τη δήλωση ΤΕΛΟΣ_ΑΝ

30 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 30 Παράδειγμα1: Να διαβαστεί ένας αριθμός και να εκτυπωθεί η απόλυτη τιμή του Αλγόριθμος Παράδειγμα_1 Διάβασε a Αν a < 0 τότε a  a*(-1) Τελος_Αν Εκτύπωσε a Τέλος Παράδειγμα _1 Δομή Επιλογής

31 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 31 Δομή Επιλογής Σύνθετη ΑΝ  Σύνταξη: ΑΝ Συνθήκη ΤΟΤΕ Εντολή1 ….. ΑΛΛΙΩΣ Εντολή2 ….. ΤΕΛΟΣ_ΑΝ  Πως δουλεύει:  Ελέγχεται η τιμή της συνθήκης και αν αυτή ισχύει (είναι αληθής), τότε εκτελούνται οι εντολές στο τμήμα του ΤΟΤΕ (μέχρι το ΑΛΛΙΩΣ). Αν η συνθήκη είναι ψευδής οι εντολές αυτές αγνοούνται και εκτελούνται οι εντολές στο τμήμα του ΑΛΛΙΩΣ (μέχρι το ΤΕΛΟΣ_ΑΝ). Σε κάθε περίπτωση λοιπόν εκτελείται μόνο το ένα τμήμα εντολών και η εκτέλεση του προγράμματος συνεχίζεται με την εντολή που ακολουθεί τη δήλωση ΤΕΛΟΣ_ΑΝ

32 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 32 Παράδειγμα 2: Να διαβασθούν δύο αριθμοί και σε περίπτωση που ο πρώτος αριθμός είναι μικρότερος του δεύτερου, να υπολογισθεί και να εκτυπωθεί το άθροισμά τους, διαφορετικά να υπολογισθεί και να εκτυπωθεί το γινόμενό τους Αλγόριθμος Παράδειγμα_3 Διάβασε a, b Αν a < b τότε c  a + b αλλιώς c  a * b τέλος_αν Εκτύπωσε c Τέλος Παράδειγμα _3 Δομή Επιλογής

33 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 33 Δομή Επιλογής Πολλαπλή Επιλογή  Οι διαδικασίες των πολλαπλών επιλογών χρησιμοποιούνται στα προβλήματα όπου μπορεί να ληφθούν διαφορετικές αποφάσεις ανάλογα με την τιμή που παίρνει μία μεταβλητή ΑΝ Συνθήκη1 ΤΟΤΕ Εντολές1 ΑΛΛΙΩΣ_ΑΝ Συνθήκη2 ΤΟΤΕ Εντολές2 … ΑΛΛΙΩΣ ΕντολέςΚ ΤΕΛΟΣ_ΑΝ  Πως δουλεύει:  Σε περίπτωση που η πρώτη συνθήκη ισχύει εκτελείται το τμήμα εντολών του δικού της ΤΟΤΕ. Διαφορετικά (αν δεν ισχύει) ελέγχεται η επόμενη συνθήκη (που βρίσκεται στο ΑΛΛΙΩΣ_ΑΝ), κοκ. Αν καμία συνθήκη δεν είναι αληθής εκτελούνται οι εντολές στο τελευταίο τμήμα ΑΛΛΙΩΣ.

34 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 34 Παράδειγμα 3: Να διαβασθεί ένας ακέραιος και να εκτυπωθεί το αντίστοιχο γράμμα της αλφαβήτου αν ο ακέραιος έχει τιμή 1 ή 2 ή 3 διαφορετικά να εκτυπωθεί η λέξη “άγνωστος”. Δομή Επιλογής Αλγόριθμος Παράδ_3 Διάβασε a Αν a = 1 τότε εκτύπωσε ‘Α’ αλλιώς_Αν a = 2 τότε εκτύπωσε ‘Β’ αλλιώς_Αν a = 3 τότε εκτύπωσε ‘Γ’ αλλιώς εκτύπωσε “άγνωστος” Τέλος_αν Τέλος Παράδ _3

35 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 35 Δομή Επιλογής Εναλλακτικά την πολλαπλή επιλογή ορισμένες φορές, μπορούμε να την εκφράσουμε με την εντολή ΕΠΙΛΕΞΕ Επίλεξε έκφραση Περίπτωση Λίστα_Τιμών_1 Εντολές1 Περίπτωση Λίστα_Τιμών_2 Εντολές2 Περίπτωση Αλλιώς Εντολέςn Τέλος_επιλογών  Πως δουλεύει  Σε μία εντολή ΕΠΙΛΕΞΕ κάθε φορά εκτελείται ένα από τα σύνολα εντολών κατά περίπτωση. Ανάλογα με την τιμή της έκφρασης εκτελούνται οι εντολές μετά την Περίπτωση που αντιστοιχεί στην τιμή της έκφρασης Η μοναδική περίπτωση στην οποία δεν εκτελείται κανένα σύνολο εντολών είναι να μην επιβεβαιώνεται καμία λίστα τιμών και να μην υπάρχει καθόλου το τμήμα ΠΕΡΙΠΤΩΣΗ ΑΛΛΙΩΣ. Το τμήμα ΠΕΡΙΠΤΩΣΗ ΑΛΛΙΩΣ ερμηνεύεται ως σε κάθε άλλη περίπτωση. Παρατηρήσεις  Η έκφραση μπορεί να είναι οποιαδήποτε σωστά οριζόμενη έκφραση πχ (x^2+4*y)  Η λίστα τιμών μπορεί να είναι μία απλή σταθερά ή μεταβλητή (π.χ. 5, 100, a) ή μία ανισότητα (π.χ. >=30, <200), ή ένα εύρος τιμών από έως, (π.χ. από 1 έως 10), ή μία συνθήκη.  Σε περίπτωση που η έκφραση επιβεβαιώνει τη λίστα τιμών εκτελείται το αντίστοιχο σύνολο εντολών.

36 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 36 Δομή Επιλογής Παράδειγμα: Να δίνεται ένας αριθμός και να εμφανίζει αν είναι 0, μονοψήφιος άρτιος ή μονοψήφιος περιττός. … ΔΙΑΒΑΣΕ αριθμός ΕΠΙΛΕΞΕ αριθμός ΠΕΡΙΠΤΩΣΗ 0 ΓΡΑΨΕ ‘Μηδέν’ ΠΕΡΙΠΤΩΣΗ 1,3,5,7,9 ΓΡΑΨΕ ‘Μονός αριθμός’ ΠΕΡΙΠΤΩΣΗ 2,4,6,8 ΓΡΑΨΕ ‘ Ζυγός αριθμός‘ ΠΕΡΙΠΤΩΣΗ ΑΛΛΙΩΣ ΓΡΑΨΕ ‘αριθμός 9 ή όχι ακέραιος’ ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ …

37 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 37 6 ““ ““ “ “ “ “ Δομή Επιλογής Εμφωλευμένη Επιλογή

38 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 38 Δομή Επιλογής

39 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 39 Δομή Επιλογής Συνθήκη: είναι μία λογική Έκφραση. Το αποτέλεσμα μίας συγκριτικής ή λογικής πράξης. Μπορεί να πάρει δύο μόνο τιμές: Αληθής, Ψευδής. Η απλή συνθήκη προκύπτει ως αποτέλεσμα της επίδρασης ενός συγκριτικού τελεστή σε δύο εκφράσεις ίδιου τύπου. Για παράδειγμα (α+5)^2 > 5-β/2+10 Η σύνθετη συνθήκη προκύπτει ως αποτέλεσμα της επίδρασης ενός λογικού τελεστή σε μία (αν πρόκειται για την Άρνηση) ή δύο άλλες λογικές εκφράσεις (απλές ή σύνθετες). Για παράδειγμα ΟΧΙ( χ>5 ΚΑΙ χ<=10).

40 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 40 Δομή Επιλογής Ο πίνακας ορισμού των τριών λογικών πράξεων είναι ο παρακάτω Όταν συνδυάζονται διαφορετικές πράξεις, εκτελούνται πρώτα οι αριθμητικές, ύστερα οι συγκριτικές και τελευταίες οι λογικές.

41 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 41 Δομή Επιλογής Εμφωλευμένη - Πολλαπλή ΔΙΑΒΑΣΕ Βάρος, Ύψος ΑΝ Βάρος < 80 ΤΟΤΕ ΑΝ Ύψος < 1.70 ΤΟΤΕ ΓΡΑΨΕ ‘Ελαφρύς, κοντός’ ΤΕΛΟΣ_ΑΝ ΔΙΑΒΑΣΕ Βάρος, Ύψος ΑΝ Βάρος < 80 ΚΑΙ Ύψος < 1.70 ΤΟΤΕ ΓΡΑΨΕ ‘Ελαφρύς, κοντός’ ΤΕΛΟΣ_ΑΝ

42 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 42 Δομή Επιλογής

43 Επιμόρφωση Εκπαιδευτικών Πληροφορικής | Ενότητα 4η (Δομημένος Προγραμματισμός) | Μέρος Α (Επικαιροποίηση Γνώσεων) 43 Με χρήση εμφωλευμένων ΑΝ ΑΝ Ποσότητα=<50 ΤΟΤΕ Κόστος  Ποσότητα * ΑΛΛΙΩΣ ΑΝ Ποσότητα =< 100 ΤΟΤΕ Κόστος  Ποσότητα * ΑΛΛΙΩΣ ΑΝ Ποσότητα =< 200 ΤΟΤΕ Κόστος  Ποσότητα * ΑΛΛΙΩΣ Κόστος  Ποσότητα * ΤΕΛΟΣ_ΑΝ Με χρήση Πολλαπλού ΑΝ ΑΝ Ποσότητα =<50 ΤΟΤΕ Κόστος  Ποσότητα * ΑΛΛΙΩΣ_ΑΝ Ποσότητα =<100 ΤΟΤΕ Κόστος  Ποσότητα * ΑΛΛΙΩΣ_ΑΝ Ποσότητα =<200 ΤΟΤΕ Κόστος  Ποσότητα * ΑΛΛΙΩΣ Κόστος  Ποσότητα * ΤΕΛΟΣ_ΑΝ Δομή Επιλογής


Κατέβασμα ppt "Ενότητα Α.4. Δομημένος Προγραμματισμός Επιμόρφωση Εκπαιδευτικών Πληροφορικής."

Παρόμοιες παρουσιάσεις


Διαφημίσεις Google