Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Λυμένες ασκήσεις με δομές επανάληψης και επιλογής Εισαγωγή στην επιστήμη των Η/Υ της Β’ ΓενικούΛυκείου.

Παρόμοιες παρουσιάσεις


Παρουσίαση με θέμα: "Λυμένες ασκήσεις με δομές επανάληψης και επιλογής Εισαγωγή στην επιστήμη των Η/Υ της Β’ ΓενικούΛυκείου."— Μεταγράφημα παρουσίασης:

1 Λυμένες ασκήσεις με δομές επανάληψης και επιλογής Εισαγωγή στην επιστήμη των Η/Υ της Β’ ΓενικούΛυκείου

2 Σε μια εξέταση ξένης γλώσσας 400 υποψήφιοι εξετάζονται προφορικά και γραπτά και βαθμολογούνται από το 1 έως το 100 σε κάθε εξέταση. Να αναπτύξετε αλγόριθμο ο οποίος: 1. Να διαβάζει την προφορική και τη γραπτή βαθμολογία κάθε υποψηφίου. 2. Να εμφανίζει στη συνέχεια το μήνυμα «Η προφορική βαθμολογία είναι μεγαλύτερη από τη γραπτή», στην περίπτωση που αυτό συμβαίνει. 3. Να εμφανίζει στο τέλος, το μέσο όρο της γραπτής βαθμολογίας όλων των υποψηφίων. Αλγόριθμος εξεταση συνολο<-0 Για ι από 1 μέχρι 400 Διάβασε προφ,γραπ Αν προφ > γραπ τότε Εμφάνισε "προφορικη μεγαλύτερη" Τέλος_αν συνολο<-συνολο+γραπ Τέλος_επανάληψης μο<- συνολο/400 Εμφάνισε μο Τέλος εξεταση Στη μεταβλητή συνολο θα μπει το άθροισμα όλων των βαθμών. ΠΡΕΠΕΙ να έχει αρχική τιμή που να μην επηρεάζει το συνολικό αποτέλεσμα Οι εντολές που υπάρχουν ΜΕΣΑ στην ΓΙΑ Τέλος_επανάληψης θα εκτελεστούν 400 φορές Ο χρήστης πληκτρολογεί ΔΥΟ τιμές, που αποθηκεύονται στις μεταβλητές που ονομάσαμε προφ και γραπ αντίστοιχα Αν η συνθήκη προφ > γραπ είναι αληθής, δηλαδή τιμή που είναι αποθηκευμένη στη μετ/τή προφ είναι μεγαλύτερη από αυτή της γραπ, εκτελούνται οι εντολές που είναι μέσα στο Αν Τέλος_αν. Εδώ είναι μόνο μία. Αλλιώς συνεχίζει μετά το Τέλος_αν Η τρέχουσα τιμή προστίθεται στο Άθροισμα Υπολογίζεται ο μέσος όρος, αποθηκεύεται στη μεταβλητή μο, της οποίας το περιεχόμενο εμφανίζεται με την επόμενη εντολή στην οθόνη του χρήστη

3 Για τους 26 μαθητές μιας τάξης να γραφεί αλγόριθμος ο οποίος: 1. Να εισάγει από το πληκτρολόγιο επαναληπτικά το γενικό βαθμό κάθε μαθητή 2. Να εμφανίζει μήνυμα αν ο μαθητής περνάει (βαθμός πάνω από 9,5) την τάξη ή όχι. 3. Να υπολογίζει και να εμφανίζει στο τέλος το μέσο όρο των βαθμών της τάξης. Αλγόριθμος προαγωγη συνολο = 9,5 τότε Εμφάνισε "προάγεται" αλλιώς Εμφάνισε "απορρίπτεται" Τέλος_αν συνολο<- συνολο+βαθ Τέλος_επανάληψης μεσος_ορος<- συνολο/26 Εμφάνισε μεσος_ορος Τέλος προαγωγή Συνθήκη Αν η συνθήκη είναι αληθής, εκτελούνται οι εντολές μεταξύ Αν......αλλιώς. Αν είναι ψευδής - δηλαδή αν η αποθηκευμένη τιμή στη μεταβλητή βαθ είναι μικρότερη από 9,5- εκτελούνται οι εντολές μεταξύ αλλιώς τελος_αν

4 Στο πληροφοριακό σύστημα ενός βιβλιοπωλείου για 1200 βιβλία που διαθέτει καταχωρούνται για κάθε βιβλίο, η χώρα και η τιμή του βιβλίου. Να γραφεί αλγόριθμος ο οποίος: 1. Για κάθε βιβλίο διαβάζει τα παραπάνω δεδομένα. 2. Για κάθε βιβλίο, αν η χώρα είναι «ΕΛΛΑΔΑ» εμφανίζει το μήνυμα «ελληνικό». Αλλιώς το μήνυμα «ξένο» 3. Εμφανίζει το μέσο όρο τιμής των ελληνικών βιβλίων (χώρα “ΕΛΛΑΔΑ”). Αλγόριθμος βιβλια συν_ελλην<-0 πληθ_ελλην<-0 Για κ από 1 μέχρι 1200 Διάβασε χωρ,τιμ Αν χωρ="ΕΛΛΑΔΑ" τότε Εμφάνισε "ελληνικό" συν_ελλην<- συν_ελλην + τιμ πληθ_ελλην<-πληθ_ελλην+ 1 αλλιώς Εμφάνισε "ξένο" Τέλος_αν Τέλος_επανάληψης μεσ_ορ<- συν_ελλην/πληθ_ελλην Εμφάνισε μεσ_ορ Τέλος βιβλια Αθροισμα τιμών ελληνικών βιβλίων Μετρητής πλήθους ελληνικών βιβλίων Μόνο αν η συνθήκη χωρ=“ΕΛΛΑΔΑ” είναι αληθής, δηλαδή στη μεταβλητή χωρ έχει δοθεί από το χρήστη η τιμή ΕΛΛΑΔΑ, εμφανίζεται το μήνυμα “ελληνικό”, προστίθεται η τιμή που έχει δώσει στη μετ/τή τιμ στο άθροισμα και αυξάνεται ο μετρητής κατά ένα (Οι 3 Εντολές μεταξύ Αν τότε και αλλιώς ) Αν η συνθήκη είναι ψευδής, εκτελούνται οι εντολές μεταξύ αλλιώς.....Τέλος_αν – έχει μόνο μια: Την Εμφάνισε “ξένο”

5 Οι 70 μαθητές της Γ’ γυμνασίου έγραψαν διαγώνίσματα φυσική και πληροφορική. Να γραφεί αλγόριθμος ο οποίος: 1. Για κάθε μαθητή θα διβάζει τους δύο αυτούς βαθμούς 2. Αν αυτός έγραψε καλύτερα στη φυσική, θα εμφανίζει το μήνυμα «καλύτερα στη φυσική» 3. Θα εμφανίζει το πλήθος των μαθητών που έγραψαν 20 στην πληροφορική Αλγόριθμος εικοσαρια πληθος<-0 Για α από 1 μέχρι 70 Διάβασε φυσ,πληρ Αν φυσ>πληρ τότε Εμφάνισε "καλύτερα στη φυσική" Τέλος_αν Αν πληρ=20 τότε πληθος<-πληθος+1 Τέλος_αν Τέλος_επανάληψης Εμφάνισε πληθος Τέλος εικοσαρια Αν η τιμή που έδωσε ο χρήστης στη μεταβλητή πληρ είναι 20, αύξησε την τιμή της μετ/τής πλήθος κατά ένα Για να μετράμε τα 20άρια που έδωσε ο χρήστης στην μετ/τή πληρ

6 Το υπουργείο περιβάλλοντος έχει εγκαταστήσει 200 σταθμούς μέτρησης του O3 σε διάφορα σημεία της χώρας. Να αναπτύξετε αλγόριθμο ο οποίος: 1. Να διαβάζει την αριθμητική τιμή του O3 για κάθε σταθμού μέτρησης 2. Να εμφανίζει το μήνυμα «αυξημένοι» αν ο σταθμός έχει ένδειξη μεγαλύτερη από Να εμφανίζει τη μέση τιμή του ρύπου στους σταθμούς με ένδειξη π’ανω από 500. Αλγόριθμος ρυποι αθρ_ρυπ 500 τότε Εμφάνισε "αυξημένοι" αθρ_ρυπ<- αθρ_ρυπ+ο3 πληθ_σταθ<- πληθ_σταθ+1 Τέλος_αν Τέλος_επανάληψης μο <- αθρ_ρυπ/πληθ_σταθ Εμφάνισε μο Τέλος ρυποι Υπολογίζουμε το πηλίκο του αθροίσματος των τιμών ρύπων που ήταν πάνω από 500, δια το πλήθους τους και το εκχωρούμε στη μεταβλητή μο

7 Στο Μαραθώνιο της Αθήνας τρέχουν δρομείς από διάφορες χώρες του κόσμου. Να αναπτύξετε αλγόριθμο ο οποίος: 1. Για κάθε αθλητή να διαβάζει τη χώρα προέλευσης και τον χρόνο που έκανε. 2. Εμφανίζει πόσοι Έλληνες δρομείς αγωνίστηκαν (η χώρα είναι «ΕΛΛΑΔΑ». 3. Εμφανίζει τον μικρότερο χρόνο που επιτεύχθηκε και τη χώρα του αθλητή που τον πέτυχε. Αλγόριθμος δρομεις ελλ_αθλ<- 0 μικρ_χρονος< χωρα_μικ_χρον<- “τιποτα" Για α από 1 μέχρι Διάβασε χωρ, χρον Αν χωρ = "ΕΛΛΑΔΑ" τότε ελλ_αθλ<- ελλ_αθλ + 1 Τέλος_αν Αν χρον ≤ μικρ_χρονος τότε μικρ_χρονος<- χρον χωρα_μικ_χρον<- χωρ Τέλος_αν Τέλος_επανάληψης Εμφάνισε ελλ_αθλ, μικρ_χρονος, χωρα_μικ_χρον Τέλος δρομεις Αρχικοποιούμε τις μεταβλητές όπου θα αποθηκεύσουμε το μικρότερο χρόνο με ΑΠΙΘΑΝΑ μεγάλη τιμή και τη χώρα του αθλητή που τον πέτυχε με τιμή που δεν υπάρχει στην πραγματικότητα Αν η τρέχουσα τιμή χρόνου που διαβάστηκε στη ματαβλητή χρον είναι μικρότερη από την προηγούμενη, αποθηκεύουμε αυτή στη μεταβλητή μικρ_χρον και την χωρα –που έχει διαβαστεί στη μετ/τή χωρ στη χωρα_μικ_χρον

8 ΣτηνΕθνική οδό είναι εγκατεστημένο ένα ειδικό σύστημα το οποίο μετράει την ταχύτητα των διερχόμενων οχημάτων. Το όριο ταχύτητας είναι 100 km/h. Να γράψετε αλγόριθμο ο οποίος για 500 οχήματα: 1. Να διαβάζει τον αριθμό πινακίδας και την ταχύτητα κάθε οχήματος. 2. Να εμφανίζει το πλήθος των οχημάτων που ξεπέρασαν το όριο ταχύτητας. 3. Να εμφανίζει την υψηλότερη ταχύτητα που πέρασε κάποιος και τον αριθμό της πινακίδας του Αλγόριθμος αυτοκινητοδρομος πληθ_υπερβ 100 τότε πληθ_υπερβ μεγ_ταχ τότε μεγ_ταχ<- ταχ αριθ_μεγ_ταχ<- αριθ Τέλος_αν Τέλος_επανάληψης Εμφάνισε πληθ_υπερβ, μεγ_ταχ, αριθ_μεγ_ταχ Τέλος αυτοκινητοδρομος Αρχικοποιούμε τις μεταβλητές όπου θα αποθηκεύσουμε τη μεγαλύτερη ταχύτητα με ΑΠΙΘΑΝΑ μικρή τιμή και τη χώρα του αθλητή που τον πέτυχε με μια που δεν υπάρχει περίπτωση να υπάρξει Αν η τρέχουσα τιμή ταχύτητας που διαβάστηκε στη ματαβλητή ταχ είναι μικρότερη από την προηγούμενη, αποθηκεύουμε αυτή στη μεταβλητή μεγ_ταχ και τον αριθμό –που έχει διαβαστεί στη μετ/τή αριθ- στην αριθ_μεγ_ταχ


Κατέβασμα ppt "Λυμένες ασκήσεις με δομές επανάληψης και επιλογής Εισαγωγή στην επιστήμη των Η/Υ της Β’ ΓενικούΛυκείου."

Παρόμοιες παρουσιάσεις


Διαφημίσεις Google