Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

ΑΕΠΠ 2ο Κεφάλαιο Γεωργαλλίδης Δημήτρης Καθηγητής Πληροφορικής 1 Ο Λύκειο Ρόδου.

Παρόμοιες παρουσιάσεις


Παρουσίαση με θέμα: "ΑΕΠΠ 2ο Κεφάλαιο Γεωργαλλίδης Δημήτρης Καθηγητής Πληροφορικής 1 Ο Λύκειο Ρόδου."— Μεταγράφημα παρουσίασης:

1 ΑΕΠΠ 2ο Κεφάλαιο Γεωργαλλίδης Δημήτρης Καθηγητής Πληροφορικής 1 Ο Λύκειο Ρόδου

2 ΔΟΜΕΣ ΕΠΑΝΑΛΗΨΗΣ 1. Όσο …επανάλαβε 2. Αρχή Επανάληψης …Μέχρις_ότου … 1. Για … από …. μέχρι…….

3 1. Όσο…. Όσο επανάλαβε εντολή 1 εντολή 2 εντολή 3 ……Τέλος_επανάληψης

4 Παράδειγμα Όσο Να γραφτεί αλγόριθμος που να εμφανίζει τους αριθμούς 1 έως 100

5 Παράδειγμα Όσο Αλγόριθμος αριθμοί Χ 1 Χ ← 1 Όσο Χ<=100 επανάλαβε Εμφάνισε Χ Χ Χ+1 Χ ← Χ+1Τέλος_επανάληψης Τέλος αριθμοί Να γραφτεί αλγόριθμος που να εμφανίζει τους αριθμούς 1 έως 100 Χ ← Χ+1 ΑΡΧΗ ΤΕΛΟΣ Εμφάνισε Χ Χ<=100 ΝΑΙ ΟΧΙ Χ ← 1

6 ΠΑΡΑΛΛΑΓΕΣ 1. Να γραφτεί αλγόριθμος που να εμφανίζει τους αριθμούς 100 έως 1 2. Να γραφτεί αλγόριθμος που να εμφανίζει τους άρτιους αριθμούς 2 έως 100

7 Παράδειγμα Όσο Ποια θα είναι η τελευταία τιμή της μεταβλητής Χ; Τι θα γινόταν αν: 1. Παραλείπαμε την Χ 1 1. Παραλείπαμε την Χ ← 1 2. Βάζαμε τη συνθήκη Χ< Χρησιμοποιούσαμε την Χ Χ+2 αντί της Χ Χ+1 3. Χρησιμοποιούσαμε την Χ ← Χ+2 αντί της Χ ← Χ+1 4. Αλλάζαμε τη σειρά εκτέλεσης των εντολών του βρόχου;

8 Παράδειγμα Όσο με χρήση μετρητή 1. Να γραφτεί αλγόριθμος που να διαβάζει 10 αριθμούς και να τους εμφανίζει 2. Να γραφτεί αλγόριθμος που να διαβάζει 10 αριθμούς και να εμφανίζει μόνο όσους είναι μεγαλύτεροι του μηδέν.

9 Παράδειγμα Όσο με χρήση μετρητή Αλγόριθμος αριθμοί i 1 i ← 1 Όσο i<=10 επανάλαβε Διάβασε Χ Εμφάνισε Χ i i + 1 i ← i + 1Τέλος_επανάληψης Τέλος αριθμοί Να γραφτεί αλγόριθμος που να διαβάζει 10 αριθμούς και να τους εμφανίζει

10 Παράδειγμα Όσο με χρήση «τιμή φρουρός»  Να γραφτεί αλγόριθμος ο οποίος να διαβάζει τους αριθμούς που πληκτρολογεί ένας χρήστης και να υπολογίζει: 1. Το πλήθος τους (μετρητής) 2. Το άθροισμά τους. (αθροιστής)  Η εισαγωγή των αριθμών θα σταματάει αν ο χρήστης εισάγει το 0.

11 Άσκηση Όσο Αλγόριθμος παράδειγμα_όσο Διάβασε Χ πλήθος 0 πλήθος ← 0 άθροισμα 0 άθροισμα ← 0 Όσο Χ<>0 επανάλαβε πλήθος πλήθος + 1 πλήθος ← πλήθος + 1 άθροισμα άθροισμα + Χ άθροισμα ← άθροισμα + Χ Διάβασε Χ Τέλος_επανάληψης Εμφάνισε πλήθος, άθροισμα Τέλος παράδειγμα_όσο

12 Άσκηση Όσο Δοκιμάστε τον αλγόριθμο: 1. Παραλείποντας την άθροισμα 0 1. Παραλείποντας την άθροισμα ← 0 2. Παραλείποντας τη Διάβασε Χ 3. Βάζοντας την Εμφάνισε άθροισμα μέσα στην επανάληψη 4. Αλλάζοντας τη σειρά εκτέλεσης των εντολών του βρόχου. Τι παρατηρείτε σε κάθε περίπτωση;

13 Για το σπίτι: Τετράδιο Μαθητή  7, 8, 9,10, σελ. 62, 63


Κατέβασμα ppt "ΑΕΠΠ 2ο Κεφάλαιο Γεωργαλλίδης Δημήτρης Καθηγητής Πληροφορικής 1 Ο Λύκειο Ρόδου."

Παρόμοιες παρουσιάσεις


Διαφημίσεις Google