Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Σημειώσεις : Χρήστος Μουρατίδης Κάντε κλικ για έναρξη…

Παρόμοιες παρουσιάσεις


Παρουσίαση με θέμα: "Σημειώσεις : Χρήστος Μουρατίδης Κάντε κλικ για έναρξη…"— Μεταγράφημα παρουσίασης:

1 Σημειώσεις : Χρήστος Μουρατίδης Κάντε κλικ για έναρξη…

2 Η χελώνα της Logo Η χελώνα στη σελίδα Η χελώνα μετακινείται και σχεδιάζει Πατώντας το εικονίδιο «Δημιουργία χελώνας» και κάνοντας κλικ στη σελίδα εμφανίζεται η χελώνα

3 Εντολές κίνησης της χελώνας Μπροστά (μπ) x Κινείται μπροστά κατά x pixels Π.χ. μπ 20 Πίσω (πι) x Κινείται πίσω κατά x pixels Π.χ. πι 20 Δεξιά (δε) y Στρίβει δεξιά κατά y μοίρες Π.χ. δε 20 Αριστερά (αρ) y Στρίβει αριστερά κατά y μοίρες Π.χ. αρ 20 Σε παρένθεση είναι η συντόμευση της εντολής. Να έχετε υπόψη ότι μπορείτε να δώσετε τις εντολές χωρίς τόνους και με μικρά γράμματα Π.χ. μπροστα x Όμως, προτιμούμε τη συντόμευση μπ x

4 Εντολές γραφικών της χελώνας Στυλόκάτω (στκ) Όταν κινείται η χελώνα θα σχεδιάζει Π.χ. στκ Στυλόάνω (στα) Όταν κινείται η χελώνα δεν θα σχεδιάζει Π.χ. στα ΣβήσεΓραφικά (σβγ) Σβήνει τα γραφικά της σελίδας κι επαναφέρει τη χελώνα στο κέντρο Π.χ σβγ Σε παρένθεση είναι η συντόμευση της εντολής Να έχετε υπόψη ότι μπορείτε να δώσετε τις εντολές και χωρίς τόνους και με μικρά γράμματα Π.χ. μπροστά x Όμως, προτιμούμε τη συντόμευση μπ x

5 Παράδειγμα 1 : Σχεδίαση τετραγώνου στκ μπ 100 δε 90 μπ 100 δε 90 μπ 100 δε 90 μπ 100 δε 90 Σχεδιάζει τετράγωνο με πλευρά 100 pixels Tip : Τί θα γίνει αν δώσουμε πρώτα μία κλίση στη χελώνα με την εντολή δε 45 ;

6 Παράδειγμα 2 : Σχεδίαση σκάλας στκ μπ 50 δε 90 μπ 50 αρ 90 μπ 50 δε 90 μπ 50 αρ 90 μπ 50 δε 90 μπ 50 Σχεδιάζει σκάλα με πλάτος και ύψος 50 pixels στκ μπ 50 δε 90 μπ 50 αρ 90 μπ 50 δε 90 μπ 50 αρ 90 μπ 50 δε 90 μπ 50 Το ίδιο αποτέλεσμα δίνει. Μπορούμε να βάλουμε πολλές εντολές σε μία γραμμή

7 Εντολή επανάληψης επανάλαβε Δείτε το παράδειγμα 1. Παρατηρείτε ότι οι εντολές μπ 100 δε 90 επαναλαμβάνονται 4 φορές; Στην περίπτωση αυτή μπορούμε να χρησιμοποιήσουμε την εντολή επανάλαβε, όπου λέει στον υπολογιστή να επαναλάβει μία ομάδα εντολών όσες φορές θέλουμε. στκ μπ 100 δε 90 μπ 100 δε 90 μπ 100 δε 90 μπ 100 δε 90 Σχεδιάζει τετράγωνο με πλευρά 100 pixels στκ επανάλαβε 4 [μπ 100 δε 90] Έχει το ίδιο αποτέλεσμα! γράφεται Η εντολή επανάλαβε έχει την εξής μορφή : επανάλαβε αριθμός_επαναλήψεων [εντολές] Η εντολή επανάλαβε έχει την εξής μορφή : επανάλαβε αριθμός_επαναλήψεων [εντολές]

8 Σχεδίαση πολυγωνικών σχημάτων Για σχεδίαση πολυγωνικού σχήματος (τριγώνου, τετραγώνου, πενταγώνου κ.ο.κ..) θα πρέπει η χελώνα να στρίβει σωστά. Για να υπολογίσουμε πόσες μοίρες θα στρίβει ακολουθούμε την εξής σκέψη : Σχήμα με ν πλευρές Η χελώνα πρέπει να στρίβει κατά 360 / ν μοίρες ( π.χ. για εξάγωνο ν=6, η χελώνα πρέπει να στρίβει 360 / 6 = 60 μοίρες) Η χελώνα πρέπει να στρίβει κατά 360 / ν μοίρες ( π.χ. για εξάγωνο ν=6, η χελώνα πρέπει να στρίβει 360 / 6 = 60 μοίρες) στκ επανάλαβε 6 [μπ 50 δε 60] Σχεδιάζει εξάγωνο με πλευρά 50 pixels. Μετά από κάθε βήμα η χελώνα στρίβει δεξιά κατά 360 / 6 = 60 μοίρες. Αν πριν την επανάλαβε είχαμε δώσει δε 30, η χελώνα πριν ξεκινήσει θα έπαιρνε μία ελαφρά κλίση.

9 Παράδειγμα 3 : Σχεδίαση οκταγώνου με μήκος πλευράς που δίνει ο χρήστης Στο παράδειγμα αυτό θα σχεδιάσουμε ένα οκτάγωνο (ν=8) όπου το μήκος της κάθε πλευράς θα είναι παραμετρικό, δηλαδή θα καθορίζεται από την τιμή που θα δίνει ο χρήστης. σβγ στκ ερώτηση [Δώσε το μήκος της πλευράς του οκταγώνου] κάνε "μήκος απάντηση επανάλαβε 8 [μπ :μήκος δε 360 / 8] Σχεδιάζει οκτάγωνο με πλευρά παραμετρική (την τιμή θα την εισάγει ο χρήστης με την εντολή ερώτηση). Την τιμή (απάντηση) που δίνει χρήστης την αποθηκεύουμε σε μία μεταβλητή με όνομα «μήκος» και την χρησιμοποιούμε στην επανάλαβε. Εδώ ο χρήστης έδωσε για το μήκος πλευράς τιμή 100 Tip : Μπορείτε να κάνετε παραμετρική και τη γωνία κλίσης;

10 Παράδειγμα 4 : Σύνθετο σχήμα σβγ στκ κάνε "α 1 επανάλαβε 9 [κάνε "α :α + 10 επανάλαβε 4 [μπ :α δε 90]] Σχεδιάζει 9 φορές ένα τετράγωνο αλλά η πλευρά κάθε φορά αυξάνεται κατά 10 pixels. Αυτό καθορίζεται στη μεταβλητή α. Σε κάθε επανάληψη η τιμή της πλευράς α αυξάνεται κατά 10 και σχεδιάζεται το αντίστοιχο τετράγωνο. Οι τιμές της πλευράς a σε κάθε επανάληψη είναι : 11, 21, 31 κ.ο.κ.

11 Ασκήσεις Δώστε τις εντολές να σχεδιάσει η χελώνα το παρακάτω σχήμα : (Βάλτε ό,τι μήκος θέλετε στις γραμμές). Δώστε τις εντολές να σχεδιάσει η χελώνα το παρακάτω σχήμα : (Βάλτε ό,τι μήκος θέλετε στις γραμμές. Θα χρειαστείτε την εντολή στα για να πάει δίπλα χωρίς να σχεδιάσει). Δώστε τις εντολές να σχεδιάσει η χελώνα το παρακάτω σχήμα :

12 Ασκήσεις Πώς θα καθοδηγήσετε τη Logo να εμφανίσει το όνομά σας 200 φορές; Δώστε την εντολή να σχεδιαστεί ένα πεντάγωνο. Γράψτε ένα πρόγραμμα όπου ο χρήστης θα δίνει το μήκος μίας γραμμής και η χελώνα της Logo θα τη σχεδιάζει. Δώστε τις εντολές να σχεδιάσει η χελώνα το παρακάτω σχήμα : ( Πρόκειται για ακτίνες. Καθορίστε μήκος ακτίνας 50 pixels και γωνία κλίσης 30 μοίρες) Τροποποιήστε το παραπάνω ώστε ο χρήστης να δίνει τη γωνία κλίσης Δώστε τις εντολές όπου η χελώνα θα σχεδιάσει τα γράμματα Τ και Κ. Το ύψος των γραμμάτων θα το δίνει ο χρήστης.


Κατέβασμα ppt "Σημειώσεις : Χρήστος Μουρατίδης Κάντε κλικ για έναρξη…"

Παρόμοιες παρουσιάσεις


Διαφημίσεις Google