0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών">

Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

1 Η ΓΙΑ ΚΑΙ Η ΛΕΙΤΟΥΡΓΙΑ ΤΗΣ Η δομή Για περιέχει 3 τμήματα (εντολές) που εκτελούνται αυτόματα(εσωτερικά στη Για) Για i από 1 μέχρι 100 i ← 1 i <= 100 i.

Παρόμοιες παρουσιάσεις


Παρουσίαση με θέμα: "1 Η ΓΙΑ ΚΑΙ Η ΛΕΙΤΟΥΡΓΙΑ ΤΗΣ Η δομή Για περιέχει 3 τμήματα (εντολές) που εκτελούνται αυτόματα(εσωτερικά στη Για) Για i από 1 μέχρι 100 i ← 1 i <= 100 i."— Μεταγράφημα παρουσίασης:

1 1 Η ΓΙΑ ΚΑΙ Η ΛΕΙΤΟΥΡΓΙΑ ΤΗΣ Η δομή Για περιέχει 3 τμήματα (εντολές) που εκτελούνται αυτόματα(εσωτερικά στη Για) Για i από 1 μέχρι 100 i ← 1 i <= 100 i ← i + 1 με_βήμα 1

2 2 Αρχή i ← 1 θετικοί ← 0 Τέλος Εκτύπωσε θετικοί ΝΑΙ θετικοί ← θετικοί + 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ i ← i + 1 α > 0 Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών Πλήθος θετικών από 100 αριθμούς – Δ.Ρ. ` Μαυρο κουτί

3 3 Πλήθος θετικών από 100 αριθμούς – Δ.Ρ. ΝΑΙ Αρχή θετικοί ← θετικοί + 1 i ← 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ θετικοί ← 0 i ← i + 1 Τέλος Εκτύπωσε θετικοί α > 0 Για το "Τέλος_επανάληψης", το βέλος γυρίζει πίσω. Έτσι, δηλώνεται επανάληψη Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών

4 4 Ροή εκτέλεσης αλγορίθμου ΝΑΙ Αρχή θετικοί ← θετικοί + 1 i ← 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ θετικοί ← 0 i ← i + 1 Τέλος Εκτύπωσε θετικοί α > 0 Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών

5 5 Ροή εκτέλεσης αλγορίθμου ΝΑΙ Αρχή θετικοί ← θετικοί + 1 i ← 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ θετικοί ← 0 i ← i + 1 Τέλος Εκτύπωσε θετικοί α > 0 Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών

6 6 Ροή εκτέλεσης αλγορίθμου ΝΑΙ Αρχή θετικοί ← θετικοί + 1 i ← 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ θετικοί ← 0 i ← i + 1 Τέλος Εκτύπωσε θετικοί α > 0 θετικοί ← 0 Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών

7 7 Ροή εκτέλεσης αλγορίθμου ΝΑΙ Αρχή θετικοί ← θετικοί + 1 i ← 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ θετικοί ← 0 i ← i + 1 Τέλος Εκτύπωσε θετικοί α > 0 i ← 1 Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών

8 8 Ροή εκτέλεσης αλγορίθμου ΝΑΙ Αρχή θετικοί ← θετικοί + 1 i ← 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ θετικοί ← 0 i ← i + 1 Τέλος Εκτύπωσε θετικοί α > 0 i <= 100 Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών

9 9 Ροή εκτέλεσης αλγορίθμου - 1 η επανάληψη ΝΑΙ Αρχή θετικοί ← θετικοί + 1 i ← 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ θετικοί ← 0 i ← i + 1 Τέλος Εκτύπωσε θετικοί α > 0 ΝΑΙ Διάβασε α Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών

10 10 ΝΑΙ Αρχή θετικοί ← θετικοί + 1 i ← 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ θετικοί ← 0 i ← i + 1 Τέλος Εκτύπωσε θετικοί α > 0 Ροή εκτέλεσης αλγορίθμου - 1 η επανάληψη α > 0 Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών

11 11 ΝΑΙ Αρχή θετικοί ← θετικοί + 1 i ← 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ θετικοί ← 0 i ← i + 1 Τέλος Εκτύπωσε θετικοί α > 0 Ροή εκτέλεσης αλγορίθμου - 1 η επανάληψη θετικοί ← θετικοί + 1 ΝΑΙ Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών Ας υποθέσουμε ότι η συνθήκη ισχύει

12 12 Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών i ← i + 1 Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών ΝΑΙ Αρχή θετικοί ← θετικοί + 1 i ← 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ θετικοί ← 0 Τέλος Εκτύπωσε θετικοί α > 0 Ροή εκτέλεσης αλγορίθμου - 1 η επανάληψη i <= 100 i ← i + 1 Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών Με_βήμα 1

13 13 Ροή εκτέλεσης αλγορίθμου - 2 η επανάληψη ΝΑΙ Αρχή θετικοί ← θετικοί + 1 i ← 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ θετικοί ← 0 i ← i + 1 Τέλος Εκτύπωσε θετικοί α > 0 ΝΑΙ Διάβασε α Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών

14 14 ΝΑΙ Αρχή θετικοί ← θετικοί + 1 i ← 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ θετικοί ← 0 i ← i + 1 Τέλος Εκτύπωσε θετικοί α > 0 Ροή εκτέλεσης αλγορίθμου - 2 η επανάληψη α > 0 Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών

15 15 ΝΑΙ Αρχή θετικοί ← θετικοί + 1 i ← 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ θετικοί ← 0 i ← i + 1 Τέλος Εκτύπωσε θετικοί α > 0 Ροή εκτέλεσης αλγορίθμου - 2 η επανάληψη θετικοί ← θετικοί + 1 ΝΑΙ Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών Ας υποθέσουμε ξανά ότι η συνθήκη ισχύει

16 16 Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών i ← i + 1 Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών ΝΑΙ Αρχή θετικοί ← θετικοί + 1 i ← 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ θετικοί ← 0 Τέλος Εκτύπωσε θετικοί α > 0 Ροή εκτέλεσης αλγορίθμου - 2 η επανάληψη i <= 100 i ← i + 1 Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών Με_βήμα 1

17 17 Ροή εκτέλεσης αλγορίθμου - 3 η επανάληψη ΝΑΙ Αρχή θετικοί ← θετικοί + 1 i ← 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ θετικοί ← 0 i ← i + 1 Τέλος Εκτύπωσε θετικοί α > 0 ΝΑΙ Διάβασε α Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών

18 18 ΝΑΙ Αρχή θετικοί ← θετικοί + 1 i ← 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ θετικοί ← 0 i ← i + 1 Τέλος Εκτύπωσε θετικοί α > 0 Ροή εκτέλεσης αλγορίθμου - 3 η επανάληψη α > 0 Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών

19 19 ΝΑΙ Αρχή θετικοί ← θετικοί + 1 i ← 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ θετικοί ← 0 i ← i + 1 Τέλος Εκτύπωσε θετικοί α > 0 Ροή εκτέλεσης αλγορίθμου - 3 η επανάληψη OXI Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών Ας υποθέσουμε ότι η συνθήκη δεν ισχύει

20 20 Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών i ← i + 1 Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών ΝΑΙ Αρχή θετικοί ← θετικοί + 1 i ← 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ θετικοί ← 0 Τέλος Εκτύπωσε θετικοί α > 0 Ροή εκτέλεσης αλγορίθμου - 3 η επανάληψη i <= 100 i ← i + 1 Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών Με_βήμα 1

21 21 Ροή εκτέλεσης αλγορίθμου Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών ΝΑΙ Αρχή θετικοί ← θετικοί + 1 i ← 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ θετικοί ← 0 i ← i + 1 Τέλος Εκτύπωσε θετικοί α > 0 Αυτό θα γίνει όταν έχουν διαβαστεί και επεξεργαστεί 100 αριθμοί Η ίδια διαδικασία θα συνεχιστεί έως ότου πάψει να ισχύει η συνθήκη της δομής Για, οπότε και τερματίζεται η επανάληψη Γνωστό πλήθος επαναλήψεων Το ίδιο δ.ρ. έχει η δομή Όσο

22 22 Ροή εκτέλεσης αλγορίθμου Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών ΝΑΙ Αρχή θετικοί ← θετικοί + 1 i ← 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ θετικοί ← 0 i ← i + 1 Τέλος Εκτύπωσε θετικοί α > 0 Ας υποθέσουμε ότι η συνθήκη δεν ισχύει, το i είναι 101

23 23 Ροή εκτέλεσης αλγορίθμου Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών ΝΑΙ Αρχή θετικοί ← θετικοί + 1 i ← 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ θετικοί ← 0 i ← i + 1 Τέλος α > 0 Εκτύπωσε θετικοί OXI Εκτύπωσε θετικοί

24 24 Ροή εκτέλεσης αλγορίθμου Αλγόριθμος Πλήθος_θετικών θετικοί ← 0 Για i από 1 μέχρι 100 Διάβασε α Αν α > 0 τότε θετικοί ← θετικοί + 1 Τέλος_αν Τέλος_επανάληψης Εκτύπωσε θετικοί Τέλος Πλήθος_θετικών ΝΑΙ Αρχή θετικοί ← θετικοί + 1 i ← 1 i <= 100 OXI Διάβασε α OXI ΝΑΙ θετικοί ← 0 i ← i + 1 Τέλος α > 0 Εκτύπωσε θετικοί Τέλος

25 25 Δομή Επανάληψης Για – Διάγραμμα ροής Για ΜΕΤ από ΑΤ μέχρι ΤΤ με_βημα Β εντολές Τέλος_επανάληψης

26 26 Συμπεράσματα Η δομή επανάληψης Για χρησιμοποιείται στην περίπτωση που είναι εξαρχής γνωστό το πλήθος των επαναλήψεων Στην περίπτωση που δεν ισχύει αυτό; Θα χρησιμοποιήσουμε την δομή Όσο…επανάλαβε …ή την δομή Αρχή_επανάληψης…Μέχρις_ότου

27 Η Δομή Επανάληψης Η Δομή Επανάληψης Για με ΔΡ


Κατέβασμα ppt "1 Η ΓΙΑ ΚΑΙ Η ΛΕΙΤΟΥΡΓΙΑ ΤΗΣ Η δομή Για περιέχει 3 τμήματα (εντολές) που εκτελούνται αυτόματα(εσωτερικά στη Για) Για i από 1 μέχρι 100 i ← 1 i <= 100 i."

Παρόμοιες παρουσιάσεις


Διαφημίσεις Google