Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Συγγραφείς Α.Βακάλη Η. Γιαννόπουλος Ν. Ιωαννίδης Χ.Κοίλιας Κ. Μάλαμας Ι. Μανωλόπουλος Π. Πολίτης Γ΄ τάξη.

Παρόμοιες παρουσιάσεις


Παρουσίαση με θέμα: "ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Συγγραφείς Α.Βακάλη Η. Γιαννόπουλος Ν. Ιωαννίδης Χ.Κοίλιας Κ. Μάλαμας Ι. Μανωλόπουλος Π. Πολίτης Γ΄ τάξη."— Μεταγράφημα παρουσίασης:

1 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Συγγραφείς Α.Βακάλη Η. Γιαννόπουλος Ν. Ιωαννίδης Χ.Κοίλιας Κ. Μάλαμας Ι. Μανωλόπουλος Π. Πολίτης Γ΄ τάξη Τεχνολογικής Κατεύθυνσης Ενιαίου Λυκείου Διδάσκων: Τσιωτάκης Παναγιώτης

2 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον2  Εντολές επιλογής –Εντολή ΑΝ –Εντολή ΕΠΙΛΕΞΕ  Εντολές επανάληψης –Εντολή ΟΣΟ…ΕΠΑΝΑΛΑΒΕ –Εντολή ΜΕΧΡΙΣ_ΟΤΟΥ –Εντολή ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ Κεφάλαιο 8 : Επιλογή και Επανάληψη

3 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον3 Εντολές επιλογής  Μία από τις βασικότερες δομές που εμφανίζονται σε ένα πρόγραμμα, είναι η επιλογή  Σχεδόν σε όλα τα προβλήματα περιλαμβάνονται κάποιοι έλεγχοι και ανάλογα με το αποτέλεσμα αυτών των ελέγχων επιλέγονται οι ενέργειες που θα ακολουθήσουν

4 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον4 Λογική έκφραση  Για τη σύνταξη μιας λογικής έκφρασης ή συνθήκης χρησιμοποιούνται σταθερές, μεταβλητές, αριθμητικές παραστάσεις, συγκριτικοί και λογικοί τελεστές, καθώς και παρενθέσεις  Στις λογικές εκφράσεις γίνεται σύγκριση της τιμής μίας έκφρασης, που βρίσκεται αριστερά από το συγκριτικό τελεστή με την τιμή μιας άλλης έκφρασης που βρίσκεται δεξιά  Το αποτέλεσμα είναι μία λογική τιμή ΑΛΗΘΗΣ ή ΨΕΥΔΗΣ

5 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον5 Λογική έκφραση

6 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον6 Λογική έκφραση  Οταν αριθμητικοί και συγκριτικοί τελεστές συνδυάζονται σε μια έκφραση, οι αριθμητικές πράξεις εκτελούνται πρώτες  Ακόμη, οι λογικοί τελεστές έχουν χαμηλότερη ιεραρχία από τους συγκριτικούς

7 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον7 Σύνθετες εκφράσεις  Σε πολλά προβλήματα οι επιλογές δεν αρκεί να γίνονται με απλές λογικές παραστάσεις όπως αυτές οι οποίες αναφέρθηκαν, αλλά χρειάζεται να συνδυαστούν μία ή περισσότερες λογικές παραστάσεις  Αυτό επιτυγχάνεται με τη χρήση των τριών βασικών λογικών τελεστών ΟΧΙ, ΚΑΙ, ‘Η

8 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον8  Εντολές επιλογής –Εντολή ΑΝ –Εντολή ΕΠΙΛΕΞΕ  Εντολές επανάληψης –Εντολή ΟΣΟ…ΕΠΑΝΑΛΑΒΕ –Εντολή ΜΕΧΡΙΣ_ΟΤΟΥ –Εντολή ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ Κεφάλαιο 8 : Επιλογή και Επανάληψη

9 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον9 Η Εντολή ΑΝ

10 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον10 Η Εντολή ΑΝ  Συχνά η εντολή ΑΝ εκτός από το τμήμα των εντολών, που εκτελούνται όταν η λογική έκφραση είναι Αληθής, περιέχει και το τμήμα των εντολών που εκτελούνται, αν δεν ισχύει η συνθήκη (είναι Ψευδής)  Η μορφή αυτής της εντολής ονομάζεται ΑΝ...ΤΟΤΕ...ΑΛΛΙΩΣ ΔΙΑΒΑΣΕ α ΑΝ α >=0 ΤΟΤΕ Ρίζα  Τ_Ρ(α) ΑΛΛΙΩΣ ΓΡΑΨΕ ‘Η τετρ. ρίζα αρνητικού αριθμού δεν ορίζεται’ ΤΕΛΟΣ_ΑΝ

11 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον11 Η Εντολή ΑΝ

12 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον12 Λογική έκφραση  Η γενική μορφή της εντολής ΑΝ καλύπτει την επιλογή μιας από δύο εναλλακτικές περιπτώσεις  ‘Οταν οι εναλλακτικές περιπτώσεις είναι περισσότερες από τις δύο, τότε μπορούν να χρησιμοποιηθούν πολλές εντολές ΑΝ η μία μέσα στην άλλη, οι εμφωλευμένες εντολές ΑΝ, όπως ονομάζονται

13 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον13 Λογική έκφραση Έστω οι παρακάτω εντολές προγράμματος ΔΙΑΒΑΣΕ Βάρος, Ύψος ΑΝ Βάρος < 80 ΤΟΤΕ ΑΝ Ύψος < 1.70 ΤΟΤΕ ΓΡΑΨΕ ‘Ελαφρύς, κοντός’ ΤΕΛΟΣ_ΑΝ

14 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον14 Λογική έκφραση Το προηγούμενο τμήμα προγράμματος μπορεί να γραφεί ως εξής ΔΙΑΒΑΣΕ Βάρος, Ύψος ΑΝ Βάρος < 80 ΚΑΙ Ύψος < 1.70 ΤΟΤΕ ΓΡΑΨΕ ‘Ελαφρύς, κοντός’ ΤΕΛΟΣ_ΑΝ

15 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον15 Η Εντολή ΑΝ

16 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον16 Η Εντολή ΑΝ Παράδειγμα ΑΝ αριθμός > 0 ΤΟΤΕ ΓΡΑΨΕ ‘Ο αριθμός είναι θετικός’ Πλήθος_θετικών  Πλήθος _θετικών + 1 ΑΛΛΙΩΣ_ΑΝ αριθμός <0 ΤΟΤΕ ΓΡΑΨΕ ‘Ο αριθμός είναι αρνητικός’ Πλήθος _αρνητικών  Πλήθος_αρνητικών +1 ΑΛΛΙΩΣ ΓΡΑΨΕ ‘Ο αριθμός είναι 0’ Πλήθος_0  Πλήθος _0 +1 ΤΕΛΟΣ_ΑΝ

17 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον17 Η Εντολή ΑΝ

18 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον18 Παράδειγμα 1 Με χρήση εμφωλευμένων εντολών ΑΝ: ΑΝ Ποσότητα=<50 ΤΟΤΕ Κόστος  Ποσότητα * ΑΛΛΙΩΣ ΑΝ Ποσότητα =< 100 ΤΟΤΕ Κόστος  Ποσότητα * ΑΛΛΙΩΣ ΑΝ Ποσότητα =< 200 ΤΟΤΕ Κόστος  Ποσότητα * ΑΛΛΙΩΣ Κόστος  Ποσότητα * ΤΕΛΟΣ_ΑΝ

19 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον19 Παράδειγμα 1 Με τη χρήση της ΑΝ...ΤΟΤΕ...ΑΛΛΙΩΣ_ΑΝ: ΑΝ Ποσότητα =<50 ΤΟΤΕ Κόστος  Ποσότητα * ΑΛΛΙΩΣ_ΑΝ Ποσότητα =<100 ΤΟΤΕ Κόστος  Ποσότητα * ΑΛΛΙΩΣ_ΑΝ Ποσότητα =<200 ΤΟΤΕ Κόστος  Ποσότητα * ΑΛΛΙΩΣ Κόστος  Ποσότητα * ΤΕΛΟΣ_ΑΝ

20 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον20 Παράδειγμα 1 Με περιττούς ελέγχους που αυξάνουν την πολυπλοκότητα: ΑΝ Ποσότητα <=50 ΤΟΤΕ Κόστος  Ποσότητα * ΑΛΛΙΩΣ_ΑΝ Ποσότητα >50 ΚΑΙ Ποσότητα =<100 ΤΟΤΕ Κόστος  Ποσότητα * ΑΛΛΙΩΣ_ΑΝ Ποσότητα >100 ΚΑΙ Ποσότητα =<200 ΤΟΤΕ Κόστος  Ποσότητα * ΑΛΛΙΩΣ Κόστος  Ποσότητα * ΤΕΛΟΣ_ΑΝ

21 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον21  Εντολές επιλογής –Εντολή ΑΝ –Εντολή ΕΠΙΛΕΞΕ  Εντολές επανάληψης –Εντολή ΟΣΟ…ΕΠΑΝΑΛΑΒΕ –Εντολή ΜΕΧΡΙΣ_ΟΤΟΥ –Εντολή ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ Κεφάλαιο 8 : Επιλογή και Επανάληψη

22 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον22 Εντολή Επίλεξε ΔΙΑΒΑΣΕ αριθμός ΕΠΙΛΕΞΕ αριθμός ΠΕΡΙΠΤΩΣΗ 0 ΓΡΑΨΕ ‘Μηδέν’ ΠΕΡΙΠΤΩΣΗ 1,3,5,7,9 ΓΡΑΨΕ ‘Μονός αριθμός’ ΠΕΡΙΠΤΩΣΗ 2,4,6,8 ΓΡΑΨΕ ‘ Ζυγός αριθμός‘ ΠΕΡΙΠΤΩΣΗ ΑΛΛΙΩΣ ΓΡΑΨΕ ‘αριθμός 9 ή όχι ακέραιος’ ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ

23 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον23 Εντολή Επίλεξε  Υπολογίζεται η τιμή της έκφρασης και εκτελούνται οι εντολές που ανήκουν στην αντίστοιχη περίπτωση τιμών  Αν η τιμή της έκφρασης δεν αντιστοιχεί σε καμία περίπτωση, τότε εκτελούνται οι εντολές αλλιώς  Στην εντολή αυτή οι λίστες τιμών που συνοδεύουν κάθε περίπτωση μπορούν να περιλαμβάνουν μία ή περισσότερες τιμές ή περιοχή τιμών από-έως

24 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον24 Ερωτήσεις 1. Κάθε εντολή ΑΝ περιλαμβάνει υποχρεωτικά το τμήμα ΑΛΛΙΩΣ 2. Κάθε τμήμα προγράμματος που χρησιμοποιεί την εντολή ΕΠΙΛΕΞΕ μπορεί να γραφεί και με εντολές ΑΝ 3. Η χρήση εμφωλευμένων ΑΝ είναι καλή προγραμματιστική τακτική 4. Αν το Α έχει την τιμή 10 και το Β την τιμή 20 τότε η έκφραση (Α >8 ΚΑΙ Β 10 Ή Β=10) είναι αληθής ΛÜèïò Σùóôü ΛÜèïò

25 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον25 Ερωτήσεις 5. Τι θα εκτυπώσουν οι παρακάτω εντολές: Α. 0 Β. 10 Γ. 5 Δ. 20

26 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον26 Ερωτήσεις 6. Να συμπληρωθούν τα κενά ώστε οι επόμενες εντολές να τυπώνουν πάντα τον μεγαλύτερο αριθμό από τους δύο που διαβάστηκαν ΔΙΑΒΑΣΕ Α,Β ΑΝ Α<Β … …… ΤΕΛΟΣ_ΑΝ ΓΡΑΨΕ Α ΤOTE A  B

27 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον27 Ερωτήσεις 7. Να συμπληρωθούν τα κενά ώστε οι επόμενες εντολές να τυπώνουν την τετραγωνική ρίζα ΔΙΑΒΑΣΕ Α ΑΝ Α ….. 0 ΤΟΤΕ Ρίζα  Τ_Ρ(Α) ΓΡΑΨΕ Ρίζα ……… ΓΡΑΨΕ ‘Δεν υπάρχει ρίζα’ ΤΕΛΟΣ_ΑΝ >= ΑΛΛΙΩΣ

28 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον28  Εντολές επιλογής –Εντολή ΑΝ –Εντολή ΕΠΙΛΕΞΕ  Εντολές επανάληψης –Εντολή ΟΣΟ…ΕΠΑΝΑΛΑΒΕ –Εντολή ΜΕΧΡΙΣ_ΟΤΟΥ –Εντολή ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ Κεφάλαιο 8 : Επιλογή και Επανάληψη

29 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον29 Εντολές επανάληψης  Ο βρόχος, η οποία επιτρέπει την εκτέλεση εντολών περισσότερες από μία φορά  Οι επαναλήψεις ελέγχονται πάντοτε από κάποια συνθήκη, η οποία καθορίζει την έξοδο από το βρόχο  Η ΓΛΩΣΣΑ υποστηρίζει τρεις εντολές επανάληψης: την εντολή ΟΣΟ όπου η επανάληψη, την εντολή ΜΕΧΡΙΣ_ΟΤΟΥ και τέλος την εντολή ΓΙΑ

30 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον30  Εντολές επιλογής –Εντολή ΑΝ –Εντολή ΕΠΙΛΕΞΕ  Εντολές επανάληψης –Εντολή ΟΣΟ…ΕΠΑΝΑΛΑΒΕ –Εντολή ΜΕΧΡΙΣ_ΟΤΟΥ –Εντολή ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ Κεφάλαιο 8 : Επιλογή και Επανάληψη

31 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον31 Εντολή ΟΣΟ…ΕΠΑΝΑΛΑΒΕ  Σε αυτή, η συνθήκη που ελέγχει την επανάληψη βρίσκεται στην αρχή της επανάληψης και ο βρόχος επαναλαμβάνεται συνεχώς, όσο η συνθήκη αυτή ισχύει  Αποτελεί υπερσύνολο των δυο άλλων δομών επανάληψης  Χαρακτηριστικό της επανάληψης αυτής είναι ότι ο αριθμός των επαναλήψεων δεν είναι γνωστός, ούτε μπορεί να υπολογιστεί πριν από την εκτέλεση του προγράμματος

32 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον32 Εντολή ΟΣΟ…ΕΠΑΝΑΛΑΒΕ

33 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον33 Εντολή ΟΣΟ…ΕΠΑΝΑΛΑΒΕ  Εφόσον μετά από κάθε επανάληψη ελέγχεται εκ νέου η συνθήκη, πρέπει υποχρεωτικά μέσα στο βρόχο να υπάρχει μία εντολή, η οποία να μεταβάλει την τιμή της μεταβλητής που ελέγχεται με τη συνθήκη  Σε αντίθετη περίπτωση η επανάληψη δε θα τερματίζεται και θα εκτελείται συνεχώς  Ελέγχεται η συνθήκη και αν είναι Αληθής, εκτελούνται οι εντολές που βρίσκονται ανάμεσα στις ΟΣΟ_ΕΠΑΝΑΛΑΒΕ και ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

34 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον34 Εντολή ΟΣΟ…ΕΠΑΝΑΛΑΒΕ  Στη συνέχεια ελέγχεται πάλι η συνθήκη και αν ισχύει, εκτελούνται πάλι οι ίδιες εντολές  ‘Οταν η λογική έκφραση γίνει Ψευδής, τότε σταματάει η επανάληψη και εκτελείται η εντολή μετά το ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

35 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον35 Εντολή ΟΣΟ…ΕΠΑΝΑΛΑΒΕ

36 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον36 Παράδειγμα 2 ΠΡΟΓΡΑΜΜΑ Άθροισμα ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Χ, Άθροισμα, Πλήθος ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ ΑΡΧΗ Πλήθος  0 Άθροισμα  0 ΓΡΑΨΕ ‘Δώσε αριθμό’ ΔΙΑΒΑΣΕ Χ ΟΣΟ ×<>0 ΕΠΑΝΑΛΑΒΕ Άθροισμα  Άθροισμα + × Πλήθος  Πλήθος + 1 ΓΡΑΨΕ ‘Δώσε αριθμό’ ΔΙΑΒΑΣΕ Χ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΑΝ Πλήθος > 0 ΤΟΤΕ ΜΟ  Πλήθος/Άθροισμα ΓΡΑΨΕ ‘Το άθρ είναι: ‘, Άθροισμα ΓΡΑΨΕ ‘Ο ΜΟ είναι: ‘, ΜΟ ΑΛΛΙΩΣ ΓΡΑΨΕ ‘Δεν δόθηκαν στοιχεία’ ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

37 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον37  Εντολές επιλογής –Εντολή ΑΝ –Εντολή ΕΠΙΛΕΞΕ  Εντολές επανάληψης –Εντολή ΟΣΟ…ΕΠΑΝΑΛΑΒΕ –Εντολή ΜΕΧΡΙΣ_ΟΤΟΥ –Εντολή ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ Κεφάλαιο 8 : Επιλογή και Επανάληψη

38 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον38 Εντολή ΜΕΧΡΙΣ_ΟΤΟΥ Εντολή ΜΕΧΡΙΣ_ΟΤΟΥ  Η δεύτερη εντολή επανάληψης που χρησιμο-ποιεί η ΓΛΩΣΣΑ είναι η εντολή ΜΕΧΡΙΣ_ΟΤΟΥ  Σε αυτή οι εντολές του βρόχου εκτελούνται μέχρις ότου ικανοποιηθεί κάποια συνθήκη η οποία ελέγχεται στο τέλος της επανάληψης  Πολύ συχνά η ίδια επαναληπτική διαδικασία μπορεί να γραφεί εξίσου σωστά χρησιμοποιώντας είτε τη δομή ΟΣΟ...ΕΠΑΝΑΛΑΒΕ είτε τη δομή ΜΕΧΡΙΣ_ΟΤΟΥ

39 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον39 Εντολή ΜΕΧΡΙΣ_ΟΤΟΥ Εντολή ΜΕΧΡΙΣ_ΟΤΟΥ

40 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον40 Εντολή ΜΕΧΡΙΣ_ΟΤΟΥ Εντολή ΜΕΧΡΙΣ_ΟΤΟΥ

41 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον41 Εντολή ΜΕΧΡΙΣ_ΟΤΟΥ Εντολή ΜΕΧΡΙΣ_ΟΤΟΥ  Υπάρχουν όμως περιπτώσεις όπου η χρήση της εντολής ΜΕΧΡΙΣ_ΟΤΟΥ οδηγεί σε απλούστερα και πιο ευκολονόητα προγράμματα  Γενικά σε περιπτώσεις όπου η επανάληψη θα συμβεί υποχρεωτικά μία φορά, είναι προτιμότερη η χρήση της ΜΕΧΡΙΣ_ΟΤΟΥ  Χαρακτηριστική περίπτωση όπου προτιμάται η εντολή ΜΕΧΡΙΣ_ΟΤΟΥ είναι στον έλεγχο αποδεκτών τιμών καθώς και στην επιλογή από προκαθορισμένες απαντήσεις ή μενού

42 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον42 Παράδειγμα 3 ΠΡΟΓΡΑΜΜΑ Άθροισμα2 ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Χ, Άθροισμα, Πλήθος ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ ΧΑΡΑΚΤΗΡΕΣ: Επιλογή ΑΡΧΗ Πλήθος  0 Άθροισμα  0 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Δώσε αριθμό’ ΔΙΑΒΑΣΕ Χ ΑΝ Χ<=0 ΤΟΤΕ ΓΡΑΨΕ ‘Λάθος αριθμός, δοκιμάστε ξανά…’ ΤΕΛΟΣ_ΑΝ ! Αν το Χ δεν είναι θετικό εισάγουμε νέο αριθμό ΜΕΧΡΙΣ_ΟΤΟΥ Χ>0 Άθροισμα  Άθροισμα + Χ Πλήθος  Πλήθος +1 ΓΡΑΨΕ ‘Νέα μέτρηση;’ ΔΙΑΒΑΣΕ Επιλογή !Αν επιλογή =Ο ή ο τότε σταματάει ΜΕΧΡΙΣ_ΟΤΟΥ Επιλογή=’Ο’ Η Επιλογή=’ο’ ΜΟ  Άθροισμα / Πλήθος ΓΡΑΨΕ ‘Άθροισμα =’, Άθροισμα ΓΡΑΨΕ ‘Μέσος όρος =’, ΜΟ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

43 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον43 Παράδειγμα 3 σε Pascal (‘Δώσε αριθμό:’); (‘Λάθος αριθμός, Δώσε ξανά..’);

44 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον44  Εντολές επιλογής –Εντολή ΑΝ –Εντολή ΕΠΙΛΕΞΕ  Εντολές επανάληψης –Εντολή ΟΣΟ…ΕΠΑΝΑΛΑΒΕ –Εντολή ΜΕΧΡΙΣ_ΟΤΟΥ –Εντολή ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ Κεφάλαιο 8 : Επιλογή και Επανάληψη

45 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον45 Εντολή ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ Εντολή ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ  Πολύ συχνά ο αριθμός των επαναλήψεων που πρέπει να εκτελεστούν, είναι γνωστός από την αρχή  Αν και αυτού του είδους οι επαναλήψεις μπορούν να αντιμετωπιστούν με τη χρήση των προηγούμενων εντολών επανάληψης, η ΓΛΩΣΣΑ διαθέτει και την εντολή ΓΙΑ

46 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον46 Εντολή ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ Εντολή ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ ΓΙΑ αριθμό ΑΠΟ 1 ΜΕΧΡΙ 100 ΜΕ ΒΗΜΑ 2 Άθροισμα  Άθροισμα + αριθμό ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

47 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον47 Παράδειγμα 4 ΠΡΟΓΡΑΜΜΑ Ðåñéôôïß ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: ¢èñïéóìá, Áñéèìüò ΑΡΧΗ ¢èñïéóìá  0 ΓΙΑ Áñéèìüò ΑΠΟ 1 ΜΕΧΡΙ 100 ΜΕ ΒΗΜΑ 2 ¢èñïéóìá  ¢èñïéóìá + Áñéèìüò ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘¢èñïéóìá ðåñéôôþí áñéèìþí åßíáé: ’, ¢èñïéóìá ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

48 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον48 Εντολή ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ Εντολή ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ  Πολύ συχνά για την επίλυση των προβλημάτων απαιτείται η χρήση εμφωλευμένων βρόχων  Στη χρήση των εμφωλευμένων βρόχων ισχύουν συγκεκριμένοι κανόνες που πρέπει να ακολουθούνται αυστηρά για την σωστή λειτουργία των προγραμμάτων. Συγκεκριμένα:  Ο εσωτερικός βρόχος πρέπει να βρίσκεται ολόκληρος μέσα στον εξωτερικό  Ο βρόχος που ξεκινάει τελευταίος, πρέπει να ολοκληρώνεται πρώτος

49 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον49 Εντολή ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ Εντολή ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ  Η είσοδος σε κάθε βρόχο υποχρεωτικά γίνεται από την αρχή του  Δεν μπορεί να χρησιμοποιηθεί η ίδια μεταβλητή ως μετρητής δύο ή περισσοτέρων βρόχων που ο ένας βρίσκεται στο εσωτερικό του άλλου

50 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον50 Παράδειγμα 5 ΠΡΟΓΡΑΜΜΑ Ðñïðáßäåéá ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ:Á,Â,Ã !Α:Πολλαπλασιαστέος, Β:Πολαπλασιαστής, Γ:Γινόμενο ΑΡΧΗ ΓΙΑ Á ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΙΑ Â ΑΠΌ 1 ΜΕΧΡΙ 10 Ã  Á*Â ΓΡΑΨΕ Á,’x’,Â,’=’,Ã ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ !Εισαγωγή κενής γραμμής στην εκτύπωση ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

51 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον51 Ερωτήσεις 1. Οι εντολές που βρίσκονται σε μία επανάληψη ΓΙΑ εκτελούνται τουλάχιστον μία φορά 2. Κάθε επανάληψη μπορεί να γραφεί με την εντολή ΟΣΟ- ΕΠΑΝΑΛΑΒΕ 3. Σε περίπτωση εμφωλευμένων βρόχων,ο εσωτερικός πρέπει να περικλείεται ολόκληρος στον εξωτερικό 4. Η τιμή του βήματος αναφέρεται υποχρεωτικά σε κάθε εντολή ΓΙΑ ΛÜèïò Σùóôü ΛÜèïò

52 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον52 Ερωτήσεις 5. Τι θα εκτυπώσουν οι παρακάτω εντολές: Α. 10 Β. 0 Γ. 2 Δ. Άπειρες

53 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον53 Ερωτήσεις 6. Να συμπληρωθούν τα κενά ώστε οι επόμενες εντολές να τυπώνουν το άθροισμα των τετραγώνων των περιττών αριθμών που είναι μικρότεροι από 10 Άθροισμα  … ΓΙΑ … ΑΠΟ 1 ΜΕΧΡΙ 10 ΜΕ ΒΗΜΑ … Άθροισμα  …………… + Ι^2 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ Άθροισμα 0 Ι 2 Άθροισμα

54 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον54 Ερωτήσεις 7. Να συμπληρωθούν τα κενά ώστε οι επόμενες εντολές να τυπώνουν το άθροισμα των αριθμών από 100 έως 200 Κ  … Σ  … ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ Σ  Σ+Κ Κ  Κ+1 ΜΕΧΡΙΣ_ΟΤΟΥ …… ΓΡΑΨΕ Σ 100 Κ>200 0

55 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον55 Βιβλίο Μαθητή Κεφάλαιο 8 : Επιλογή και Επανάληψη

56 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον56 Συμβουλές – Υποδείξεις  Με τη σωστή χρήση των åíôïëών åðéëïãήò êáé åðáíÜëçøçò õëïðïéείται ó÷åäüí ïðïéïíäÞðïôå áëãüñéèìïς  ¼ôáí ÷ñçóéìïðïéåßò óýíèåôåò ëïãéêÝò åêöñÜóåéò, íá ðñïóÝ÷åéò ôçí éåñáñ÷ßá ôùí ôåëåóôþí. Åßíáé êáëýôåñï íá ÷ñçóéìïðïéoύνται ðÜíôá ðáñåíèÝóåéò, Ýóôù êáé áí äåí åßíáé áðáñáßôçôï

57 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον57 Συμβουλές – Υποδείξεις  Ðñéí ÷ñçóéìïðïéÞóåéò åìöùëåõìÝíá ÁÍ, óêÝøïõ ìÞðùò ôï ßäéï ðñüãñáììá ìðïñåß íá õëïðïéçèåß áðëïýóôåñá ìå óýíèåôåò ëïãéêÝò åêöñÜóåéò, ôçí åíôïëÞ ÁÍ – ÁËËÉÙÓ_ÁÍ Þ êÜðïéá Üëëç åíôïëÞ åðéëïãÞò  Ïé ìåôáâëçôÝò ðïõ åëÝã÷ïõí ôçí åðáíÜëçøç ôïõ âñü÷ïõ ÏÓÏ êáé ÌÅ×ÑÉÓ_ÏÔÏÕ ðñÝðåé õðï÷ñåùôéêÜ íá áëëÜæïõí ôéìÞ ìÝóá óôï óþìá ôïõ âñü÷ïõ, áëëéþò Þ äåí åêôåëåßôáé ðïôÝ Þ óõíçèÝóôåñá äåí óôáìáôÜåé ç åêôÝëåóç ôïõ (áôÝñìùí âñü÷ïò)

58 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον58 Συμβουλές – Υποδείξεις  Ïé åðáíáëÞøåéò ðïõ õëïðïéïýíôáé ìå ôçí åíôïëÞ ÏÓÏ, ìðïñåß íá ìçí åêôåëåóôïýí ïýôå ìßá öïñÜ, áöïý ï Ýëåã÷ïò ãßíåôáé óôçí åßóïäï ôïõ âñü÷ïõ, áíôßèåôá ïé åðáíáëÞøåéò ÌÅ×ÑÉÓ_ÏÔÏÕ èá ðñáãìáôïðïéçèïýí ôïõëÜ÷éóôïí ìßá öïñÜ  Ç åíôïëÞ ÃÉÁ ÷ñçóéìïðïéåßôáé ìüíï ãéá ðñïêáèïñéóìÝíï áñéèìü åðáíáëÞøåùí  Έλεγχος δεδομένων

59 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον59 Τεστ αυτοαξιολόγησης Á. Ã ÑÁØÅ ‘Äåí õð Üñ χ åé ñßæá’ Â. ÁÍ Á >0 Ô Ï Ô Å Ã. Ô ÅËÏÓ _ ÁÍ Ä. ÁËËÉÙÓ Å. Ñßæá  Ô_ Ñ ( Á ) Β, Ε, Δ, Α, Γ

60 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον60 Τεστ αυτοαξιολόγησης Á. Ì Å Χ ÑÉÓ _ Ï Ô Ï Õ ( Á ð Üí ô çóç = ’Í’ ¹ Á ð Üí ô çóç = ’í’ ) Â. ÄÉÁ Â ÁÓÅ Á ð Üí ô çóç Ã. ÁÑ Χ Ç _ Å Ð ÁÍÁËÇØÇÓ Ä. Ã ÑÁØÅ ‘Ä þ óå á ð Üí ô çóç : ’ Γ, Δ, Β, Α

61 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον61 Τεστ αυτοαξιολόγησης 3. Ïé åíôïëÝò ðïõ âñßóêïíôáé óå Ýíá âñüχï ÏÓÏ ÅÐÁÍÁËÁÂÅ åêôåëïýíôáé ôïõëÜχéóôïí ìßá öïñÜ 4. Ç ôéìÞ ôïõ âÞìáôïò óôçí åíôïëÞ ÃÉÁ åßíáé õðïχñåùôéêÞ íá áíáãñÜöåôáé 5. ÊÜèå åíôïëÞ ÁÍ ðñÝðåé íá Ýχåé ôçí áíôßóôïéχç åíôïëÞ ÔÅËÏÓ_ÁÍ 6. ÊÜèå âñüχïò ðïõ õëïðïéåßôáé ìå ôçí åíôïëÞ ÏÓÏ ÅÐÁÍÁËÁÂÅ ìðïñåß íá ãñáöåß êáé ìå χñÞóç ôçò åíôïëÞò ÃÉÁ 7. Áí ôï Á Ýχåé ôçí ôéìÞ 5 êáé ôï  ôçí ôéìÞ 6 ôüôå ç ëïãéêÞ Ýêöñáóç Á>5 ¹ Á 5 åßíáé øåõäÞò ΛÜèïò Σùóôü ΛÜèïò Σùóôü

62 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον62 Τεστ αυτοαξιολόγησης Ð ïéï á ð ü ô á ð áñá ê Ü ô ù õð ïëï ã ßæåé ô ï Üèñïéóìá ô ùí ð åñé ôôþ í áñéèì þ í που υπάρχουν στους 100 πρώτους ακεραίους A. ¢èñïéóìá  0 ÃÉÁ É ÁÐÏ 1 ÌÅΧÑÉ 100 ¢èñïéóìá  ¢èñïéóìá + É ÔÅËÏÓ_ÅÐÁÍÁËÇØÇÓ Ã. ÃÉÁ É ÁÐÏ 1 ÌÅΧÑÉ 100 ÌÅ_ÂÇÌÁ 2 ¢èñïéóìá  0 ¢èñïéóìá  ¢èñïéóìá + É ÔÅËÏÓ_ÅÐÁÍÁËÇØÇÓ B. ¢èñïéóìá  0 ÃÉÁ É ÁÐÏ 1 ÌÅΧÑÉ 100 ÌÅ_ÂÇÌÁ 2 ¢èñïéóìá  ¢èñïéóìá + É ÔÅËÏÓ_ÅÐÁÍÁËÇØÇÓ Ä. ÃÉÁ É ÁÐÏ 1 ÌÅΧÑÉ 100 ÌÅ_ÂÇÌÁ 2 ¢èñïéóìá  É ÔÅËÏÓ_ÅÐÁÍÁËÇØÇÓ

63 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον63 Τεστ αυτοαξιολόγησης 9. Ô é èá å êôõðþ óåé ô ï ð áñá ê Ü ô ù ô ì Þ ìá ð ñï ã ñÜììá ô ï ò Á  0 ÃÉÁ É ÁÐÏ 10 ÌÅΧÑÉ 20 ÌÅ_ÂÇÌÁ 10 Á  Á + É ^2 ÔÅËÏÓ_ÅÐÁÍÁËÇØÇÓ Ã ÑÁØÅ Á Á. 0 Â. 100 Ã. 500 Ä. 400

64 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον64 Τεστ αυτοαξιολόγησης 10. Ð üóå ò öïñ Ýò èá å êô åëåó ô åß ç ð áñá ê Ü ô ù å ð áíÜëçøç ÁÑΧÇ_ÅÐÁÍÁËÇØÇÓ Á  0 ÃÉÁ É ÁÐÏ 1 ÌÅ×ÑÉ 5 Á  Á -1 ÔÅËÏÓ_ÅÐÁÍÁËÇØÇÓ ÌÅ×ÑÉÓ_ÏÔÏÕ Á =0 Á. 10 Â. 0 Ã. 5 Ä. ¢ ð åéñå ò

65 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον65 Τεστ αυτοαξιολόγησης 11. Ð ïéå ò á ð ü ô é ò å ð üìåíå ò ïìÜäå ò åí ô ïë þ í äßíï õ í ó ô ï Á ô çí ßäéá ôéìÞ με τον εξής κώδικα; Á  1 ÃÉÁ É ÁÐÏ 1 ÌÅ×ÑÉ 10 ÌÅ_ÂÇÌÁ 2 Á <- Á * É ÔÅËÏÓ_ÅÐÁÍÁËÇØÇÓ

66 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον66 Τεστ αυτοαξιολόγησης Á. Á  1 É  1 ÏÓÏ É <=10 ÅÐÁÍÁËÁÂÅ É  É +2 Á  Á * É ÔÅËÏÓ_ÅÐÁÍÁËÇØÇÓ Β. Á  1 É  1 ÏÓÏ É <=10 ÅÐÁÍÁËÁÂÅ Á  Á * É É  É +2 ÔÅËÏÓ_ÅÐÁÍÁËÇØÇÓ Γ. Á  1 É  1 ΑΡΧΗ_ÅÐÁÍÁËÇØÇÓ Á  Á * É É  É +2 ÌÅ×ÑÉÓ_ÏÔÏÕ É<10 Δ. Á  1 É  1 ΑΡΧΗ_ÅÐÁÍÁËÇØÇÓ Á  Á * É É  É +2 ÌÅ×ÑÉÓ_ÏÔÏÕ É=10

67 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον67 Τεστ αυτοαξιολόγησης 12. Ð üóå ò öïñ Ýò èá å êô åëåó ô åß ç ð áñá ê Ü ô ù å ð áíÜëçøç ÃÉÁ I ÁÐÏ 1 ÌÅ×ÑÉ 2 ÌÅ_ÂÇÌÁ 3 ÃÑÁØÅ ‘ ÌÞ í õ ìá’ ÔÅËÏÓ_ÅÐÁÍÁËÇØÇÓ A. 2 B. 0 Ã. 1 Ä. ¢ ð åéñå ò

68 1/4/2015Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον68 Τεστ αυτοαξιολόγησης 13. Ð ïéá ç ëåé ô ï õ ñ ã ßá ô ï õ ð áñá ê Ü ô ù ô ì Þ ìá ô ï ò ð ñï ã ñÜì   10 ÄÉÁÂÁÓÅ A   Á ÁÍ Á < 0 ÔÏÔÅ B  -A ÔÅËÏÓ_ÁÍ Á  0 ÃÑÁØÅ Â A. Tõðþ íåé ô ïí áñéèìü ð ï õ äéÜ â áóå B. Tõðþ íåé ô çí á ð üë õô ç ô éì Þ ô ï õ áñéèìï ý ð ï õ äéÜ â áóå Ã. Tõðþ íåé ð Üí ô á ô çí ô éì Þ 0 Ä. Tõðþ íåé ð Üí ô á ô çí ô éì Þ 10


Κατέβασμα ppt "ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Συγγραφείς Α.Βακάλη Η. Γιαννόπουλος Ν. Ιωαννίδης Χ.Κοίλιας Κ. Μάλαμας Ι. Μανωλόπουλος Π. Πολίτης Γ΄ τάξη."

Παρόμοιες παρουσιάσεις


Διαφημίσεις Google