Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Επανάληψη. Επανάληψη με όσο Όσο συνθήκη επανάλαβε εντολές Τέλος_επανάληψης συνθήκη εντολές (πράξεις) ψευδής αληθής Πως δουλεύει: Όσο η συνθήκη είναι αληθής.

Παρόμοιες παρουσιάσεις


Παρουσίαση με θέμα: "Επανάληψη. Επανάληψη με όσο Όσο συνθήκη επανάλαβε εντολές Τέλος_επανάληψης συνθήκη εντολές (πράξεις) ψευδής αληθής Πως δουλεύει: Όσο η συνθήκη είναι αληθής."— Μεταγράφημα παρουσίασης:

1 επανάληψη

2 Επανάληψη με όσο Όσο συνθήκη επανάλαβε εντολές Τέλος_επανάληψης συνθήκη εντολές (πράξεις) ψευδής αληθής Πως δουλεύει: Όσο η συνθήκη είναι αληθής εκτελούνται οι εντολές Αν η συνθήκη γίνει ψευδής η επανάληψη σταματά

3 Επανάληψη με αρχή_επανάληψης Αρχή_επανάληψης εντολές Μέχρις_ότου συνθήκη συνθήκη εντολές (πράξεις) αληθής ψευδής Πως δουλεύει: Οι εντολές εκτελούνται όσο η συνθήκη είναι ψευδής Αν η συνθήκη γίνει αληθής η επανάληψη σταματά

4 Επανάληψη με Για Για i από αρχική τιμή μέχρι τελική τιμή με_βήμα Ν εντολές Τέλος_επανάληψης Πως δουλεύει: Εκχωρείται στο i αρχική τιμή Όσο το i είναι μικρότερο ή ίσο από την τελική_τιμή εκτελούνται οι εντολές Το i αυξάνεται κάθε φορά κατά Ν (αν το βήμα είναι 1 παραλείπεται)

5 Διαφορές των 3 εντολών επανάληψης Όσο Η συνθήκη βρίσκεται στην αρχή Αν η συνθήκη είναι αληθής εκτελούνται οι εντολές Όταν η συνθήκη γίνει ψευδής σταματά η επανάληψη Αν η συνθήκη είναι από την αρχή ψευδής οι εντολές δεν εκτελούνται ποτέ Αρχή επανάληψης Η συνθήκη βρίσκεται στην τέλος Αν η συνθήκη είναι ψευδής εκτελούνται οι εντολές Όταν η συνθήκη γίνει αληθής σταματά η επανάληψη Η επανάληψη (ο βρόγχος) θα εκτελεστεί τουλάχιστον μία φορά Για Χρησιμοποιείται μόνο όταν γνωρίζουμε το πλήθος των επαναλήψεων Η συνθήκη είναι πάντα το i <= τελική τιμή Όσο το i <= τελική τιμή συνεχίζεται η επανάληψη

6 Προσοχή ! Μία επανάληψη με την εντολή ΓΙΑ μπορεί να λυθεί και με τις εντολές ΟΣΟ ή ΑΡΧΗ ΕΠΑΝΑΛΗΨΗΣ. Το αντίθετο δε μπορεί να συμβεί

7 Αλγόριθμος παράδειγμα_1 i  1 Όσο i <=100 επανάλαβε Εμφάνισε i i  i + 1 Τέλος_επανάληψης Τέλος παράδειγμα_1 Να γραφεί αλγόριθμος που να εμφανίζει τους αριθμούς από 1 έως 100. Με τη χρήση της εντολής ΟΣΟ

8 Αλγόριθμος παράδειγμα_1 i  1 Αρχή_επανάληψης Εμφάνισε i i  i + 1 Μέχρις_ότου i > 100 Τέλος παράδειγμα_1 Να γραφεί αλγόριθμος που να εμφανίζει τους αριθμούς από 1 έως 100. Με τη χρήση της εντολής ΑΡΧΗ ΕΠΑΝΑΛΗΨΗΣ

9 Αλγόριθμος παράδειγμα_1 Για i από 1 μέχρι 100 Εμφάνισε i Τέλος_επανάληψης Τέλος παράδειγμα_1 Να γραφεί αλγόριθμος που να εμφανίζει τους αριθμούς από 1 έως 100. Με τη χρήση της εντολής ΓΙΑ Προφανώς η ΓΙΑ είναι η καταλληλότερη για την άσκηση αυτή

10 Αλγόριθμος παράδειγμα_2 Διάβασε x Όσο x > 0 επανάλαβε Εμφάνισε x Διάβασε x Τέλος_επανάληψης Τέλος παράδειγμα_2 Να γραφεί αλγόριθμος που να διαβάζει ένα άγνωστο πλήθος θετικών αριθμών και να εμφανίζει τον κάθε αριθμό. Μόλις δοθεί αριθμός όχι θετικός ο αλγόριθμος να σταματά Αλγόριθμος παράδειγμα_2 Διάβασε x Αρχή_επανάληψης Εμφάνισε x Διάβασε x Μέχρις_ότου x < 0 Τέλος παράδειγμα_2 Αυτή η άσκηση δε λύνεται με την εντολή επανάληψης ΓΙΑ, αφού δε γνωρίζουμε το πλήθος των επαναλήψεων

11 Αλγόριθμος: ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ ΑΛΑ ΡΩΣΙΚΑ Κλασικός τρόπος 45 x Στον υπολογιστή Άθροισμα: 855


Κατέβασμα ppt "Επανάληψη. Επανάληψη με όσο Όσο συνθήκη επανάλαβε εντολές Τέλος_επανάληψης συνθήκη εντολές (πράξεις) ψευδής αληθής Πως δουλεύει: Όσο η συνθήκη είναι αληθής."

Παρόμοιες παρουσιάσεις


Διαφημίσεις Google