Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

ΑΕΠΠ 2ο Κεφάλαιο Γεωργαλλίδης Δημήτρης Καθηγητής Πληροφορικής 1 Ο Λύκειο Ρόδου.

Παρόμοιες παρουσιάσεις


Παρουσίαση με θέμα: "ΑΕΠΠ 2ο Κεφάλαιο Γεωργαλλίδης Δημήτρης Καθηγητής Πληροφορικής 1 Ο Λύκειο Ρόδου."— Μεταγράφημα παρουσίασης:

1 ΑΕΠΠ 2ο Κεφάλαιο Γεωργαλλίδης Δημήτρης Καθηγητής Πληροφορικής 1 Ο Λύκειο Ρόδου

2 ΔΟΜΕΣ ΕΠΑΝΑΛΗΨΗΣ 1. Όσο …επανάλαβε 2. Αρχή Επανάληψης …Μέχρις_ότου … 1. Για … από …. μέχρι…….

3 1. Όσο…. Όσο επανάλαβε εντολή 1 εντολή 2 εντολή 3 ……Τέλος_επανάληψης

4 ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ Όσο … επανάλαβε 1. Με γνωστό πλήθος επαναλήψεων 2. Με άγνωστο πλήθος επαναλήψεων

5 Παράδειγμα Όσο Με γνωστό πλήθος επαναλήψεων Αλγόριθμος αριθμοί1 i 1 i ← 1 Όσο i<=10 επανάλαβε Εμφάνισε i i i+1 i ← i+1Τέλος_επανάληψης Τέλος αριθμοί1 Να γραφτεί αλγόριθμος που να εμφανίζει τους αριθμούς 1 έως 10 i ← i+1 ΑΡΧΗ ΤΕΛΟΣ Εμφάνισε i Χ<=10 ΝΑΙ ΟΧΙ i ← 1

6 Εφαρμογή: Να γραφτεί αλγόριθμος που να εμφανίζει τους αριθμούς 10 έως 1 Για το σπίτι (διαφ. 6) Να γραφτεί αλγόριθμος που να εμφανίζει τους άρτιους αριθμούς 2 έως 10

7 Παράδειγμα Όσο Με γνωστό πλήθος επαναλήψεων Αλγόριθμος αριθμοί2 i ………. i ← ………. Όσο i…….. επανάλαβε Τέλος_επανάληψης Τέλος αριθμοί2

8 Παράδειγμα 2.14, σελ Να γραφτεί αλγόριθμος που να διαβάζει έναν ακέραιο αριθμό Ν, να εμφανίζει τους αριθμούς 1 έως Ν Τι θα αλλάξουμε στον προηγούμενο αλγόριθμο;

9 Παράδειγμα Όσο Αλγόριθμος αριθμοί3 διάβασε Ν i 1 i ← 1 Όσο i<=N επανάλαβε Εμφάνισε i i i+1 i ← i+1Τέλος_επανάληψης Τέλος αριθμοί3 Να γραφτεί αλγόριθμος που να εμφανίζει τους αριθμούς 1 έως N i ← i+1 ΑΡΧΗ ΤΕΛΟΣ Εμφάνισε i i <= Ν ΝΑΙ ΟΧΙ i ← 1

10 Σκελετός Όσο με γνωστό πλήθος επαναλήψεων (διαφ.10) i 1 i ← 1 Όσο i<=….. επανάλαβε ΕΝΤΟΛΗ 1 ΕΝΤΟΛΗ 2.. ΕΝΤΟΛΗ Κ i i + 1 i ← i + 1Τέλος_επανάληψης i <=….. ΝΑΙ ΟΧΙ i ← 1 ΕΝΤΟΛΕΣ i ← i+1

11 Όσο με γνωστό πλήθος επαναλήψεων Εφαρμογή: Να γραφτεί αλγόριθμος που να διαβάζει 10 αριθμούς και να τους εμφανίζει Για το σπίτι: (διαφ. 11) Να γραφτεί αλγόριθμος που να διαβάζει 10 αριθμούς και να εμφανίζει μόνο όσους είναι μεγαλύτεροι από το μηδέν.

12 Παράδειγμα Όσο Με γνωστό πλήθος επαναλήψεων Αλγόριθμος αριθμοί4 i ………. i ← ………. Όσο i…….. επανάλαβε i i + 1 i ← i + 1Τέλος_επανάληψης Τέλος αριθμοί4

13 Παράδειγμα Όσο με γνωστό πλήθος επαναλήψεων Αλγόριθμος αριθμοί4 i 1 i ← 1 Όσο i<=10 επανάλαβε Διάβασε Χ Εμφάνισε Χ i i + 1 i ← i + 1Τέλος_επανάληψης Τέλος αριθμοί4 Να γραφτεί αλγόριθμος που να διαβάζει 10 αριθμούς και να τους εμφανίζει

14 Για το σπίτι: Α) Βιβλίο (θεωρία σελ ) (θεωρία σελ ) Β) Ασκήσεις από διαφάνειες 6, 11

15 ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ Όσο … επανάλαβε 1. Με γνωστό πλήθος επαναλήψεων 2. Με άγνωστο πλήθος επαναλήψεων

16 2. Παράδειγμα Όσο με χρήση «τιμή φρουρός» Να γραφτεί αλγόριθμος ο οποίος να διαβάζει τους αριθμούς που πληκτρολογεί ένας χρήστης. Η εισαγωγή των αριθμών θα σταματάει αν ο χρήστης εισάγει το 0. Να γραφτεί αλγόριθμος ο οποίος να διαβάζει τους αριθμούς που πληκτρολογεί ένας χρήστης. Η εισαγωγή των αριθμών θα σταματάει αν ο χρήστης εισάγει το 0. Στο τέλος να εμφανίζονται: α) το πλήθος των αριθμών β) το άθροισμά τους. Στο τέλος να εμφανίζονται: α) το πλήθος των αριθμών β) το άθροισμά τους.

17 τιμή φρουρός Αλγόριθμος παράδειγμα_όσο Σ Σ ← 0 Π 0 Π ← 0 Διάβασε Χ Όσο Χ <> 0 επανάλαβε Σ Σ + Χ Σ ← Σ + Χ Π Π + 1 Π ← Π + 1 Διάβασε Χ Τέλος_επανάληψης Εμφάνισε Σ Τέλος παράδειγμα_όσο

18 Παράδειγμα Όσο Δοκιμάστε τον αλγόριθμο: 1. Παραλείποντας την Σ 0 1. Παραλείποντας την Σ ← 0 2. Παραλείποντας τη Διάβασε Χ 3. Βάζοντας την Εμφάνισε Σ μέσα στην επανάληψη 4. Αλλάζοντας τη σειρά εκτέλεσης των εντολών του βρόχου.

19 Σκελετός Όσο με χρήση «τιμής φρουρός» Διάβασε Χ Όσο Χ <> ….. επανάλαβε ΕΝΤΟΛΗ 1 ΕΝΤΟΛΗ 2.. ΕΝΤΟΛΗ Κ Διάβασε Χ Τέλος_επανάληψης Χ<>0 ΝΑΙ ΟΧΙ Διάβασε Χ ΕΝΤΟΛΕΣ

20 Εφαρμογή: παρ. 2.15, σελ Να γραφτεί αλγόριθμος που να διαβάζει το όνομα και τους βαθμούς κάθε μαθητή μιας τάξης σε τρία μαθήματα. Να γραφτεί αλγόριθμος που να διαβάζει το όνομα και τους βαθμούς κάθε μαθητή μιας τάξης σε τρία μαθήματα. Έπειτα να υπολογίζει και να εμφανίζει το μέσο όρο του. Έπειτα να υπολογίζει και να εμφανίζει το μέσο όρο του. Η διαδικασία θα σταματά όταν ως όνομα δοθεί το κενό. Έπειτα να εμφανίζεται το πλήθος των μαθητών αυτών. Η διαδικασία θα σταματά όταν ως όνομα δοθεί το κενό. Έπειτα να εμφανίζεται το πλήθος των μαθητών αυτών. (Υπόδειξη: Χρήση τιμών φρουρών) (Υπόδειξη: Χρήση τιμών φρουρών)

21 Εφαρμογή: παρ. 2.16, σελ. 40

22 Να γραφεί αλγόριθμος που αρχικά να διαβάζει ένα διαθέσιμο ποσό για αγορές. Έπειτα, θα διαβάζει διαδοχικά την τιμή των προς αγορά προϊόντων. Οι αγορές θα σταματούν πριν η ενδεχόμενη αγορά κάποιου προϊόντος οδηγήσει στην υπέρβαση του διαθέσιμου ποσού. Να γραφεί αλγόριθμος που αρχικά να διαβάζει ένα διαθέσιμο ποσό για αγορές. Έπειτα, θα διαβάζει διαδοχικά την τιμή των προς αγορά προϊόντων. Οι αγορές θα σταματούν πριν η ενδεχόμενη αγορά κάποιου προϊόντος οδηγήσει στην υπέρβαση του διαθέσιμου ποσού. Εφαρμογή (διαφ. 22): καλάθι αγορών

23 Για το σπίτι: Α) Βιβλίο Μαθητή Σελ , (όχι την εντολή μέχρις ότου, σελ. 42) Σελ , (όχι την εντολή μέχρις ότου, σελ. 42) Β) Ασκήσεις 32, 33, 34 32, 33, 34

24 ΠΙΝΑΚΕΣ ΤΙΜΩΝ ΣΤΗΝ ΟΣΟ - ΕΠΑΝΑΛΑΒΕ ΑΝΑΛΥΤΙΚΟΣ ΑΝΑΛΥΤΙΚΟΣ ΣΥΝΟΠΤΙΚΟΣ ΣΥΝΟΠΤΙΚΟΣ

25 Βλ. φυλλάδιο Πίνακες τιμών όσο_επανάλαβε

26 Εφαρμογή διαφ.25 0: Σ  0

27 Για το σπίτι ασκ. 46, σελ. 54 (α γίνει με πίνακα τιμών)

28 Εύρεση MIN - MAX

29 Για το σπίτι (διαφ.28)

30 Για το σπίτι: Α) Βιβλίο Μαθητή Σελ , (όχι την εντολή μέχρις ότου, σελ. 42) Σελ , (όχι την εντολή μέχρις ότου, σελ. 42) Β) Ασκήσεις Διαφάνειες 25, 26, 28 Διαφάνειες 25, 26, 28 Μια άσκηση από την τράπεζα θεμάτων (βλ. Μια άσκηση από την τράπεζα θεμάτων (βλ.

31 2. Μέχρις_ότου … Επανάλαβε εντολή 1 εντολή 2 εντολή 3 …… Μέχρις_ότου Μέχρις_ότου

32 Έλεγχος εισόδου δεδομένων Μέχρις_ότου 1. Να γράψετε την εντολή που διαβάζει το ύψος ενός μαθητή 2. Να τροποποιήσετε την εντολή ώστε να εξασφαλίζεται ότι ο χρήστης θα δίνει πάντα θετική τιμή.

33 Έλεγχος εισόδου δεδομένων σε Αλγόριθμο με τη Μέχρις_ότου Επανάλαβεδιάβασε Μέχρις_ότου …………………………..

34 Εφαρμογή 1. Να γραφεί αλγόριθμος ο οποίος να εμφανίζει το εμβαδόν ενός τετραγώνου, λαμβάνοντας σαν είσοδο την πλευρά του. Η είσοδος της πλευράς να γίνεται με τέτοιο τρόπο ώστε να εξασφαλίζεται ότι ο χρήστης θα δίνει πάντα θετική τιμή.

35 Έλεγχος εισόδου δεδομένων Μέχρις_ότου Επανάλαβε διάβασε φύλο Μέχρις_ότου ………………………….. Επανάλαβε διάβασε βαθμό Μέχρις_ότου …………………………..

36 Έλεγχος εισόδου δεδομένων Μέχρις_ότου Επανάλαβε διάβασε φύλο Μέχρις_ότου φύλο=‘Α’ ή ‘φύλο=‘Γ’ Επανάλαβε διάβασε βαθμό Μέχρις_ότου βαθμό >= 0 και βαθμό = 0 και βαθμό <= 20

37 Για το σπίτι: Έλεγχος εισόδου δεδομένων Μέχρις_ότου Να γραφτεί αλγόριθμος ο οποίος να υπολογίζει το εμβαδόν ενός τριγώνου έτσι ώστε να εξασφαλίζεται η εγκυρότητα των δεδομένων. Να γραφτεί αλγόριθμος ο οποίος να υπολογίζει το εμβαδόν ενός τριγώνου έτσι ώστε να εξασφαλίζεται η εγκυρότητα των δεδομένων. Υπόδειξη: Μπορούμε να χρησιμοποιήσουμε είτε μία δομή ελέγχου και για τα δύο δεδομένα (βάση, ύψος), είτε μία ξεχωριστή δομή για το καθένα. Και οι δύο λύσεις είναι σωστές. Να διαλέξετε αυτή που είναι «φιλικότερη προς τον χρήστη». Υπόδειξη: Μπορούμε να χρησιμοποιήσουμε είτε μία δομή ελέγχου και για τα δύο δεδομένα (βάση, ύψος), είτε μία ξεχωριστή δομή για το καθένα. Και οι δύο λύσεις είναι σωστές. Να διαλέξετε αυτή που είναι «φιλικότερη προς τον χρήστη».

38 Μενού Επιλογής Με τη Μέχρις_ότου

39 Παράδειγμα 2.17 σελ. 40 βιβλίου

40 Για το σπίτι: Α) Βιβλίο Μαθητή Παρ. 2.17, σελ Παρ. 2.17, σελ Β) Ασκήσεις 48 (σελ. 54) 48 (σελ. 54) Διαφάνεια 39 Διαφάνεια 39

41 3. Για … από …. μέχρι… Για i από 1 μέχρι 100 εντολή 1 εντολή 2 εντολή 3 ……Τέλος_επανάληψης

42 Για … από …. μέχρι… με βήμα Να γραφτεί αλγόριθμος που να εμφανίζει τους αριθμούς 1 έως 100 Αλγόριθμος εμφάνιση _αριθμών Για i από 1 μέχρι 100 εμφάνισε i εμφάνισε iΤέλος_επανάληψης Τέλος εμφάνιση_αριθμών

43 Για … από …. μέχρι… με βήμα Να γραφτεί αλγόριθμος που να εμφανίζει τους άρτιους αριθμούς 1 έως 100 Αλγόριθμος εμφάνιση_άρτιων Για i από 2 μέχρι 100 με βήμα 2 εμφάνισε i εμφάνισε iΤέλος_επανάληψης Τέλος εμφάνιση_άρτιων Εφαρμογή: Να γραφτεί αλγόριθμος που να εμφανίζει τους περιττούς αριθμούς 99 έως 1

44 Για … από …. μέχρι… με βήμα Να γραφτεί αλγόριθμος που να εμφανίζει τους περιττούς αριθμούς 99 έως 1 Αλγόριθμος εμφάνιση_περιττών Για i από 99 μέχρι 1 με βήμα -2 εμφάνισε i εμφάνισε iΤέλος_επανάληψης Τέλος εμφάνιση_περιττών

45

46

47 ΕΦΑΡΜΟΓΗ

48 Για … από …. μέχρι… με βήμα Να γραφτεί αλγόριθμος που να εμφανίζει τις διαδοχικές τιμές της συνάρτησης f(x)=2x+5 στο διάστημα [0,2] με βήμα 0,1

49 Για … από …. μέχρι… με βήμα Να γραφτεί αλγόριθμος που να εμφανίζει τις διαδοχικές τιμές της συνάρτησης f(x)=2x+5 στο διάστημα [0,2] με βήμα 0,1 Αλγόριθμος εμφάνιση_τιμών_συνάρτησης Για Χ από 0 μέχρι 2 με βήμα 0,1 εμφάνισε 2*Χ+5 εμφάνισε 2*Χ+5Τέλος_επανάληψης Τέλος εμφάνιση_τιμών_συνάρτησης

50 Για το σπίτι: Α) Βιβλίο Μαθητή Παρ. 2.18, σελ. 41 Παρ. 2.18, σελ. 41 Β) Ασκήσεις 29, σελ , σελ (πίνακας τιμών), 47 (σελ. 54) 46 (πίνακας τιμών), 47 (σελ. 54) Γ)Θέματα Δ 3, 6 (Από Φ/Τ)


Κατέβασμα ppt "ΑΕΠΠ 2ο Κεφάλαιο Γεωργαλλίδης Δημήτρης Καθηγητής Πληροφορικής 1 Ο Λύκειο Ρόδου."

Παρόμοιες παρουσιάσεις


Διαφημίσεις Google