Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ ΟΣΟ ΣΥΝΘΗΚΗ ΕΠΑΝΑΛΑΒΕ ΕΝΤΟΛΕΣ ΕΝΤΟΛΕΣΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ.

Παρόμοιες παρουσιάσεις


Παρουσίαση με θέμα: "ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ ΟΣΟ ΣΥΝΘΗΚΗ ΕΠΑΝΑΛΑΒΕ ΕΝΤΟΛΕΣ ΕΝΤΟΛΕΣΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ."— Μεταγράφημα παρουσίασης:

1 ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ ΟΣΟ ΣΥΝΘΗΚΗ ΕΠΑΝΑΛΑΒΕ ΕΝΤΟΛΕΣ ΕΝΤΟΛΕΣΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

2 ΝΑ ΕΜΦΑΝΙΣΤΟΥΝ ΟΙ ΑΡΙΘΜΟΙ 1-100

3 ΚΟΥΤΟΣ ΤΡΟΠΟΣ ΓΡΑΨΕ 1 ΓΡΑΨΕ 2 ΓΡΑΨΕ 3 ΓΡΑΨΕ 4 ΓΡΑΨΕ 5 ΓΡΑΨΕ ΓΡΑΨΕ 100

4 Τι επαναλαμβάνεται ι  1 Αρχικοποίηση Εμφάνισε ι Ι  ι+1

5 Ο Αλγόριθμος ΠΡΟΓΡΑΜΜΑ ΑΡΙΘΜΟΙ1_100 ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Ι ΑΡΧΗ Ι  1 ΟΣΟ Ι <= 100 ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ Ι Ι  Ι + 1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΑΡΙΘΜΟΙ1_100 Ι

6 μεταβλητή Αθροιστής Για να αθροίσουμε κάποια δεδομένα χρησιμοποιούμε μία μεταβλητή π.χ. Σ Που την αρχικοποιούμε με 0, Σ  0 Σ  Σ+ΙΣ  Σ+Χ

7 Να προσθέσουμε του αριθμούς ΠΡΟΓΡΑΜΜΑ ΑΡΙΘΜΟΙ1_100 ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Ι, Σ ΑΡΧΗ Ι <- 1 Σ <- 0 ΟΣΟ Ι <= 100 ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ Ι Σ <- Σ + Ι Ι <- Ι + 1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ' = ', Σ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΑΡΙΘΜΟΙ1_100 ΙΣΙΣ

8 Να γράψετε αλγόριθμο (ψευδογλώσσα και διάγραμμα ροής) που να διαβάζει αριθμούς από το πληκτρολόγιο και να υπολογίζει το άθροισμά τους. Ο αλγόριθμος σταματά όταν δώσουμε το 999 (τιμή φρουρός) σαν είσοδο. Στη συνεχεία να προστεθούν οι απαραίτητες εντολές ώστε να υπολογιστεί και ο μέσος όρος των αριθμών. (Θα χρησιμοποιηθεί μεταβλητή αθροιστή π.χ. Σ  Σ+α).

9 μεταβλητή ΜΕΤΡΗΤΗΣ Για να μετρήσουμε το πλήθος κάποιων δεδομένων, συμβάντων π.χ. άρτιων αριθμών που διαβάζονται χρησιμοποιούμε μία μεταβλητή π.χ. μ Που την αρχικοποιούμε με την κατάλληλη τιμή, μ  0 μ  μ+1

10 Μέσος Όρος MO  Αθροιστής / Μετρητής ΜΟ  Αθροιστής / 100

11 ΠΡΟΓΡΑΜΜΑ ΣΤΑΤΙΣΤΙΚΑ_ΗΛΙΚΙΩΝ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Μ, Λ, Σ, ΗΛΙΚΙΑ ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ ΑΡΧΗ Μ 0 ΕΠΑΝΑΛΑΒΕ ΑΝ ΗΛΙΚΙΑ 0 ΤΟΤΕ ΜΟ <- Σ/(Μ + Λ) ΓΡΑΨΕ 'ΜΕΣΟΣ ΟΡΟΣ ΗΛΙΚΙΩΝ ΠΟΥ ΔΙΑΒΑΣΤΗΚΑΝ: ', ΜΟ ΑΛΛΙΩΣ ΓΡΑΨΕ 'ΡΕ ΣΥ ΔΕΝ ΕΔΩΣΕΣ ΚΑΜΙΑ ΗΛΙΚΙΑ' ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΣΤΑΤΙΣΤΙΚΑ_ΗΛΙΚΙΩΝ

12 ΜΕΧΡΙΣ_ΟΤΟΥ ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ ΕΝΤΟΛΕΣ ΜΕΧΡΙΣ_ΟΤΟΥ ΣΥΝΘΗΚΗ ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ ΔΙΑΒΑΣΕ Χ ΜΕΧΡΙΣ_ΟΤΟΥ Χ>=0 ΚΑΙ Χ<=20

13 ΕΜΦΑΝΙΣΗ ΑΡΙΘΜΩΝ 1-10 ΜΕ ΟΣΟ ΠΡΟΓΡΑΜΜΑ Αριθμοί1_10 ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Ι ΑΡΧΗ Ι <- 1 ΟΣΟ Ι <= 10 ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ Ι Ι <- Ι + 1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Αριθμοί1_10

14 ΕΜΦΑΝΙΣΗ ΑΡΙΘΜΩΝ 1-10 ΜΕ ΟΣΟ

15 ΕΜΦΑΝΙΣΗ ΑΡΙΘΜΩΝ 1-10 ΜΕ ΜΕΧΡΙΣ_ΟΤΟΥ ;

16 ΠΡΟΓΡΑΜΜΑ Αριθμοί1_10 ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Ι ΑΡΧΗ Ι 10 ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Αριθμοί1_10

17 ΕΜΦΑΝΙΣΗ ΑΡΙΘΜΩΝ 1-10 ΜΕ ΜΕΧΡΙΣ_ΟΤΟΥ

18 Να αναπτυχθεί αλγόριθμος που θα διαβάζει έναν αριθμό (μεγαλύτερο του 0, να γίνει έλεγχος με μέχρις ότου) και να υπολογίζει τη σειρά: …… + Ν Ν

19 Να γραφτεί αλγόριθμος που να λύνει το παρακάτω πρόβλημα Από έρευνες έχει φανεί ότι μια κοινότητα μελισσών υπό κανονικές συνθήκες αναπτύσσεται με ρυθμό 3.8 % ετησίως. Αν ένας μελισσοκόμος διαθέτει μελίσσια με συνολικό πληθυσμό 1200 μέλισσες σε πόσα έτη θα ξεπεράσει τη χωρητικότητα των κυψελών του που είναι 2000 μέλισσες;

20 ΓΙΑ ΓΙΑ ΜΕΤΑΒΛΗΤΗ ΑΠΟ ΤΙΜΗ1 ΜΕΧΡΙ ΤΙΜΗ2 ΜΕ_ΒΗΜΑ ΤΙΜΗ3 ΕΝΤΟΛΕΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10 ΜΕ_ΒΗΜΑ 1 ΕΜΦΑΝΙΣΕ Ι ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Ι  1 ΟΣΟ Ι<=10 ΕΠΑΝΑΛΑΒΕ ΕΜΦΑΝΙΣΕ Ι Ι  Ι+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

21 ΕΜΦΑΝΙΣΗ ΑΡΙΘΜΩΝ 1-10 ΜΕ ΓΙΑ, ΙΔΙΟ με ΟΣΟ

22 ΓΙΑ ΓΙΑ Ι ΑΠΟ 10 ΜΕΧΡΙ 1 ΜΕ_ΒΗΜΑ -1 ΕΜΦΑΝΙΣΕ Ι ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Ι  10 ΟΣΟ Ι>=1 ΕΠΑΝΑΛΑΒΕ ΕΜΦΑΝΙΣΕ Ι Ι  Ι-1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

23 ΓΙΑ ΓΙΑ Ι ΑΠΟ 10 ΜΕΧΡΙ 10 ΕΜΦΑΝΙΣΕ Ι ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ Ι ΑΠΟ 10 ΜΕΧΡΙ 1 ΕΜΦΑΝΙΣΕ Ι ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

24 ΕΥΡΕΣΗ ΜΕΓΙΣΤΟΥ Να γραφτεί αλγόριθμος που να διαβάζει 10 αριθμούς και να βρίσκει τον μεγαλύτερο

25 ΕΥΡΕΣΗ ΜΕΓΙΣΤΟΥ ΠΡΟΓΡΑΜΜΑ ΕΥΡΕΣΗ_ΜΕΓΙΣΤΟΥ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: ΜΕΓΙΣΤΟΣ, Α, Ι ΑΡΧΗ ΓΡΑΨΕ 'ΔΩΣΕ 1ο ΑΡΙΘΜΟ' ΔΙΑΒΑΣΕ Α ΜΕΓΙΣΤΟΣ  Α ! ΕΣΤΩ ΜΕΓΙΣΤΟΣ Ο ΠΡΩΤΟΣ ΑΡΙΘΜΟΣ ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 10 ΓΡΑΨΕ 'ΔΩΣΕ ', Ι, 'ο ΑΡΙΘΜΟ' ΔΙΑΒΑΣΕ Α ΑΝ Α > ΜΕΓΙΣΤΟΣ ΤΟΤΕ ΜΕΓΙΣΤΟΣ  Α ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ' Ο ΜΕΓΑΛΥΤΕΡΟΣ ΑΡΙΘΜΟΣ ΠΟΥ ΔΙΑΒΑΣΤΗΚΕ ΕΙΝΑΙ : ', ΜΕΓΙΣΤΟΣ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΕΥΡΕΣΗ_ΜΕΓΙΣΤΟΥ

26 Να αναπτυχθεί αλγόριθμος που θα διαβάζει έναν αριθμό (μεγαλύτερο του 0, να γίνει έλεγχος με μέχρις ότου) και να υπολογίζει τη σειρά: …… + Ν Ν

27 ΑΛΓΟΡΙΘΜΟΣ ΣΕΙΡΑΤΕΤΡΑΓΩΝΩΝ ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ ! …… + Ν Ν ΔΙΑΒΑΣΕ Ν ΜΕΧΡΙΣ_ΟΤΟΥ Ν>0 Σ0Σ0 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν Σ  Σ+Ι^Ι ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΕΜΦΑΝΙΣΕ Σ ΤΕΛΟΣ ΣΕΙΡΑΤΕΤΡΑΓΩΝΩΝ

28

29 Παρατηρήσεις Διάγραμμα ροής ΓΙΑ όπως ή ΟΣΟ. Αρχικά μετέτρεψε την ΓΙΑ σε ΟΣΟ και μετά κάνε διάγραμμα ροής. Ποιες οι διαφορές των εντολών επανάληψης; Πότε θα χρησιμοποιήσετε την κάθε μία;

30 Τι κάνει ο παρακάτω αλγόριθμος; ΑΛΓΟΡΙΘΜΟΣ ΠΟΛ ΔΙΑΒΑΣΕ Α,Β Γ  Α*Β ΕΜΦΑΝΙΣΕ Γ ΤΕΛΟΣ ΠΟΛ

31 ΡΩΣΙΚΟΣ ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ

32 ΡΩΣΙΚΟΣ ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ ΠΡΟΓΡΑΜΜΑ ΡΩΣΙΚΟΣ_ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Μ1, Μ2, Ρ ΑΡΧΗ Ρ 0 ΕΠΑΝΑΛΑΒΕ ΑΝ Μ2 MOD 2 = 1 ΤΟΤΕ Ρ <- Ρ + Μ1 ΤΕΛΟΣ_ΑΝ Μ1 <- Μ1*2 Μ2 <- Μ2 DIV 2 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ Ρ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΡΩΣΙΚΟΣ_ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ

33

34 Παρατηρήσεις για τον ρώσικο πολλαπλασιασμό Απαιτεί πολλαπλασιασμό με το 2 και διαίρεση με το 2. Ο Η/Υ κάνει τις παραπάνω πράξεις ταχύτατα (με ολίσθηση)γιατί χρησιμοποιεί το δυαδικό σύστημα αρίθμησης, όπως εμείς κάνουμε γρήγορα τις πράξεις με το 10. Η μέθοδος του ρώσικου πολλαπλασιασμού χρησιμοποιείται από τον Η/Υ για κάθε πολλαπλασιασμό.

35 ΜΚΔ, Αλγόριθμος Ευκλείδη xyz=(x mod y) ΜΚΔ(150,35)= ΜΚΔ(57,24)=3

36 ΜΚΔ, Αλγόριθμος Ευκλείδη ΠΡΟΓΡΑΜΜΑ ΜΕΓΙΣΤΟΣ_ΚΟΙΝΟΣ_ΔΙΑΙΡΕΤΗΣ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Χ, Υ, Ζ, ΜΚΔ ΑΡΧΗ ΔΙΑΒΑΣΕ Χ, Υ Ζ 0 ΕΠΑΝΑΛΑΒΕ Χ <- Υ Υ <- Ζ Ζ <- Χ MOD Υ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΜΚΔ <- Υ ΓΡΑΨΕ Υ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΜΕΓΙΣΤΟΣ_ΚΟΙΝΟΣ_ΔΙΑΙΡΕΤΗΣ

37 ΠΡΟΠΑΙΔΕΙΑ ΠΡΟΓΡΑΜΜΑ ΠΡΟΠΑΙΔΕΙΑ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Α, Β, Γ ΑΡΧΗ ΓΙΑ Α ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΡΑΨΕ 'ΠΡΟΠΑΙΔΕΙΑ ΤΟΥ ', Α ΓΙΑ Β ΑΠΟ 1 ΜΕΧΡΙ 10 Γ <- Α*Β ΓΡΑΨΕ Β, 'Χ', Α, '=', Γ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΠΡΟΠΑΙΔΕΙΑ

38 Πρόγραμμα Προπαίδεια Μεταβλητές ακέραιες: Α,Β,Γ Αρχή Για Α από 1 μέχρι 10 Για Β από 1 μέχρι 10 Γ  Α*Β Γράψε Α, ' * ', Β, ' = ', Γ τέλος_επανάληψης Τέλος_προγράμματος ABΓ

39 ΑΒΓ ……….…..…… Πρόγραμμα Προπαίδεια Μεταβλητές ακέραιες: Α,Β,Γ Αρχή Για Α από 1 μέχρι 10 Για Β από 1 μέχρι 10 Γ  Α*Β Γράψε Α, ' * ', Β, ' = ', Γ τέλος_επανάληψης Τέλος_προγράμματος

40 Στους εμφωλευμένους βρόχους ισχύουν: Ο εσωτερικός βρόχος πρέπει να βρίσκεται ολόκληρος μέσα στον εξωτερικό. Ο βρόχος που ξεκινάει τελευταίος, πρέπει να ολοκληρώνεται πρώτος. Η είσοδος σε κάθε βρόχο υποχρεωτικά γίνεται από την αρχή του. Δεν μπορεί να χρησιμοποιηθεί η ίδια μεταβλητή ως μετρητής δύο ή περισσοτέρων βρόχων που ο ένας βρίσκεται στο εσωτερικό του άλλου. Πρόγραμμα Προπαίδεια Μεταβλητές ακέραιες: Α,Β,Γ Αρχή Για Α από 1 μέχρι 10 Για Β από 1 μέχρι 10 Γ  Α*Β Γράψε Α, ' * ', Β, ' = ', Γ τέλος_επανάληψης Τέλος_προγράμματος

41 Παράδειγμα (Παν. Εξετάσεις 2005) ∆ίνεται το παρακάτω τμήμα αλγορίθμου: S ← 0 Για I από 2 μέχρι 100 με_βήμα 2 S ← S + I Τέλος_επανάληψης 1. Να μετατραπεί σε ισοδύναμο με χρήση της δομής Όσο … Επανάλαβε. Μονάδες 5 2. Να μετατραπεί σε ισοδύναμο με χρήση της δομής Αρχή_επανάληψης.. μέχρις_ότου. Μονάδες 5


Κατέβασμα ppt "ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ ΟΣΟ ΣΥΝΘΗΚΗ ΕΠΑΝΑΛΑΒΕ ΕΝΤΟΛΕΣ ΕΝΤΟΛΕΣΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ."

Παρόμοιες παρουσιάσεις


Διαφημίσεις Google