Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Ανάπτυξη Εφαρμογών1 Παραδείγματα αλγορίθμων: Η παρασκευή ενός κέικ Η εύρεση του μέγιστου κοινού διαιρέτη δύο αριθμών Η εκκίνηση ενός αυτοκινήτου Η πρωινή.

Παρόμοιες παρουσιάσεις


Παρουσίαση με θέμα: "Ανάπτυξη Εφαρμογών1 Παραδείγματα αλγορίθμων: Η παρασκευή ενός κέικ Η εύρεση του μέγιστου κοινού διαιρέτη δύο αριθμών Η εκκίνηση ενός αυτοκινήτου Η πρωινή."— Μεταγράφημα παρουσίασης:

1 Ανάπτυξη Εφαρμογών1 Παραδείγματα αλγορίθμων: Η παρασκευή ενός κέικ Η εύρεση του μέγιστου κοινού διαιρέτη δύο αριθμών Η εκκίνηση ενός αυτοκινήτου Η πρωινή προετοιμασία για το σχολείο / νυχτερινή έξοδο Αλγόριθμος είναι μια πεπερασμένη σειρά ενεργειών, αυστηρά καθορισμένων και εκτελέσιμων σε πεπερασμένο χρόνο, που στοχεύουν στην επίλυση ενός προβλήματος. Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων 2.1 Τι είναι αλγόριθμος Η αλληλουχία των ενεργειών δεν είναι πάντα μία και μοναδική!!!

2 Ανάπτυξη Εφαρμογών2 Είσοδος (input): καμία, μία ή περισσότερες τιμές δεδομένων πρέπει να δίνονται ως είσοδοι στον αλγόριθμο Έξοδος (output): ο αλγόριθμος «παράγει» τουλάχιστον μία τιμή δεδομένων ως αποτέλεσμα Καθοριστικότητα (defineteness): να εξασφαλίζεται ο «ορισμός» κάθε εντολής Περατότητα (finiteness): ο αλγόριθμος τελειώνει μετά από πεπερασμένα βήματα εκτέλεσης. (Διαφορετικά, λέγεται υπολογιστική διαδικασία ) Αποτελεσματικότητα (effectiveness): ο αλγόριθμος αποτελείται από μεμονωμένες απλές-εκτελέσιμες εντολές Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων 2.1 Κριτήρια ενός αλγορίθμου Εκτός ύλης η παράγραφος 2.2

3 Ανάπτυξη Εφαρμογών3 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων 2.3 Περιγραφή & αναπαράσταση αλγορίθμων Ελεύθερο κείμενο: περιγραφή σε φυσική γλώσσα Ο πιο αδόμητος τρόπος αναπαράστασης. Ελλοχεύει ο κίνδυνος να παραβιαστεί το κριτήριο της αποτελεσματικότητας!!!

4 Ανάπτυξη Εφαρμογών4 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων 2.3 Περιγραφή & αναπαράσταση αλγορίθμων Φυσική γλώσσα κατά βήματα: περιγραφή κατά βήματα Σαφώς καλύτερος τρόπος αναπαράστασης από το ελεύθερο κείμενο.

5 Ανάπτυξη Εφαρμογών5 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων 2.3 Περιγραφή & αναπαράσταση αλγορίθμων Διαγραμματικές τεχνικές: συνιστούν ένα γραφικό τρόπο παρουσίασης του αλγορίθμου (η πιο γνωστή είναι το διάγραμμα ροής (flow chart)) Δεν χρησιμοποιείται πλέον συχνά.

6 Ανάπτυξη Εφαρμογών6 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων 2.3 Περιγραφή & αναπαράσταση αλγορίθμων Κωδικοποίηση (coding): πρόγραμμα γραμμένο είτε με μία ψευδογλώσσα είτε σε κάποιο προγραμματιστικό περιβάλλον που όταν εκτελεσθεί θα δώσει τα ίδια αποτελέσματα με τον αλγόριθμο. Εκτελείται από τον υπολογιστή!

7 Ανάπτυξη Εφαρμογών7 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων 2.3 Περιγραφή & αναπαράσταση αλγορίθμων Αναπαράσταση αλγορίθμου με ελεύθερο κείμενο Αρχικά διαβάζουμε τους συντελεστές α, β, γ του τριωνύμου. Στη συνέχεια, υπολογίζουμε τη διακρίνουσα με τον τύπο β 2 -4αγ και ανάλογα με την τιμή της, υπολογίζουμε τις ρίζες του τριωνύμου. Δηλαδή, αν η διακρίνουσα είναι αρνητική, το τριώνυμο δεν επιλύεται στο σύνολο των πραγματικών αριθμών. Ενώ, αν η διακρίνουσα ισούται με μηδέν, η λύση είναι –β/2α. Τέλος, αν η διακρίνουσα είναι θετική, τότε το τριώνυμο έχει τις εξής δύο λύσεις: ……

8 Ανάπτυξη Εφαρμογών8 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων 2.3 Περιγραφή & αναπαράσταση αλγορίθμων Αναπαράσταση αλγορίθμου σε φυσική γλώσσα κατά βήματα 1.Διαβάζουμε τους συντελεστές α, β, γ 2.Υπολογίζουμε τη διακρίνουσα (Δ=β 2 - 4αγ) 3.Αν Δ<0 τότε το τριώνυμο δεν επιλύεται 4.Αν Δ=0 τότε χ=–β/2α 5.Αν Δ>0 τότε χ1=(-β+ΤΡ(Δ))/2α και χ2=(-β-ΤΡ(Δ))/2α

9 Ανάπτυξη Εφαρμογών9 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων 2.3 Περιγραφή & αναπαράσταση αλγορίθμων Αναπαράσταση αλγορίθμου με διάγραμμα ροής ΤΕΛΟΣ ΑΡΧΗ Διάβασε α, β, γ Δ < 0 ΝΑΙ ΟΧΙ Δ  β 2 -4αγ Εκτύπωσε … Εκτύπωσε ‘Δε λύνεται’ Δ > 0 ΟΧΙ ΝΑΙ Εκτύπωσε...

10 Ανάπτυξη Εφαρμογών10 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων 2.3 Περιγραφή & αναπαράσταση αλγορίθμων αναπαράσταση αλγορίθμου με κωδικοποίηση σε ψευδογλώσσα Αλγόριθμος Τριώνυμο Διάβασε α, β, γ Δ  β 2 – 4αγ Αν Δ<0 τότε Εκτύπωσε ‘Δεν υπάρχει λύση’ Αλλιώς_αν Δ=0 τότε χ  -β/(2α) Εκτύπωσε χ Αλλιώς χ 1  -β+ΤΡ(Δ)/(2α) χ 2  -β+ΤΡ(Δ)/(2α) Εκτύπωσε χ 1, χ 2 Τέλος_αν Τέλος Τριώνυμο

11 Ανάπτυξη Εφαρμογών11 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων 2.4 Βασικές συνιστώσες/εντολές  Δομή ακολουθίας  Δομή επιλογής  Διαδικασίες πολλαπλών επιλογών  Εμφωλευμένες Διαδικασίες  Δομή επανάληψης Τα τούβλα είναι τα δομικά στοιχεία ενός κτίσματος Οι εντολές είναι τα δομικά στοιχεία ενός αλγορίθμου

12 Ανάπτυξη Εφαρμογών12 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Δομή ακολουθίας/Σειριακή δομή Παράδειγμα : Να διαβασθούν δύο αριθμοί, να υπολογισθεί και να εκτυπωθεί το γινόμενο τους. Αλγόριθμος Γινόμενο Διάβασε a, b c  a * b Εκτύπωσε c Τέλος Γινόμενο Η ακολουθιακή δομή εντολών χρησιμοποιείται για την αντιμετώπιση απλών προβλημάτων, όπου είναι δεδομένη η σειρά εκτέλεσης ενός συνόλου ενεργειών.

13 Ανάπτυξη Εφαρμογών13 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Δομή ακολουθίας/Σειριακή δομή Αλγόριθμος Γινόμενο Διάβασε a, b c  a * b Εκτύπωσε c Τέλος Γινόμενο Εντολή ανάγνωσης/εισόδου Εντολή εκχώρησης Εντολή εξόδου 1.Να γίνει το διάγραμμα ροής 2.Να υλοποιηθεί σε ψευδογλώσσα Δηλωτικές εντολές Εκτελεστέες εντολές Εντολή είναι μία λέξη που προσδιορίζει μια σαφή ενέργεια α,b,c: Μεταβλητές

14 Ανάπτυξη Εφαρμογών14 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Δομή ακολουθίας Αρχίζει με τη δηλωτική εντολή Αλγόριθμος … Τελειώνει με τη δηλωτική εντολή Τέλος … Εισαγωγή δεδομένων: Διάβασε … Κάθε λέξη της ψευδογλώσσας που προσδιορίζει μια σαφή ενέργεια αποκαλείται εντολή μεταβλητή  έκφραση : εντολή εκχώρησης τιμής γίνονται οι πράξεις στην έκφραση και το αποτέλεσμα εκχωρείται στη μεταβλητή Εκτύπωσε … : ή Εμφάνισε … Γράφει το αποτέλεσμα στον εκτυπωτή ή την οθόνη αντίστοιχα Κριτήρια αλγορίθμων: ικανοποιούνται;

15 Ανάπτυξη Εφαρμογών 15 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Δομή ακολουθίας Παράδειγμα : Με δεδομένη την ακτίνα, να υπολογισθεί το εμβαδόν του αντίστοιχου κύκλου και το εμβαδόν του τετραγώνου που είναι περιγεγραμμένο στον κύκλο αυτόν. Αλγόριθμος Εμβαδά Διάβασε ακτίνα εμβΚύκλου  3.14 * ακτίνα * ακτίνα πλευρά  2 * ακτίνα εμβΤετραγώνου  πλευρά * πλευρά Εκτύπωσε εμβΚύκλου, εμβΤετραγώνου Τέλος Εμβαδά 1.Ποια είναι τα δεδομένα και ποια τα ζητούμενα; 2.Ποιες είναι οι μεταβλητές; 3.Ποιες εντολές χρησιμοποιούνται; Θα μπορούσε να αλλάξει η αλληλουχία τους; 4.Ικανοποιούνται τα κριτήρια των αλγορίθμων;

16 Ανάπτυξη Εφαρμογών16 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Στοιχεία Ψευδογλώσσας Σταθερές (constants) Προκαθορισμένες τιμές που μένουν αμετάβλητες σε όλη τη διάρκεια εκτέλεσης ενός αλγορίθμου. Έχουν όνομα και τιμή (βλέπε συμβάσεις ονομάτων, σελ. 150) Έχουν τύπο (βλέπε §7.2 στη σελίδα 148) 1.Αριθμητικές (Ακέραιες ή Πραγματικές), π.χ. 123, -5, Αλφαριθμητικές ή Χαρακτήρες : Οποιοιδήποτε χαρακτήρες μέσα σε εισαγωγικά, π.χ. “Κώστας”, “Αποτελέσματα2ουΤετραμήνου” 3.Λογικές, δύο τιμές: Αληθής, Ψευδής Παραδείγματα: π=3.14 g=10 ονοματεπώνυμο=“Θεόδωρος Κολοκοτρώνης”

17 Ανάπτυξη Εφαρμογών17 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Στοιχεία Ψευδογλώσσας Μεταβλητές (variables) Ένα γλωσσικό αντικείμενο που παριστάνει ένα δεδομένο Έχουν όνομα και τιμή (βλέπε συμβάσεις ονομάτων, σελ. 150) Έχουν τύπο (βλέπε §7.2 στη σελίδα 148) 1.Αριθμητικές (Ακέραιες ή Πραγματικές), π.χ. 123, -5, Αλφαριθμητικές ή Χαρακτήρες : Οποιοιδήποτε χαρακτήρες μέσα σε εισαγωγικά, π.χ. “Κώστας”, “Αποτελέσματα2ουΤετραμήνου” 3.Λογικές, δύο τιμές: Αληθής, Ψευδής Παραδείγματα: ποσό  10 σύνολοΜαθητών10ουΛυκείου  αιμοδοσία  πίεση > 10 ΚΑΙ αιματοκρίτης > 38

18 Ανάπτυξη Εφαρμογών18 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Στοιχεία Ψευδογλώσσας Τελεστές (operators) Σύμβολα που χρησιμοποιούνται στις διάφορες πράξεις Έχουν τύπο 1.Αριθμητικοί: +, -, *, /, ^, div, mod (βλέπε §7.5 στη σελίδα 152) 2.Συγκριτικοί: ,  3.Λογικοί: και, ή, όχι Ιεραρχία αριθμητικών πράξεων 1.Παρενθέσεις 2. Ύψωση σε δύναμη 3.Πολλαπλασιασμός-Διαίρεση-DIV-MOD 4.Πρόσθεση-Αφαίρεση Ιεραρχία τελεστών 1.Αριθμητικοί 2.Συγκριτικοί 3.Λογικοί

19 Ανάπτυξη Εφαρμογών19 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Στοιχεία Ψευδογλώσσας Εκφράσεις (expressions) Σχηματίζονται από τελεστέους (σταθερές, μεταβλητές και συναρτήσεις) και από τελεστές. Αποδίδονται τιμές στις μεταβλητές και στις σταθερές και στη συνέχεια εκτελούνται οι πράξεις που ορίζουν οι τελεστές. Παραδείγματα: μαθητέςΑ1 + μαθητέςΑ2 + μαθητέςΑ3 5*α-β/2+4*(γ+1) 2*ημ(ω)+2^2 πίεση > 10 Βρέχει ή Χιονίζει

20 Ανάπτυξη Εφαρμογών20 Κεφάλαιο 7 : Βασικές Έννοιες Προγρ/σμού Σημαντικές παρατηρήσεις Σχόλια (!) Πρόκειται για απλές παρατηρήσεις του προγραμματιστή και όχι για εντολές Δεσμευμένες είναι οι λέξεις που χρησιμοποιεί η ΓΛΩΣΣΑ για συγκεκριμένο σκοπό. Π.χ. πρόγραμμα, ακέραιες, αρχή. Οι μεταβλητές μπορούν να αλλάξουν τιμή κατά τη διάρκεια εκτέλεσης του αλγορίθμου αλλά όχι τύπο. Συμβολικές σταθερές είναι τα ονόματα στα οποία αντιστοιχίζουμε σταθερές τιμές. Π.χ. g=9,81, όνομα = “Βασιλεία” Ιεραρχία τελεστών: (1. αριθμητικοί 2. συγκριτικοί 3. λογικοί) Το τμήμα του προγράμματος ανάμεσα στην ΑΡΧΗ και το ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ονομάζεται κύριο μέρος του προγράμματος. & (ampersand) Αν μία εντολή δεν χωράει να γραφεί σε μία γραμμή, την συνεχίζω στην επόμενη, βάζουμε όμως μπροστά αυτό το σύμβολο.

21 Ανάπτυξη Εφαρμογών21 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Δομή επιλογής Απλή επιλογή Αν συνθήκη τότε εντολή Παράδειγμα Αν ΜΟ>=9.5 τότε Εμφάνισε “Προάγεσαι!!!” Αν συνθήκη τότε εντολές Τέλος_αν Παράδειγμα Αν ΜΟ>=0 τότε Εμφάνισε “Προάγεσαι” νέαΤάξη ← “Γ’” Τέλος_αν Άσκηση 15 σε ψευδογλώσσα, πρόγραμμα και διάγραμμα ροής

22 Ανάπτυξη Εφαρμογών22 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Δομή επιλογής Σύνθετη επιλογή Αν συνθήκη τότε εντολές αλλιώς εντολές τέλος_αν Παράδειγμα Αν ΜΟ>=9.5 τότε Εμφάνισε “Προάγεσαι!!!” νέαΤάξη← “Γ” αλλιώς Εμφάνισε “Απορρίπτεσαι…” τέλος_αν Άσκηση 16 σε ψευδογλώσσα, πρόγραμμα και διάγραμμα ροής

23 Ανάπτυξη Εφαρμογών23 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Δομή επιλογής Διαδικασίες πολλαπλών επιλογών Αν συνθήκη1 τότε εντολές αλλιώς_αν συνθήκη2 τότε εντολές αλλιώς_αν συνθήκη3 τότε εντολές αλλιώς εντολές τέλος_αν Παράδειγμα Αν Δ>0 τότε ….. αλλιώς_αν Δ=0 τότε …. αλλιώς …. τέλος_αν Άσκηση 32 σε ψευδογλώσσα, πρόγραμμα και διάγραμμα ροής

24 Ανάπτυξη Εφαρμογών24 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Δομή επιλογής Εμφωλευμένες διαδικασίες Αν συνθήκη1 τότε εντολές Αν συνθήκη2 τότε εντολές αλλιώς_αν συνθήκη4 τότε εντολές τέλος_αν αλλιώς_αν συνθήκη3 τότε εντολές τέλος_αν Παράδειγμα Αν φοίτηση=“Επαρκής”τότε Αν ΜΟ>=9.5 τότε Εμφάνισε “Προάγεσαι!” αλλιώς Εμφάνισε “Παραπέμπεσαι…” τέλος_αν Αλλιώς Εμφάνισε “Επαναλαμβάνεις την τάξη…” τέλος_αν

25 Ανάπτυξη Εφαρμογών25 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Δομή επανάληψης Παραδείγματα Θέλω να εμφανίσω 8 φορές το μήνυμα «Συγχαρητήρια» Θέλω να εμφανίσω τους αριθμούς …. 13 Θέλω να υπολογίσω τον ΜΟ των βαθμών των 2 τετραμήνων για 190 μαθητές Πώς θα λύναμε τα παραπάνω προβλήματα με όσα ξέρουμε μέχρι τώρα; Αλγόριθμος Μήνυμα Εμφάνισε «Συγχαρητήρια» Τέλος Μήνυμα Αλγόριθμος ΜονοίΑριθμοί Εμφάνισε «1» Εμφάνισε «3» Εμφάνισε «5» Εμφάνισε «7» Εμφάνισε «9» Εμφάνισε «11» Εμφάνισε «13» Τέλος ΜονοίΑριθμοί

26 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Δομή επανάληψης 1 η επαναληπτική εντολή: Για Για x από 1 μέχρι 10 Εμφάνισε «Συγχαρητήρια» Τέλος_επανάληψης Για x από 1 μέχρι 21 με_βήμα 2 Εμφάνισε x Τέλος_επανάληψης Μπορώ να χρησιμοποιήσω τη Για προκειμένου: 1.Να εκτελέσω μία ή περισσότερες εντολές πολλές φορές 2.Να δημιουργήσω συγκεκριμένους αριθμούς π.χ. τους ζυγούς αριθμούς Άσκηση 45 σε ψευδογλώσσα, πρόγραμμα και διάγραμμα ροής Άσκηση 46 σε ψευδογλώσσα, πρόγραμμα και διάγραμμα ροής Για x από α μέχρι β με_βήμα γ εντολές…. Τέλος_επανάληψης

27 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Δομή επανάληψης 1 η επαναληπτική εντολή: Για Για x από 3 μέχρι 3 με_βήμα 2 εντολές…. Τέλος_επανάληψης Πόσες φορές εκτελούνται οι παρακάτω βρόχοι; Για x από 3 μέχρι -3 με_βήμα -2 εντολές…. Τέλος_επανάληψης Για x από 3 μέχρι -3 με_βήμα 2 εντολές…. Τέλος_επανάληψης Για x από 3 μέχρι -3 με_βήμα 0 εντολές…. Τέλος_επανάληψης Βήμα>0: έλεγχος για ≤ Βήμα<0: έλεγχος για ≥ Βήμα>0: έλεγχος για ≤ Βήμα<0: έλεγχος για ≥ Απαγορεύεται η μεταβολή του μετρητή μέσα στη Για!!!

28 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Δομή επανάληψης 2 η επαναληπτική εντολή: Όσο Χρειαζόμαστε κι άλλη επαναληπτική εντολή; Παράδειγμα: Γράψε αλγόριθμο που να διαβάζει την ποσότητα χαρτιού για ανακύκλωση (σε κιλά) που μάζεψε κάθε ένα από τα 23 σχολεία του νομού μας. Ο αλγόριθμος να εμφανίζει το σύνολο του χαρτιού που μαζεύτηκε. Παράδειγμα: Γράψε αλγόριθμο που να διαβάζει την ποσότητα χαρτιού για ανακύκλωση (σε κιλά) που μάζεψε κάθε ένα από τα σχολεία του νομού μας και να εμφανίζει το σύνολο του χαρτιού που μαζεύτηκε. O αλγόριθμος να σταματάει την ανάγνωση δεδομένων όταν ο χρήστης εισάγει την τιμή 0.

29 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Δομή επανάληψης 2 η επαναληπτική εντολή: Όσο Όσο συνθήκη επανάλαβε εντολές… Τέλος_επανάληψης Αλγόριθμος Χαρτί συν ← 0 Διάβασε ποσ Όσο ποσ <> 0 επανάλαβε συν ← συν + ποσ Διάβασε ποσ Τέλος_επανάληψης Εμφάνισε συν Τέλος Χαρτί Οι εντολές του βρόχου μπορούν να εκτελεστούν καμία, μία ή περισσότερες φορές! Τι θα συμβεί αν ξεχάσω τη 2 η Διάβασε ποσ; Διάγραμμα ροής Εμφάνιση των αριθμών 1,3, 5,…,99 με Για και με Όσο Τι πρέπει να ισχύει για την τιμή φρουρό;

30 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Δομή επανάληψης 2 η επαναληπτική εντολή: Όσο Δύο αδελφάκια μάζεψαν 175.8€ λέγοντας τα κάλαντα σε συγγενείς και φίλους. Κατευθύνθηκαν αμέσως σε κατάστημα παιχνιδιών όπου συνέλλεξαν κάμποσα παιχνίδια που θα ήθελαν να πάρουν. Δεν ξέρουν όμως αν τα χρήματα επαρκούν για να τα αγοράσουν όλα. Οπότε, τα τοποθέτησαν σε σειρά…προτεραιότητας! Υλοποιήστε πρόγραμμα το οποίο θα διαβάζει μία μία τις τιμές των παιχνιδιών και θα ελέγχει αν μπορεί να αγοραστεί το παιχνίδι. Αν μπορεί να αγοραστεί, να βγάζει μήνυμα στον ταμία «Μπορεί να αγοραστεί», διαφορετικά να βγάζει «Καλά Χριστούγεννα!» και να τερματίζει η ανάγνωση τιμών. Τέλος, να εμφανίζει το συνολικό κόστος και τα ρέστα που πρέπει να λάβουν τα παιδιά. Διάγραμμα ροής Μπορεί να λυθεί με Για;

31 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Δομή επανάληψης 2 η επαναληπτική εντολή: Όσο Ένας μετεωρολόγος εισάγει τις θερμοκρασίες του Ηρακλείου για κάποιο διάστημα και θέλει να βρει τον μέσο όρο τους. Όταν τελειώσει η εισαγωγή θερμοκρασιών, πληκτρολογεί το 100. Σχεδιάστε αλγόριθμο για το πρόβλημα αυτό. Μπορεί να λυθεί με Για; Να υλοποιηθεί σε ψευδογλώσσα. Ένας καθηγητής εισάγει τους βαθμούς των μαθητών του στον ΗΥ και θέλει να υπολογίσει τον μέσο όρο τους, πόσοι είναι κάτω από 10 και πόσοι είναι άνω του Θα εισάγει το 0 για να δηλώσει το τέλος εισαγωγής των δεδομένων. Υλοποιήστε το πρόγραμμα που χρειάζεται ο καθηγητής.

32 Ανάπτυξη Εφαρμογών32 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Δομή επανάληψης Πολλαπλασιασμός αλά ρωσικά Έτσι πολλαπλασιάζουν οι Η/Υ και όσοι δεν ξέρουν προπαίδεια! Απαιτείται μόνο πολλαπλασιασμός και διαίρεση με το 2! Οι Η/Υ πραγματοποιούν πράξεις μεταξύ δυαδικών αριθμών!  πολλαπλασιασμός ενός δυαδικού αριθμού με το 2  ολίσθηση προς τα αριστερά  διαίρεση ενός δυαδικού αριθμού με το 2  ολίσθηση προς τα δεξιά (Για τα ανήσυχα πνεύματα, περισσότερες πληροφορίες στο blog στο βοηθητικό υλικό.)

33 Ανάπτυξη Εφαρμογών33 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Δομή επανάληψης Πολλαπλασιασμός αλά ρωσικά Ελεύθερο κείμενο Έστω 2 θετικοί ακέραιοι αριθμοί. Οι αριθμοί γράφονται δίπλα δίπλα. Ο πρώτος συνεχώς διπλασιάζεται, ενώ ο δεύτερος διαιρείται με το 2 αγνοώντας το δεκαδικό μέρος. Η διαδικασία αυτή συνεχίζεται μέχρι στη 2 η στήλη να προκύψει μονάδα. Το γινόμενο είναι το άθροισμα των στοιχείων της 1 ης στήλης όπου αντίστοιχα στη 2 η υπάρχει περιττός αριθμός! (Διόρθωση στις παλιές εκδόσεις βιβλίων!)

34 Ανάπτυξη Εφαρμογών34 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Δομή επανάληψης Πολλαπλασιασμός αλά ρωσικά Φυσική γλώσσα κατά βήματα

35 Ανάπτυξη Εφαρμογών35 Κεφάλαιο 2 : Βασικές Έννοιες Αλγορίθμων Δομή επανάληψης Πολλαπλασιασμός αλά ρωσικά Ψευδοκώδικας


Κατέβασμα ppt "Ανάπτυξη Εφαρμογών1 Παραδείγματα αλγορίθμων: Η παρασκευή ενός κέικ Η εύρεση του μέγιστου κοινού διαιρέτη δύο αριθμών Η εκκίνηση ενός αυτοκινήτου Η πρωινή."

Παρόμοιες παρουσιάσεις


Διαφημίσεις Google