Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

01/04/20151 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΚΕΦΑΛΑΙΟ 2ο: ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΑΛΓΟΡΙΘΜΩΝ Δ’ ΜΕΡΟΣ : Παραδείγματα Λυμένων Ασκήσεων Καθηγητής.

Παρόμοιες παρουσιάσεις


Παρουσίαση με θέμα: "01/04/20151 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΚΕΦΑΛΑΙΟ 2ο: ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΑΛΓΟΡΙΘΜΩΝ Δ’ ΜΕΡΟΣ : Παραδείγματα Λυμένων Ασκήσεων Καθηγητής."— Μεταγράφημα παρουσίασης:

1 01/04/20151 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΚΕΦΑΛΑΙΟ 2ο: ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΑΛΓΟΡΙΘΜΩΝ Δ’ ΜΕΡΟΣ : Παραδείγματα Λυμένων Ασκήσεων Καθηγητής : Δρίμτζιας Βασίλης

2 01/04/20152 ΑΣΚΗΣΗ 2-1  Να σχεδιάσετε αλγόριθμο που θα διαβάζει 100 αριθμούς, και θα εμφανίζει τον μεγαλύτερο και τον μικρότερο από τους αριθμούς που πληκτρολογήθηκαν. Σημείωση : Η άσκηση μπορεί να λυθεί και με τις 3 εντολές επανάληψης. Καθηγητής : Δρίμτζιας Βασίλης

3 01/04/20153 ΑΣΚΗΣΗ 2-1 ΛΥΣΗ Αλγόριθμος Μέγιστο_Ελάχιστο Διάβασε Χ max  Χ min  X Για i από 2 μέχρι 100 Διάβασε Χ Αν Χ>max τότε max  X Αν Χ

4 01/04/20154 ΑΣΚΗΣΗ 2-2: Να υπολογιστεί το παραγοντικό ενός αριθμού. Αλγόριθμος Παραγοντικό Εκτύπωσε ”Πληκτρολογήστε τον αριθμό” Διάβασε α P  1 Για i από 1 μέχρι α P  P* i Τέλος_επανάληψης Εκτύπωσε ”Το παραγοντικό του αριθμού είναι”, Ρ Τέλος Παραγοντικό Καθηγητής : Δρίμτζιας Βασίλης

5 01/04/20155 ΑΣΚΗΣΗ: Να γραφεί αλγόριθμος που να διαβάζει ζεύγη αριθμών και να σταματάει όταν διαβάσει δύο θετικούς αριθμούς, για τους οποίους α<β Αλγόριθμος Άσκηση2_3 Αρχή_επανάληψης Διάβασε α Διάβασε β Μέχρις_ότου α 0 και β>0 Τέλος Άσκηση2_3 Καθηγητής : Δρίμτζιας Βασίλης

6 01/04/20156 ΑΣΚΗΣΗ 2-4 Ένας συλλέκτης γραμματοσήμων επισκέπτεται στο διαδίκτυο το αγαπημένο του ηλεκτρονικό κατάστημα φιλοτελισμού προκειμένου να αγοράσει γραμματόσημα. Προτίθεται να ξοδέψει μέχρι 1500 ευρώ. Να αναπτύξετε αλγόριθμο ο οποίος: α. Για κάθε γραμματόσημο, να διαβάζει την τιμή και την προέλευσή του (ελληνικό/ξένο) και να επιτρέπει την αγορά του, εφόσον η τιμή του δεν υπερβαίνει το διαθέσιμο υπόλοιπο χρημάτων. ∆ιαφορετικά να τερματίζει τυπώνοντας το μήνυμα «ΤΕΛΟΣ ΑΓΟΡΩΝ». Σημείωση: ∆εν απαιτείται έλεγχος εγκυρότητας για τα δεδομένα εισόδου. β. Να τυπώνει: 1. Το συνολικό ποσό που ξόδεψε ο συλλέκτης. 2. Το πλήθος των ελληνικών και το πλήθος των ξένων γραμματοσήμων που αγόρασε. 3. Το ποσό που περίσσεψε, εφόσον υπάρχει, διαφορετικά το μήνυμα «ΕΞΑΝΤΛΗΘΗΚΕ ΟΛΟ ΤΟ ΠΟΣΟ». Καθηγητής : Δρίμτζιας Βασίλης

7 01/04/20157 ΛΥΣΗ Αλγόριθμος Γραμματόσημα sum  0 stamps_gr  0 stamps_for  0 Διάβασε timi, proel Όσο sum + timi ≤1500 επανάλαβε sum  sum + timi Αν proel=”ελληνικό” τότε stamps_gr  stamps_gr +1 αλλιώς stamps_for  stamps_for + 1 Τέλος_αν Διάβασε timi, proel Τέλος_επανάληψης Εκτύπωσε ”Τέλος αγορών” Εκτύπωσε ”Συνολικό ποσό αγορών”, sum Εκτύπωσε ”Ελληνικά Γραμματόσημα”, stamps_gr Εκτύπωσε ”Ξένα Γραμματόσημα”, stamps_for Aν Sum=1500 τότε Εκτύπωσε ”Εξαντλήθηκε όλο το ποσό” αλλιώς Εκτύπωσε ”Υπόλοιπο”, 1500-sum Τέλος_αν Τέλος Γραμματόσημα Καθηγητής : Δρίμτζιας Βασίλης

8 01/04/20158 Βελτίωση λύσης Τροποποιήστε τον προηγούμενο αλγόριθμο, ώστε να ελέγχει αν η τιμή του γραμματοσήμου είναι θετική και εάν είναι αρνητική ή μηδέν, να ζητάει νέα τιμή. Καθηγητής : Δρίμτζιας Βασίλης

9 01/04/20159 ΛΥΣΗ Αλγόριθμος Γραμματόσημα sum  0 stamps_gr  0 stamps_for  0 Διάβασε timi, proel Όσο timi≤0 επανάλαβε Εκτύπωσε “Μη έγκυρη τιμή γραμματοσήμου, πληκτρολογήστε νέα”’ Διάβασε timi Τέλος_επανάληψης Όσο sum + timi ≤1500 επανάλαβε sum  sum + timi Αν proel=“ελληνικό” τότε stamps_gr  stamps_gr +1 αλλιώς stamps_for  stamps_for + 1 Τέλος_αν Διάβασε timi, proel Όσο timi ≤ 0 επανάλαβε Εκτύπωσε ”Μη έγκυρη τιμή γραμματοσήμου, πληκτρολογήστε νέα” Διάβασε timi Τέλος_επανάληψης Εκτύπωσε ”Τέλος αγορών” Εκτύπωσε “Συνολικό ποσό αγορών”, sum Εκτύπωσε “Ελληνικά Γραμματόσημα”, stamps_gr Εκτύπωσε “Ξένα Γραμματόσημα”, stamps_for Aν Sum=1500 τότε Εκτύπωσε “Εξαντλήθηκε όλο το ποσό” αλλιώς Εκτύπωσε “Υπόλοιπο”, 1500-sum Τέλος_αν Τέλος Γραμματόσημα Καθηγητής : Δρίμτζιας Βασίλης

10 01/04/ Μία εταιρεία ταχυδροµικών υπηρεσιών εφαρµόζει για τα έξοδα αποστολής ταχυδροµικών επιστολών εσωτερικού και εξωτερικού, χρέωση σύµφωνα µε τον παρακάτω πίνακα: Για παράδειγµα τα έξοδα αποστολής µιας επιστολής βάρους 800 γραµµαρίων και προορισµού εσωτερικού είναι 3,5 Ευρώ. Να γράψετε αλγόριθµο ο οποίος: α. Να διαβάζει το βάρος της επιστολής. β. Να διαβάζει τον προορισµό της επιστολής. Η τιµή "ΕΣ" δηλώνει προορισµό εσωτερικού και η τιµή "ΕΞ" δηλώνει προορισµό εξωτερικού. γ. Να υπολογίζει τα έξοδα αποστολής ανάλογα µε τον προορισµό και το βάρος της επιστολής. δ. Να εκτυπώνει τα έξοδα αποστολής. Παρατήρηση: Θεωρείστε ότι ο αλγόριθµος δέχεται τιµές για το βάρος µεταξύ του 0 και του 2000 και για τον προορισµό µόνο τις τιµές "ΕΣ" και "ΕΞ". ΒΑΡΟΣΕΞΟΔΑ ΑΠΟΣΤΟΛΗΣ ΕΣΩΤΕΡΙΚΟΥ ΕΞΟΔΑ ΑΠΟΣΤΟΛΗΣ ΕΞΩΤΕΡΙΚΟΥ ,04, ,57, ,611,5 Καθηγητής : Δρίμτζιας Βασίλης

11 01/04/ ΛΥΣΗ Αλγόριθμος Ταχυδρομείο Εμφάνισε “Δώσε βάρος επιστολής” Διάβασε βάρος Εμφάνισε “Δώσε προορισμό: ΕΣ για Εσωτερικό ή ΕΞ για εσωτερικό” Διάβασε προορισμός Αν προορισμός = “ΕΣ” τότε Αν βάρος ≤500 τότε χρέωση  2,0 αλλιώς_αν βάρος ≤1000 τότε χρέωση  3,5 αλλιώς χρέωση  4,6 Τέλος_αν αλλιώς Αν βάρος ≤500 τότε χρέωση  4,8 αλλιώς_αν βάρος ≤1000 τότε χρέωση  7,2 αλλιώς χρέωση  11,5 Τέλος_αν Τέλος_αν Εμφάνισε “Η χρέωση είναι”, χρέωση Τέλος Ταχυδρομείο Καθηγητής : Δρίμτζιας Βασίλης


Κατέβασμα ppt "01/04/20151 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΚΕΦΑΛΑΙΟ 2ο: ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΑΛΓΟΡΙΘΜΩΝ Δ’ ΜΕΡΟΣ : Παραδείγματα Λυμένων Ασκήσεων Καθηγητής."

Παρόμοιες παρουσιάσεις


Διαφημίσεις Google