Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

1 Τμηματικός προγραμματισμός ονομάζεται η τεχνική σχεδίασης και ανάπτυξης των προγραμμάτων ως ένα σύνολο από απλούστερα τμήματα προγραμμάτων. Υποπρόγραμμα.

Παρόμοιες παρουσιάσεις


Παρουσίαση με θέμα: "1 Τμηματικός προγραμματισμός ονομάζεται η τεχνική σχεδίασης και ανάπτυξης των προγραμμάτων ως ένα σύνολο από απλούστερα τμήματα προγραμμάτων. Υποπρόγραμμα."— Μεταγράφημα παρουσίασης:

1 1 Τμηματικός προγραμματισμός ονομάζεται η τεχνική σχεδίασης και ανάπτυξης των προγραμμάτων ως ένα σύνολο από απλούστερα τμήματα προγραμμάτων. Υποπρόγραμμα ονομάζεται ένα τμήμα προγράμματος που επιτελεί αυτόνομο έργο και έχει γραφεί χωριστά από το υπόλοιπο πρόγραμμα. Πρόβλημα Να γραφεί πρόγραμμα που να διαβάζει τους κωδικούς 100 πόλεων και τις μέσες τιμές θερμοκρασίας σε κάθε μία από αυτές και να τις αποθηκεύει σε δύο πίνακες. Έπειτα, να υπολογίζει και να εμφανίζει τη μικρότερη θερμοκρασία. Κεφάλαιο 10 Τμηματικός προγραμματισμός

2 2 Λύση ΧΩΡΙΣ τμηματικό προγραμματισμό Πρόγραμμα ΘερμοκρασίεςΠόλεων Μεταβλητές Ακέραιες: Θερμ[100], ΚωδΠόλεων[100], χ, min Αρχή ! Εισαγωγή στοιχείων Για χ από 1 μέχρι 100 Διάβασε Θερμ[χ] Διάβασε ΚωδΠόλεων[χ] Τέλος_επανάληψης ! Υπολογισμός ελαχίστου min  Θερμ[1] Για χ από 2 μέχρι 100 Αν Θερμ[χ] < min τότε min  Θερμ[x] Τέλος_αν Τέλος_επανάληψης ! Εμφάνιση αποτελεσμάτων Γράψε ΄Η ελάχιστη θερμοκρασία είναι: ΄, min Τέλος_προγράμματος Κεφάλαιο 10 Τμηματικός προγραμματισμός

3 3 Λύση ΜΕ τμηματικό προγραμματισμό Πρόγραμμα ΘερμοκρασίεςΠόλεων Μεταβλητές Ακέραιες: Θερμ[100], ΚωδΠόλεων[100], min Αρχή ! Εισαγωγή στοιχείων Κάλεσε ΔιάβασμαΠίνακα(Θερμ) Κάλεσε ΔιάβασμαΠίνακα(ΚωδΠόλεων) ! Υπολογισμός ελαχίστου min  ΕύρεσηΕλαχίστου(Θερμ) ! Εμφάνιση αποτελεσμάτων Γράψε ΄Η ελάχιστη θερμοκρασία είναι: ΄, min Τέλος_προγράμματος Κύριο πρόγραμμα Κλήση της διαδικασίας ΔιάβασμαΠίνακα 2 φορές Κλήση της συνάρτησης ΕύρεσηΕλαχίστου με απλή αναφορά στο όνομά της Συνεχίζεται… Κεφάλαιο 10 Τμηματικός προγραμματισμός

4 4 Λύση ΜΕ τμηματικό προγραμματισμό Διαδικασία ΔιάβασμαΠίνακα(Π) Μεταβλητές Ακέραιες: Π[100], χ Αρχή Για χ από 1 μέχρι 100 Διάβασε Π[χ] Τέλος_επανάληψης Τέλος_διαδικασίας Δήλωση της διαδικασίας ΔιάβασμαΠίνακα Δήλωση της συνάρτησης ΕύρεσηΕλαχίστου Συνάρτηση ΕύρεσηΕλαχίστου(Π): Ακέραια Μεταβλητές Ακέραιες: Π[100], χ, min Αρχή min  Π[1] Για χ από 2 μέχρι 100 Αν Π[χ] < min τότε min  Π[x] Τέλος_αν Τέλος_επανάληψης ΕύρεσηΕλαχίστου  min ! SOS Τέλος_συνάρτησης Υποπρογράμματα Κεφάλαιο 10 Τμηματικός προγραμματισμός

5 5 Πού έχουμε ξαναδεί τις συναρτήσεις; Εδώ πρόκειται για ενσωματωμένη συνάρτηση Πρόγραμμα ΥπολογισμόςΥποτίνουσας Μεταβλητές Πραγματικές: α, β, υποτίνουσα Αρχή Διάβασε α, β υποτίνουσα  Τ_Ρ(α^2 + β^2) Γράψε ΄Η υποτίνουσα του τριγώνου είναι: ΄, υποτίνουσα Τέλος_προγράμματος Κεφάλαιο 10 Τμηματικός προγραμματισμός

6 6 Χαρακτηριστικά υποπρογραμμάτων: 1.Κάθε υποπρόγραμμα έχει μόνο μία είσοδο και μόνο μία έξοδο 2.Κάθε υποπρόγραμμα πρέπει να είναι ανεξάρτητο από τα άλλα 3.Κάθε υποπρόγραμμα πρέπει να μην είναι πολύ μεγάλο και να επιτελεί μόνο μία λειτουργία Πλεονεκτήματα τμηματικού προγραμματισμού 1.Διευκολύνει την ανάπτυξη του αλγορίθμου και του αντίστοιχου προγράμματος 2.Διευκολύνει την κατανόηση και διόρθωση του προγράμματος 3.Απαιτεί λιγότερο χρόνο και προσπάθεια στη συγγραφή του προγράμματος 4.Επεκτείνει τις δυνατότητες των γλωσσών προγραμματισμού Κεφάλαιο 10 Τμηματικός προγραμματισμός

7 7 Τύποι υποπρογραμμάτων: 1.Η συνάρτηση (function) είναι ένας τύπος υποπρογράμματος που υπολογίζει και επιστρέφει μόνο μία τιμή με το όνομά της. 2.Η διαδικασία (procedure) είναι ένας τύπος υποπρογράμματος που μπορεί να εκτελεί όλες τις λειτουργίες ενός υποπρογράμματος. Μία παράμετρος είναι μία μεταβλητή που επιτρέπει το πέρασμα της τιμής της από ένα τμήμα προγράμματος σε ένα άλλο. Προσοχή: Μια διαδικασία μπορεί να μεταβάλλει την τιμή των παραμέτρων της Κεφάλαιο 10 Τμηματικός προγραμματισμός

8 8 Ένα υποπρόγραμμα μπορεί να έχει καμία, μία ή περισσότερες παραμέτρους!!! Διαδικασία ΕμφάνισεΝΣτοιχεία(Π, ν) Μεταβλητές Χαρακτήρες: Π[100] Ακέραιες: χ, ν Αρχή Για χ από 1 μέχρι ν Γράψε Π[χ] Τέλος_επανάληψης Τέλος_διαδικασίας Κανόνες λίστας παραμέτρων: 1.Ίσο πλήθος παραμέτρων στην κλήση και στη δήλωση 2.Απόλυτη αντιστοίχιση παραμέτρων στην κλήση και στη δήλωση 3.Οι αντίστοιχες παράμετροι να είναι του ίδιου τύπου Τα ονόματά τους δεν χρειάζεται να είναι ίδια Κεφάλαιο 10 Τμηματικός προγραμματισμός

9 9 Πρόγραμμα ΘερμοκρασίεςΠόλεων Μεταβλητές Ακέραιες: Θερμ[100], ΚωδΠόλεων[100], min Αρχή ! Εισαγωγή στοιχείων Κάλεσε ΔιάβασμαΠίνακα(Θερμ) Κάλεσε ΔιάβασμαΠίνακα(ΚωδΠόλεων) ! Υπολογισμός ελαχίστου min  ΕύρεσηΕλαχίστου(Θερμ) ! Εμφάνιση αποτελεσμάτων Γράψε ΄Η ελάχιστη θερμοκρασία είναι: ΄, min Τέλος_προγράμματος Τυπικές ή πραγματικές παράμετροι??? Πραγματικές (εμφανίζονται στην κλήση) Διαδικασία ΔιάβασμαΠίνακα(Π) Αρχή …………… Τέλος_διαδικασίας Συνάρτηση ΕύρεσηΕλαχίστου(Π): Ακέραια Αρχή …………. Τέλος_συνάρτησης Τυπικές (εμφανίζονται στη δήλωση) Κεφάλαιο 10 Τμηματικός προγραμματισμός


Κατέβασμα ppt "1 Τμηματικός προγραμματισμός ονομάζεται η τεχνική σχεδίασης και ανάπτυξης των προγραμμάτων ως ένα σύνολο από απλούστερα τμήματα προγραμμάτων. Υποπρόγραμμα."

Παρόμοιες παρουσιάσεις


Διαφημίσεις Google