Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Δημιουργώντας νέες λέξεις - Διαδικασίες ΑΒΡΑΜΙΔΟΥ ΜΑΡΓΑΡΙΤΑ ΠΕ20.

Παρόμοιες παρουσιάσεις


Παρουσίαση με θέμα: "Δημιουργώντας νέες λέξεις - Διαδικασίες ΑΒΡΑΜΙΔΟΥ ΜΑΡΓΑΡΙΤΑ ΠΕ20."— Μεταγράφημα παρουσίασης:

1 Δημιουργώντας νέες λέξεις - Διαδικασίες ΑΒΡΑΜΙΔΟΥ ΜΑΡΓΑΡΙΤΑ ΠΕ20

2 Η διαδικασία τετράγωνο έχει δημιουργήσει μια νέα εντολή «τετράγωνο». Εντολές που επιθυμούμε να εκτελεστούν με τη σειρά μπορούν να ομαδοποιηθούν σε ένα νέο όνομα. Ηομαδοποίηση αυτή των εντολών καλείται Διαδικασία. Για τη δημιουργία μιας διαδικασίας πληκτρολογούμε στην καρτέλα «Διαδικασία» την ομάδα εντολών με τη μορφή : (Να γράφονται με μικρά και τόνους οι Διαδικασίες). για επιλεγμένο_όνομα εντολή 1 εντολή 2 ………….. τέλος ΑΒΡΑΜΙΔΟΥ ΜΑΡΓΑΡΙΤΑ ΠΕ20

3 Να δημιουργήσουμε τις 2 διαδικασίες: Τετράγωνο και Τρίγωνο Να δημιουργήσουμε με 3 εντολές ένα σπιτάκι ΑΒΡΑΜΙΔΟΥ ΜΑΡΓΑΡΙΤΑ ΠΕ20

4 Μεταβλητές Σύμφωνα με την παραπάνω Διαδικασία «τετράγωνο», όταν θέλουμε να δημιουργήσουμε τετράγωνα με διαφορετικό μήκος πλευράς, πρέπει να επεμβαίνουμε κάθε φορά στην εντολή μπροστά και να αλλάζουμε το μήκος της πλευράς. Έτσι αν θέλουμε να σχεδιάσουμε ένα τετράγωνο πλευράς 50 εικονοστοιχείων, θα δώσουμε την εντολή : Επανάλαβε 4 [μπ 50 δε 90] Ενώ, αν θέλουμε ένα τετράγωνο πλευράς 150 εικονοστοιχείων, θα δώσουμε την εντολή: Επανάλαβε 4 [μπ 150 δε 90] Για αυτό το λόγο μπορούμε να χρησιμοποιούμε την ίδια πάντα διαδικασία για το σχεδιασμό τετραγώνων διαφορετικών πλευρών χρησιμοποιώντας μεταβλητές. για νέο_τετράγωνο :μήκος στκ επανάλαβε 4 [μπ :μήκος δε 90] τέλος ΑΒΡΑΜΙΔΟΥ ΜΑΡΓΑΡΙΤΑ ΠΕ20

5 Παράδειγμα Τετραγώνου Άσκηση : Να γίνει το ίδιο με ένα τρίγωνο ΑΒΡΑΜΙΔΟΥ ΜΑΡΓΑΡΙΤΑ ΠΕ20

6 Παράδειγμα Τριγώνου ΑΒΡΑΜΙΔΟΥ ΜΑΡΓΑΡΙΤΑ ΠΕ20

7 Παράδειγμα Πολυγώνου Χρησιμοποιούμε 3 μεταβλητές, που δίνουν τιμές : πλευρές, μήκος και μοίρες. ΑΒΡΑΜΙΔΟΥ ΜΑΡΓΑΡΙΤΑ ΠΕ20

8

9 Μια παραλλαγή της διαδικασίας τρίγωνο, χρησιμοποιώντας το μεταβολέα Αντί να δίνουμε κάθε φορά το μήκος της πλευράς στη διαδικασία «τρίγωνο», θα μπορούμε να χρησιμοποιήσουμε έναν μεταβολέα. Επιλέγουμε από τη γραμμή εργαλείων το αντικείμενο «μεταβολέας» και με απλή επιλογή τον δημιουργούμε στην Επιφάνεια εργασίας. Ορίζουμε το όνομα του μεταβολέα και το διάστημα τιμών που θα παίρνει. Άσκηση : Να γίνει το ίδιο με ένα δεκάγωνο ΑΒΡΑΜΙΔΟΥ ΜΑΡΓΑΡΙΤΑ ΠΕ20

10 Στο πολύγωνο χρησιμοποιούμε 2 μεταβολείς. Ο ένας για να του δίνουμε τον αριθμό των πλευρών και ο άλλος για να του δίνουμε το μήκος της κάθε πλευράς. ΑΒΡΑΜΙΔΟΥ ΜΑΡΓΑΡΙΤΑ ΠΕ20

11 Το μόνο που προσθέτουμε είναι ένα κουμπάκι με το όνομα της διαδικασίας «Πολύγωνο» ΑΒΡΑΜΙΔΟΥ ΜΑΡΓΑΡΙΤΑ ΠΕ20

12 Τώρα δημιουργούμε μια διαδικασία με το όνομα «Τετράγωνο» στην οποία δίνουμε το μήκος της κάθε πλευράς με έναν μεταβολέα και έχουμε δημιουργήσει και ένα κουμπί που εκτελεί την εντολή Τετράγωνο. ΑΒΡΑΜΙΔΟΥ ΜΑΡΓΑΡΙΤΑ ΠΕ20

13 Άσκηση : Να κάνετε την παρακάτω άσκηση ΑΒΡΑΜΙΔΟΥ ΜΑΡΓΑΡΙΤΑ ΠΕ20

14


Κατέβασμα ppt "Δημιουργώντας νέες λέξεις - Διαδικασίες ΑΒΡΑΜΙΔΟΥ ΜΑΡΓΑΡΙΤΑ ΠΕ20."

Παρόμοιες παρουσιάσεις


Διαφημίσεις Google