Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Παράδειγμα 5: Θερμοκρασίες Να γραφεί πρόγραμμα που να υπολογίζει τη μέση θερμοκρασία κάθε πόλης για τον παρακάτω πίνακα θερμοκρασιών (δίδονται 30 θερμοκρασίες.

Παρόμοιες παρουσιάσεις


Παρουσίαση με θέμα: "Παράδειγμα 5: Θερμοκρασίες Να γραφεί πρόγραμμα που να υπολογίζει τη μέση θερμοκρασία κάθε πόλης για τον παρακάτω πίνακα θερμοκρασιών (δίδονται 30 θερμοκρασίες."— Μεταγράφημα παρουσίασης:

1 Παράδειγμα 5: Θερμοκρασίες Να γραφεί πρόγραμμα που να υπολογίζει τη μέση θερμοκρασία κάθε πόλης για τον παρακάτω πίνακα θερμοκρασιών (δίδονται 30 θερμοκρασίες 10 πόλεων).Επίσης,για κάθε πόλη, να υπολογίζει πόσες ημέρες η θερμοκρασία ήταν κατώτερη από την αντίστοιχη μέση. ΗΜΕΡΑ ΠΟΛΗ

2 Παράδειγμα 5: Θερμοκρασίες ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30,10], Μέση[10] ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,Σύνολο ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,ΣύνολοΑΡΧΗ ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Σύνολο=0 Σύνολο=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 Σύνολο=Σύνολο +Θερμοκρασία[i,j] Σύνολο=Σύνολο +Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση[j]=Σύνολο/30 Μέση[j]=Σύνολο/30ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Ημέρες=0 Ημέρες=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ Ημέρες=Ημέρες+1 Ημέρες=Ημέρες+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, Ημέρες ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, ΗμέρεςΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

3 Παράδειγμα 5:Θερμοκρασίες ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30,10], Μέση[10] ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,Σύνολο ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,ΣύνολοΑΡΧΗ ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 !Ονομασία προγράμματος ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 !Ονομασία προγράμματος ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Σύνολο=0 Σύνολο=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 Σύνολο=Σύνολο +Θερμοκρασία[i,j] Σύνολο=Σύνολο +Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση[j]=Σύνολο/30 Μέση[j]=Σύνολο/30ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Ημέρες=0 Ημέρες=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ Ημέρες=Ημέρες+1 Ημέρες=Ημέρες+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, Ημέρες ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, ΗμέρεςΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

4 Παράδειγμα 5: Θερμοκρασίες ΠΡΟΓΡΑΜΜΑ Θερμοκρασιες ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30,10], Μέση[10] ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,Σύνολο ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,ΣύνολοΑΡΧΗ ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 !Δήλωση μεταβλητών του ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 !Δήλωση μεταβλητών του ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j προγράμματος, πραγματικές ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j προγράμματος, πραγματικές ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] και ακέραιες ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] και ακέραιες ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Σύνολο=0 Σύνολο=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 Σύνολο=Σύνολο +Θερμοκρασία[i,j] Σύνολο=Σύνολο +Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση[j]=Σύνολο/30 Μέση[j]=Σύνολο/30ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Ημέρες=0 Ημέρες=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ Ημέρες=Ημέρες+1 Ημέρες=Ημέρες+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, Ημέρες ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, ΗμέρεςΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

5 Παράδειγμα 5: Θερμοκρασίες ΠΡΟΓΡΑΜΜΑ Θερμοκρασιες ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30,10], Μέση[10] ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,Σύνολο ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,ΣύνολοΑΡΧΗ ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ! Αρχή προγράμματος ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ! Αρχή προγράμματος ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Σύνολο=0 Σύνολο=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 Σύνολο=Σύνολο +Θερμοκρασία[i,j] Σύνολο=Σύνολο +Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση[j]=Σύνολο/30 Μέση[j]=Σύνολο/30ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Ημέρες=0 Ημέρες=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ Ημέρες=Ημέρες+1 Ημέρες=Ημέρες+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, Ημέρες ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, ΗμέρεςΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

6 Παράδειγμα 5: Θερμοκρασίες ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30,10], Μέση[10] ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,Σύνολο ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,ΣύνολοΑΡΧΗ ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 !Ξεκινά να σαρώνεται ο πίνακας ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 !Ξεκινά να σαρώνεται ο πίνακας ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j Διαβάζονται πρώτα οι ημέρες ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j Διαβάζονται πρώτα οι ημέρες ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] Εισαγωγή δεδομένων ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] Εισαγωγή δεδομένων ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Σύνολο=0 Σύνολο=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 Σύνολο=Σύνολο +Θερμοκρασία[i,j] Σύνολο=Σύνολο +Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση[j]=Σύνολο/30 Μέση[j]=Σύνολο/30ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Ημέρες=0 Ημέρες=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ Ημέρες=Ημέρες+1 Ημέρες=Ημέρες+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, Ημέρες ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, ΗμέρεςΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

7 Παράδειγμα 5: Θερμοκρασίες ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30,10], Μέση[10] ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,Σύνολο ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,ΣύνολοΑΡΧΗ ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] !Σάρωση πίνακα,εισαγωγή ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] !Σάρωση πίνακα,εισαγωγή ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ των δεδομένων διαβάζονται ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ των δεδομένων διαβάζονται ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ οι πόλεις ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Σύνολο=0 Σύνολο=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 Σύνολο=Σύνολο +Θερμοκρασία[i,j] Σύνολο=Σύνολο +Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση[j]=Σύνολο/30 Μέση[j]=Σύνολο/30ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Ημέρες=0 Ημέρες=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ Ημέρες=Ημέρες+1 Ημέρες=Ημέρες+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, Ημέρες ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, ΗμέρεςΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

8 Παράδειγμα 5: Θερμοκρασίες ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30,10], Μέση[10] ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,Σύνολο ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,ΣύνολοΑΡΧΗ ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] !Θεωρείται ως δεδομένο η τιμή ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] !Θεωρείται ως δεδομένο η τιμή ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ που δίνεται από το πληκτρολόγιο ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ που δίνεται από το πληκτρολόγιοΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Σύνολο=0 Σύνολο=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 Σύνολο=Σύνολο +Θερμοκρασία[i,j] Σύνολο=Σύνολο +Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση[j]=Σύνολο/30 Μέση[j]=Σύνολο/30ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Ημέρες=0 Ημέρες=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ Ημέρες=Ημέρες+1 Ημέρες=Ημέρες+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, Ημέρες ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, ΗμέρεςΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

9 Παράδειγμα 5: Θερμοκρασίες ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30,10], Μέση[10] ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,Σύνολο ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,ΣύνολοΑΡΧΗ ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Σύνολο=0 Σύνολο=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 Σύνολο=Σύνολο +Θερμοκρασία[i,j] Σύνολο=Σύνολο +Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση[j]=Σύνολο/30 Μέση[j]=Σύνολο/30ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Ημέρες=0 Ημέρες=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ Ημέρες=Ημέρες+1 Ημέρες=Ημέρες+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, Ημέρες ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, ΗμέρεςΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

10 Παράδειγμα 5: Θερμοκρασίες ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30,10], Μέση[10] ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,Σύνολο ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,ΣύνολοΑΡΧΗ ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Σύνολο=0 Σύνολο=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 Σύνολο=Σύνολο +Θερμοκρασία[i,j] Σύνολο=Σύνολο +Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση[j]=Σύνολο/30 Μέση[j]=Σύνολο/30ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Ημέρες=0 Ημέρες=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ Ημέρες=Ημέρες+1 Ημέρες=Ημέρες+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, Ημέρες ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, ΗμέρεςΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

11 Παράδειγμα 5: Θερμοκρασίες ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30,10], Μέση[10] ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,Σύνολο ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,ΣύνολοΑΡΧΗ ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] !Ξεκινούν οι υπολογισμοί ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] !Ξεκινούν οι υπολογισμοί ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Ξεκινά η δεύτερη σάρωση του ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Ξεκινά η δεύτερη σάρωση του ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ πίνακα και δίνεται αρχική τιμή 0 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 στη μεταβλητή Σύνολο Σύνολο=0 Σύνολο=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 Σύνολο=Σύνολο +Θερμοκρασία[i,j] Σύνολο=Σύνολο +Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση[j]=Σύνολο/30 Μέση[j]=Σύνολο/30ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Ημέρες=0 Ημέρες=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ Ημέρες=Ημέρες+1 Ημέρες=Ημέρες+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, Ημέρες ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, ΗμέρεςΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

12 Παράδειγμα 5:Θερμοκρασίες ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30,10], Μέση[10] ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,Σύνολο ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,ΣύνολοΑΡΧΗ ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] !Υπολογισμοί ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] !Υπολογισμοί ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Σύνολο=0 Σύνολο=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 Σύνολο=Σύνολο +Θερμοκρασία[i,j] Σύνολο=Σύνολο +Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση[j]=Σύνολο/30 Μέση[j]=Σύνολο/30ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Ημέρες=0 Ημέρες=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ Ημέρες=Ημέρες+1 Ημέρες=Ημέρες+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, Ημέρες ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, ΗμέρεςΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

13 Παράδειγμα 5: Θερμοκρασίες ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30,10], Μέση[10] ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,Σύνολο ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,ΣύνολοΑΡΧΗ ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Σύνολο=0 Σύνολο=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 Σύνολο=Σύνολο +Θερμοκρασία[i,j] Σύνολο=Σύνολο +Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση[j]=Σύνολο/30 Μέση[j]=Σύνολο/30ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Ημέρες=0 Ημέρες=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ Ημέρες=Ημέρες+1 Ημέρες=Ημέρες+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, Ημέρες ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, ΗμέρεςΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

14 Παράδειγμα 5: Θερμοκρασίες ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30,10], Μέση[10] ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,Σύνολο ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,ΣύνολοΑΡΧΗ ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] !Υπολογισμοί που καταχωρούνται ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] !Υπολογισμοί που καταχωρούνται ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ σε μονοδιάστατο πίνακα ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ σε μονοδιάστατο πίνακαΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Σύνολο=0 Σύνολο=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 Σύνολο=Σύνολο +Θερμοκρασία[i,j] Σύνολο=Σύνολο +Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση[j]=Σύνολο/30 Μέση[j]=Σύνολο/30ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Ημέρες=0 Ημέρες=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ Ημέρες=Ημέρες+1 Ημέρες=Ημέρες+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, Ημέρες ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, ΗμέρεςΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

15 Παράδειγμα 5:Θερμοκρασίες ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30,10], Μέση[10] ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,Σύνολο ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,ΣύνολοΑΡΧΗ ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] !Τρίτη σάρωση του δυσδιάστατου ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] !Τρίτη σάρωση του δυσδιάστατου ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ πίνακα Θερμοκρασία και αρχική ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ πίνακα Θερμοκρασία και αρχική ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ τιμή 0 στη μεταβλητή Ημέρες ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Σύνολο=0 Σύνολο=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 Σύνολο=Σύνολο +Θερμοκρασία[i,j] Σύνολο=Σύνολο +Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση[j]=Σύνολο/30 Μέση[j]=Σύνολο/30ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Ημέρες=0 Ημέρες=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ Ημέρες=Ημέρες+1 Ημέρες=Ημέρες+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, Ημέρες ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, ΗμέρεςΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

16 Παράδειγμα 5:Θερμοκρασίες ΠΡΟΓΡΑΜΜΑ Θερμοκρασιες ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30,10], Μέση[10] ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,Σύνολο ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,ΣύνολοΑΡΧΗ ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Σύνολο=0 Σύνολο=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 Σύνολο=Σύνολο +Θερμοκρασία[i,j] Σύνολο=Σύνολο +Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση[j]=Σύνολο/30 Μέση[j]=Σύνολο/30ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Ημέρες=0 Ημέρες=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ Ημέρες=Ημέρες+1 Ημέρες=Ημέρες+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, Ημέρες ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, ΗμέρεςΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

17 Παράδειγμα 5:Θερμοκρασίες ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30,10], Μέση[10] ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,Σύνολο ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,ΣύνολοΑΡΧΗ ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Σύνολο=0 Σύνολο=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 Σύνολο=Σύνολο +Θερμοκρασία[i,j] Σύνολο=Σύνολο +Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση[j]=Σύνολο/30 Μέση[j]=Σύνολο/30ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Ημέρες=0 Ημέρες=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ Ημέρες=Ημέρες+1 Ημέρες=Ημέρες+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, Ημέρες ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, ΗμέρεςΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

18 Παράδειγμα :Θερμοκρασίες ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30,10], Μέση[10] ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,Σύνολο ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,ΣύνολοΑΡΧΗ ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] !Εκτύπωση αποτελεσμάτων στην ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] !Εκτύπωση αποτελεσμάτων στην ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ οθόνη ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ οθόνηΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Σύνολο=0 Σύνολο=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 Σύνολο=Σύνολο +Θερμοκρασία[i,j] Σύνολο=Σύνολο +Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση[j]=Σύνολο/30 Μέση[j]=Σύνολο/30ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Ημέρες=0 Ημέρες=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ Ημέρες=Ημέρες+1 Ημέρες=Ημέρες+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, Ημέρες ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, ΗμέρεςΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

19 Παράδειγμα :Θερμοκρασίες ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30,10], Μέση[10] ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,Σύνολο ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,ΣύνολοΑΡΧΗ ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Σύνολο=0 Σύνολο=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 Σύνολο=Σύνολο +Θερμοκρασία[i,j] Σύνολο=Σύνολο +Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση[j]=Σύνολο/30 Μέση[j]=Σύνολο/30ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Ημέρες=0 Ημέρες=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ Ημέρες=Ημέρες+1 Ημέρες=Ημέρες+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, Ημέρες ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, ΗμέρεςΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

20 Παράδειγμα 5:Θερμοκρασίες ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30,10], Μέση[10] ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,Σύνολο ΑΚΕΡΑΙΕΣ: i, j, Ημέρες,ΣύνολοΑΡΧΗ ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i,j ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] !Τέλος προγράμματος ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] !Τέλος προγράμματος ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Σύνολο=0 Σύνολο=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 Σύνολο=Σύνολο +Θερμοκρασία[i,j] Σύνολο=Σύνολο +Θερμοκρασία[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση[j]=Σύνολο/30 Μέση[j]=Σύνολο/30ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Ημέρες=0 Ημέρες=0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ Ημέρες=Ημέρες+1 Ημέρες=Ημέρες+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Μέση Θερμοκρασία’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, Ημέρες ΓΡΑΨΕ ‘Ημέρες με μικρότερη Θερμοκρασία’, ΗμέρεςΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

21 Παράδειγμα 5: Θερμοκρασίες Προγραμματιστικό περιβάλλον PASCAL PROGRAM poleis; VAR temperature: array[1..30,1..10] OF REAL; temperature: array[1..30,1..10] OF REAL; ave: array[1..10] OF REAL; ave: array[1..10] OF REAL; total: REAL; total: REAL; i, j, days:INTEGER; i, j, days:INTEGER;BEGIN FOR i:=1 TO 30 DO FOR i:=1 TO 30 DO FOR j:=1 TO 10 DO FOR j:=1 TO 10 DO BEGIN BEGIN write (‘Δώσε θερμοκρασία:’, i,j, ‘ ’); write (‘Δώσε θερμοκρασία:’, i,j, ‘ ’); readln (temperature[i,j]); readln (temperature[i,j]); END; END; FOR j:=1 TO 10 DO FOR j:=1 TO 10 DO BEGIN BEGIN total:=0; total:=0; FOR i:=0 TO 30 DO FOR i:=0 TO 30 DO tota l:=total+temperature[i,j]; tota l:=total+temperature[i,j]; ave[j]:=total/30; ave[j]:=total/30; END; END;

22 FOR j:=1 TO 10 DO BEGIN BEGIN days:=0; days:=0; FOR i:=1 TO 30 DO FOR i:=1 TO 30 DO IF temperature[i,j]


Κατέβασμα ppt "Παράδειγμα 5: Θερμοκρασίες Να γραφεί πρόγραμμα που να υπολογίζει τη μέση θερμοκρασία κάθε πόλης για τον παρακάτω πίνακα θερμοκρασιών (δίδονται 30 θερμοκρασίες."

Παρόμοιες παρουσιάσεις


Διαφημίσεις Google