Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Επιμέλεια Π. Τσάκωνας. 1. Ποια από τα ακόλουθα αποσπάσματα αλγόριθμων πραγματοποιούν σωστά την ταξινόμηση του πίνακα Α; ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ Ν ΓΙΑ j ΑΠΟ.

Παρόμοιες παρουσιάσεις


Παρουσίαση με θέμα: "Επιμέλεια Π. Τσάκωνας. 1. Ποια από τα ακόλουθα αποσπάσματα αλγόριθμων πραγματοποιούν σωστά την ταξινόμηση του πίνακα Α; ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ Ν ΓΙΑ j ΑΠΟ."— Μεταγράφημα παρουσίασης:

1 Επιμέλεια Π. Τσάκωνας

2 1. Ποια από τα ακόλουθα αποσπάσματα αλγόριθμων πραγματοποιούν σωστά την ταξινόμηση του πίνακα Α; ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ Ν ΓΙΑ j ΑΠΟ Ν ΜΕΧΡΙ i ME_BHMA -1 AN A[j-1]

3 1. Ποια από τα ακόλουθα αποσπάσματα αλγόριθμων πραγματοποιούν σωστά την ταξινόμηση του πίνακα Α; ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ Ν ΓΙΑ j ΑΠΟ Ν ΜΕΧΡΙ i ME_BHMA -1 AN A[j-1]

4 1. Ποια από τα ακόλουθα αποσπάσματα αλγόριθμων πραγματοποιούν σωστά την ταξινόμηση του πίνακα Α; ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν ΓΙΑ j ΑΠΟ Ν ΜΕΧΡΙ i ME_BHMA -1 AN A[j-1]

5 1. Ποια από τα ακόλουθα αποσπάσματα αλγόριθμων πραγματοποιούν σωστά την ταξινόμηση του πίνακα Α; ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν-1 ΓΙΑ j ΑΠΟ Ν ΜΕΧΡΙ i+1 ME_BHMA -1 AN A[j]

6 1. Ποια από τα ακόλουθα αποσπάσματα αλγόριθμων πραγματοποιούν σωστά την ταξινόμηση του πίνακα Α; ΓΙΑ j ΑΠΟ 2 ΜΕΧΡΙ Ν ΓΙΑ i ΑΠΟ Ν ΜΕΧΡΙ j ME_BHMA -1 AN A[i-1]

7 1. Ποια από τα ακόλουθα αποσπάσματα αλγόριθμων πραγματοποιούν σωστά την ταξινόμηση του πίνακα Α; ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ Ν ΓΙΑ j ΑΠΟ Ν+1 ΜΕΧΡΙ i+1 ME_BHMA -1 AN A[j-1]

8 2. Δίνεται δισδιάστατος πίνακας 5000x4, ο οποίος περιέχει τα στοιχεία των πελατών ενός ασφαλιστικού γραφείου. Η πρώτη στήλη περιλαμβάνει τα επώνυμα των πελατών, η δεύτερη τα ονόματα, η τρίτη τη διεύθυνση και η τέταρτη την πόλη/συνοικία. Να γράψετε αλγόριθμο ο οποίος θα ταξινομεί τον πίνακα ως προς την πόλη κατοικίας. Σε περίπτωση που περισσότεροι του ενός πελάτες κατοικούν στην ίδια πόλη, θα ταξινομούνται κατά αύξουσα σειρά επωνύμου.

9 ΑΛΓΟΡΙΘΜΟΣ Πελατολόγιο ΔΕΔΟΜΕΝΑ //Π,5000,4 // !Εισαγωγή δεδομένων ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5000 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 4 ΓΡΑΨΕ “Δώσε”, j, “ο στοιχείο”, i,“ου πελάτη” ΔΙΑΒΑΣΕ Π[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

10 ΑΛΓΟΡΙΘΜΟΣ Πελατολόγιο ΔΕΔΟΜΕΝΑ //Π,5000,4,Πρ,4// !Εισαγωγή δεδομένων Πρ[1]  “Επώνυμο” Πρ[2]  “Όνομα” Πρ[3]  “Διεύθυνση” Πρ[4]  “Πόλη/Συνοικία” ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5000 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 4 ΓΡΑΨΕ “Δώσε”, Πρ[j], i, “ου πελάτη” ΔΙΑΒΑΣΕ Π[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

11 !Ταξινόμηση με κλειδί την Πόλη ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 5000 ΓΙΑ j ΑΠΟ 5000 ΜΕΧΡΙ i ΜΕ_ΒΗΜΑ -1 ΑΝ Π[j,4] < Π[j-1,4] TOTE temp  Π[j,4] Π[j,4]  Π[j-1,4] Π[j-1,4]  temp ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΒασιλείουΒασίλειοςΒηλαρά 4Βόλος ΑντωνίουΑντώνιοςΆλκμήνης 2Αθήνα ΒασιλείουΒασίλειοςΒηλαρά 4Αθήνα ΑντωνίουΑντώνιοςΆλκμήνης 2Βόλος

12 !Ταξινόμηση με κλειδί την Πόλη ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 5000 ΓΙΑ j ΑΠΟ 5000 ΜΕΧΡΙ i ΜΕ_ΒΗΜΑ -1 ΑΝ Π[j,4] < Π[j-1,4] TOTE !Αντιμετάθεση ΟΛΩΝ των ζευγαριών των γραμμών j και j-1 ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ 4 temp  Π[j, k] Π[j,k]  Π[j-1,k] Π[j-1,k]  temp ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΒασιλείουΒασίλειοςΒηλαρά 4Βόλος ΑντωνίουΑντώνιοςΆλκμήνης 2Αθήνα ΑντωνίουΒασίλειοςΒηλαρά 4Βόλος ΒασιλείουΑντώνιοςΆλκμήνης 2Αθήνα ΑντωνίουΑντώνιοςΒηλαρά 4Βόλος ΒασιλείουΒασίλειοςΆλκμήνης 2Αθήνα ΑντωνίουΑντώνιοςΆλκμήνης 2Βόλος ΒασιλείουΒασίλειοςΒηλαρά 4Αθήνα ΑντωνίουΑντώνιοςΆλκμήνης 2Αθήνα ΒασιλείουΒασίλειοςΒηλαρά 4Βόλος k=1k=2k=3k=4

13 !Ταξινόμηση με κλειδί την Πόλη ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 5000 ΓΙΑ j ΑΠΟ 5000 ΜΕΧΡΙ i ΜΕ_ΒΗΜΑ -1 ΑΝ Π[j,4] < Π[j-1,4] TOTE !Αντιμετάθεση ΟΛΩΝ των ζευγαριών των γραμμών j και j-1 ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ 4 temp  Π[j, k] Π[j,k]  Π[j-1,k] Π[j-1,k]  temp ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΑΛΛΙΩΣ_ΑΝ Π[j,4] = Π[j-1,4] TOTE ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

14 !Ταξινόμηση με κλειδί την Πόλη ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 5000 ΓΙΑ j ΑΠΟ 5000 ΜΕΧΡΙ i ΜΕ_ΒΗΜΑ -1 ΑΝ Π[j,4] < Π[j-1,4] TOTE !Αντιμετάθεση ΟΛΩΝ των ζευγαριών των γραμμών j και j-1 ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ 4 temp  Π[j, k] Π[j,k]  Π[j-1,k] Π[j-1,k]  temp ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΑΛΛΙΩΣ_ΑΝ Π[j,4] = Π[j-1,4] TOTE ΑΝ Π[j,1] < Π[j-1,1] TOTE ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

15 !Ταξινόμηση με κλειδί την Πόλη ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 5000 ΓΙΑ j ΑΠΟ 5000 ΜΕΧΡΙ i ΜΕ_ΒΗΜΑ -1 ΑΝ Π[j,4] < Π[j-1,4] TOTE !Αντιμετάθεση ΟΛΩΝ των ζευγαριών των γραμμών j και j-1 ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ 4 temp  Π[j, k] Π[j,k]  Π[j-1,k] Π[j-1,k]  temp ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΑΛΛΙΩΣ_ΑΝ Π[j,4] = Π[j-1,4] TOTE ΑΝ Π[j,1] < Π[j-1,1] TOTE !Αντιμετάθεση των 3 πρώτων των ζευγαριών των γραμμών j και j-1 ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ 3 temp  Π[j, k] Π[j,k]  Π[j-1,k] Π[j-1,k]  temp ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΒασιλείουΒασίλειοςΒηλαρά 4Βόλος ΑντωνίουΑντώνιοςΆλκμήνης 2Βόλος ΑντωνίουΒασίλειοςΒηλαρά 4Βόλος ΒασιλείουΑντώνιοςΆλκμήνης 2Βόλος ΑντωνίουΑντώνιοςΒηλαρά 4Βόλος ΒασιλείουΒασίλειοςΆλκμήνης 2Βόλος ΑντωνίουΑντώνιοςΆλκμήνης 2Βόλος ΒασιλείουΒασίλειοςΒηλαρά 4Βόλος ΑντωνίουΑντώνιοςΆλκμήνης 2Βόλος ΒασιλείουΒασίλειοςΒηλαρά 4Βόλος k=1k=2k=3

16 !Εμφάνιση ταξινομημένου πίνακα ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5000 ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ 4 ΓΡΑΨΕ Πρ[k], “:”, Π[i,k] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ Πελατολόγιο

17 3. Η χώρα Σουαζιλάνδη οργανώνει αγώνες πρόκρισης των ακοντιστών της στους Ολυμπιακούς Αγώνες. Από τους 70 αθλητές που συμμετέχουν θα προκριθούν οι 5 με τις καλύτερες επιδόσεις. Κάθε αθλητής δικαιούται να εκτελέσει 6 ρίψεις το πολύ, αλλά, μπορεί να πραγματοποιήσει και λιγότερες, αν ο ίδιος ή ο προπονητής του, θεωρήσουν ότι οι πρώτες προσπάθειες είναι ικανοποιητικές. Η κατάταξη των αθλητών ορίζεται βάσει της μέσης επίδοσής τους. Να γράψετε αλγόριθμο ο οποίος: α) θα ορίζει τους κατάλληλους πίνακες, β) θα ζητά το όνομα και το πλήθος των προσπαθειών κάθε αθλητή καθώς και τις επιδόσεις του σε κάθε προσπάθεια, γ) θα υπολογίζει και θα εμφανίζει τη μέση επίδοση κάθε αθλητή, δ) θα υπολογίζει και θα εμφανίζει την κατάταξη των αθλητών βάσει επίδοσης, και ε) θα εμφανίζει τα ονόματα εκείνων που θα λάβουν μέρος στους Αγώνες. Να υποθέσετε ότι δεν υπάρχουν ισοβαθμίες.

18 ΑΛΓΟΡΙΘΜΟΣ Αθλητές ΔΕΔΟΜΕΝΑ //Ο,70,Ριψ,70,Επ,70,6,ΜΟ,70// Να γράψετε αλγόριθμο ο οποίος: α) θα ορίζει τους κατάλληλους πίνακες,

19 ΑΛΓΟΡΙΘΜΟΣ Αθλητές ΔΕΔΟΜΕΝΑ //Ο,70,Ριψ,70,Επ,70,6,ΜΟ,70// ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 70 ΓΡΑΨΕ “Δώσε το όνομα του”,i, “ου αθλητή” ΔΙΑΒΑΣΕ Ο[i] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ β) θα ζητά το όνομα

20 ΑΛΓΟΡΙΘΜΟΣ Αθλητές ΔΕΔΟΜΕΝΑ //Ο,70,Ριψ,70,Επ,70,6,ΜΟ,70// ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 70 ΓΡΑΨΕ “Δώσε το όνομα του”,i, “ου αθλητή” ΔΙΑΒΑΣΕ Ο[i] ΓΡΑΨΕ “Δώσε το πλήθος των ρίψεών του” ΔΙΑΒΑΣΕ Ριψ[i] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ β) θα ζητά το όνομα και το πλήθος των προσπαθειών

21 ΑΛΓΟΡΙΘΜΟΣ Αθλητές ΔΕΔΟΜΕΝΑ //Ο,70,Ριψ,70,Επ,70,6,ΜΟ,70// ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 70 ΓΡΑΨΕ “Δώσε το όνομα του”,i, “ου αθλητή” ΔΙΑΒΑΣΕ Ο[i] ΓΡΑΨΕ “Δώσε το πλήθος των ρίψεών του” ΔΙΑΒΑΣΕ Ριψ[i] ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Ριψ[i] ΓΡΑΨΕ “Δώσε τη”, j, “η επίδοση” ΔΙΑΒΑΣΕ Επ[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ β) θα ζητά το όνομα και το πλήθος των προσπαθειών κάθε αθλητή καθώς και τις επιδόσεις του σε κάθε προσπάθεια,

22 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 70 sum  0 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Ριψ[i] sum  sum + Επ[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΜΟ[i]  sum/Ριψ[i] ΓΡΑΨΕ “Η μέση επίδοση του ”,Ο[i], “είναι”, ΜΟ[i] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ γ) θα υπολογίζει και θα εμφανίζει τη μέση επίδοση κάθε αθλητή,

23 ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 70 ΓΙΑ j ΑΠΟ 70 ΜΕΧΡΙ i ΜΕ_ΒΗΜΑ -1 ΑΝ ΜΟ[j]>ΜΟ[j-1] TOTE tempO  Ο[j] Ο[j]  Ο[j-1] Ο[j-1]  tempΟ tempΜΟ  ΜΟ[j] ΜΟ[j]  ΜΟ[j-1] ΜΟ[j-1]  tempΜΟ ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ δ) θα υπολογίζει την κατάταξη των αθλητών βάσει επίδοσης,

24 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 70 ΓΡΑΨΕ “Η επίδοση του”, Ο[i], “είναι”, ΜΟ[i] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ δ) θα υπολογίζει και θα εμφανίζει την κατάταξη των αθλητών βάσει επίδοσης,

25 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5 ΓΡΑΨΕ “Στους αγώνες προκρίνεται ”, i, “ος ο”, Ο[i] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ Αθλητές ε) θα εμφανίζει τα ονόματα εκείνων που θα λάβουν μέρος στους Αγώνες.

26 4. Τι θα αλλάξει στον προηγούμενο αλγόριθμο αν έχουν δικαίωμα πρόκρισης όλοι όσοι ισοβαθμούν με τον 5 ο ; !Έχουμε αλλαγή μόνο στο πέμπτο ερώτημα !Αρχικά θα προκριθούν οι πέντε καλύτεροι ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5 ΓΡΑΨΕ “Στους αγώνες προκρίνεται ”, i, “ος ο”, Ο[i] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ Αθλητές

27 4. Τι θα αλλάξει στον προηγούμενο αλγόριθμο αν έχουν δικαίωμα πρόκρισης όλοι όσοι ισοβαθμούν με τον 5 ο ; !Έχουμε αλλαγή μόνο στο πέμπτο ερώτημα !Αρχικά θα προκριθούν οι πέντε καλύτεροι ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5 ΓΡΑΨΕ “Στους αγώνες προκρίνεται ”, i, “ος ο”, Ο[i] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ !και ακολούθως όσοι ισοβαθμούν με τον 5 ο j  6 ΟΣΟ ΜΟ[j]=ΜΟ[5] ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ “Στους αγώνες προκρίνεται ”, j, “ος ο”, Ο[j] j  j+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ Αθλητές Τι λάθος έχει αυτός ο αλγόριθμος; Αν όλοι ισοβαθμούν με τον 5 ο, ο δείκτης j βγαίνει ΕΚΤΟΣ ΟΡΙΩΝ!!!

28 4. Τι θα αλλάξει στον προηγούμενο αλγόριθμο αν έχουν δικαίωμα πρόκρισης όλοι όσοι ισοβαθμούν με τον 5 ο ; !Έχουμε αλλαγή μόνο στο πέμπτο ερώτημα !Αρχικά θα προκριθούν οι πέντε καλύτεροι ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5 ΓΡΑΨΕ “Στους αγώνες προκρίνεται ”, i, “ος ο”, Ο[i] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ !και ακολούθως όσοι ισοβαθμούν με τον 5 ο j  6 ΚΑΙ j<70 ΟΣΟ ΜΟ[j]=ΜΟ[5] ΚΑΙ j<70 ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ “Στους αγώνες προκρίνεται ”, j, “ος ο”, Ο[j] j  j+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ Αθλητές Είναι σωστή αυτή η παραλλαγή; Όχι, γιατί δεν ελέγχει τον 70 ο αθλητή!

29 4. Τι θα αλλάξει στον προηγούμενο αλγόριθμο αν έχουν δικαίωμα πρόκρισης όλοι όσοι ισοβαθμούν με τον 5 ο ; !Έχουμε αλλαγή μόνο στο πέμπτο ερώτημα !Αρχικά θα προκριθούν οι πέντε καλύτεροι ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5 ΓΡΑΨΕ “Στους αγώνες προκρίνεται ”, i, “ος ο”, Ο[i] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ !και ακολούθως όσοι ισοβαθμούν με τον 5 ο j  6 = ΟΣΟ ΜΟ[j]=ΜΟ[5] ΚΑΙ j<=70 ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ “Στους αγώνες προκρίνεται ”, j, “ος ο”, Ο[j] j  j+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ Αθλητές Μήπως είναι σωστή αυτή η παραλλαγή; Όχι, γιατί και πάλι μπορεί να βγούμε εκτός ορίων του πίνακα

30 4. Τι θα αλλάξει στον προηγούμενο αλγόριθμο αν έχουν δικαίωμα πρόκρισης όλοι όσοι ισοβαθμούν με τον 5 ο ; !Έχουμε αλλαγή μόνο στο πέμπτο ερώτημα !Αρχικά θα προκριθούν οι πέντε καλύτεροι ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5 ΓΡΑΨΕ “Στους αγώνες προκρίνεται ”, i, “ος ο”, Ο[i] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ !και ακολούθως όσοι ισοβαθμούν με τον 5 ο ΤΕΛΟΣ Αθλητές ΔΙΑΦΟΡΕΤΙΚΑ ΣΗΜΕΙΑ Θα πρέπει να ελέγξουμε σε ΔΙΑΦΟΡΕΤΙΚΑ ΣΗΜΕΙΑ του κώδικα τις επί μέρους συνθήκες : 1. Ισόβαθμος αθλητής 2. Μη ισόβαθμος αθλητής 3. Δείκτης εκτός πίνακα ΔΙΑΦΟΡΕΤΙΚΑ ΣΗΜΕΙΑ Θα πρέπει να ελέγξουμε σε ΔΙΑΦΟΡΕΤΙΚΑ ΣΗΜΕΙΑ του κώδικα τις επί μέρους συνθήκες : 1. Ισόβαθμος αθλητής 2. Μη ισόβαθμος αθλητής 3. Δείκτης εκτός πίνακα Θα χρησιμοποιήσουμε μια ΛΟΓΙΚΗ μεταβλητή (έστω done) χωρίς η οποία θα τερματίζει τις επαναλήψεις όταν πρέπει, χωρίς να βγαίνουμε εκτός πίνακα Θα χρησιμοποιήσουμε μια ΛΟΓΙΚΗ μεταβλητή (έστω done) χωρίς η οποία θα τερματίζει τις επαναλήψεις όταν πρέπει, χωρίς να βγαίνουμε εκτός πίνακα πιο ευαίσθητη... ξεκινώντας από την πιο ευαίσθητη! ΠΟΙΑ ΕΙΝΑΙ Η ΣΩΣΤΗ ΣΕΙΡΑ ΕΛΕΓΧΟΥ ΤΩΝ ΠΕΡΙΠΤΩΣΕΩΝ;

31 4. Τι θα αλλάξει στον προηγούμενο αλγόριθμο αν έχουν δικαίωμα πρόκρισης όλοι όσοι ισοβαθμούν με τον 5 ο ; !Έχουμε αλλαγή μόνο στο πέμπτο ερώτημα !Αρχικά θα προκριθούν οι πέντε καλύτεροι ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5 ΓΡΑΨΕ “Στους αγώνες προκρίνεται ”, i, “ος ο”, Ο[i] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ !και ακολούθως όσοι ισοβαθμούν με τον 5 ο j  6 done  FALSE ΟΣΟ done=FALSE ΕΠΑΝΑΛΑΒΕ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ Αθλητές Θα χρησιμοποιήσουμε μια ΛΟΓΙΚΗ μεταβλητή (έστω done) χωρίς η οποία θα τερματίζει τις επαναλήψεις όταν πρέπει, χωρίς να βγαίνουμε εκτός πίνακα Θα χρησιμοποιήσουμε μια ΛΟΓΙΚΗ μεταβλητή (έστω done) χωρίς η οποία θα τερματίζει τις επαναλήψεις όταν πρέπει, χωρίς να βγαίνουμε εκτός πίνακα ΠΟΙΑ ΕΙΝΑΙ Η ΣΩΣΤΗ ΣΕΙΡΑ ΕΛΕΓΧΟΥ ΤΩΝ ΠΕΡΙΠΤΩΣΕΩΝ;

32 4. Τι θα αλλάξει στον προηγούμενο αλγόριθμο αν έχουν δικαίωμα πρόκρισης όλοι όσοι ισοβαθμούν με τον 5 ο ; !Έχουμε αλλαγή μόνο στο πέμπτο ερώτημα !Αρχικά θα προκριθούν οι πέντε καλύτεροι ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5 ΓΡΑΨΕ “Στους αγώνες προκρίνεται ”, i, “ος ο”, Ο[i] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ !και ακολούθως όσοι ισοβαθμούν με τον 5 ο j  6 done  FALSE ΟΣΟ done=FALSE ΕΠΑΝΑΛΑΒΕ AN j=71 ΤΟΤΕ done  TRUE ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ Αθλητές Αν είμαστε εκτός ορίων τότε τερματίζουμε την επανάληψη (η πιο ευαίσθητη συνθήκη) ΠΟΙΑ ΕΙΝΑΙ Η ΣΩΣΤΗ ΣΕΙΡΑ ΕΛΕΓΧΟΥ ΤΩΝ ΠΕΡΙΠΤΩΣΕΩΝ;

33 4. Τι θα αλλάξει στον προηγούμενο αλγόριθμο αν έχουν δικαίωμα πρόκρισης όλοι όσοι ισοβαθμούν με τον 5 ο ; !Έχουμε αλλαγή μόνο στο πέμπτο ερώτημα !Αρχικά θα προκριθούν οι πέντε καλύτεροι ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5 ΓΡΑΨΕ “Στους αγώνες προκρίνεται ”, i, “ος ο”, Ο[i] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ !και ακολούθως όσοι ισοβαθμούν με τον 5 ο j  6 done  FALSE ΟΣΟ done=FALSE ΕΠΑΝΑΛΑΒΕ AN j=71 ΤΟΤΕ done  TRUE ΑΛΛΙΩΣ_AN ΜΟ[j]<>ΜΟ[5] ΤΟΤΕ done  TRUE ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ Αθλητές Αν είμαστε εκτός ορίων τότε τερματίζουμε την επανάληψη (η πιο ευαίσθητη συνθήκη) εντός ορίων Διαφορετικά, αν είμαστε εντός ορίων, αλλά πάψαμε να βρίσκουμε ισόβαθμο αθλητή, τότε και πάλι τερματίζουμε την επανάληψη. ΠΟΙΑ ΕΙΝΑΙ Η ΣΩΣΤΗ ΣΕΙΡΑ ΕΛΕΓΧΟΥ ΤΩΝ ΠΕΡΙΠΤΩΣΕΩΝ;

34 4. Τι θα αλλάξει στον προηγούμενο αλγόριθμο αν έχουν δικαίωμα πρόκρισης όλοι όσοι ισοβαθμούν με τον 5 ο ; !Έχουμε αλλαγή μόνο στο πέμπτο ερώτημα !Αρχικά θα προκριθούν οι πέντε καλύτεροι ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5 ΓΡΑΨΕ “Στους αγώνες προκρίνεται ”, i, “ος ο”, Ο[i] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ !και ακολούθως όσοι ισοβαθμούν με τον 5 ο j  6 done  FALSE ΟΣΟ done=FALSE ΕΠΑΝΑΛΑΒΕ AN j=71 ΤΟΤΕ done  TRUE ΑΛΛΙΩΣ_AN ΜΟ[j]<>ΜΟ[5] ΤΟΤΕ done  TRUE ΑΛΛΙΩΣ ΓΡΑΨΕ “Στους αγώνες προκρίνεται ”, j, “ος ο”, Ο[j] j  j+1 ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ Αθλητές εντός ορίων Διαφορετικά, αν είμαστε εντός ορίων, αλλά πάψαμε να βρίσκουμε ισόβαθμο αθλητή, τότε και πάλι τερματίζουμε την επανάληψη. Διαφορετικά, συνεχίζουμε να εμφανίζουμε ονόματα και να αυξάνουμε το δείκτη j προχωρώντας μέσα στον πίνακα, μέχρι να ισχύσει κάποια από τις δύο προηγούμενες συνθήκες. ΠΟΙΑ ΕΙΝΑΙ Η ΣΩΣΤΗ ΣΕΙΡΑ ΕΛΕΓΧΟΥ ΤΩΝ ΠΕΡΙΠΤΩΣΕΩΝ; Αν είμαστε εκτός ορίων τότε τερματίζουμε την επανάληψη (η πιο ευαίσθητη συνθήκη)

35 5. Τι θα αλλάξει στον προηγούμενο αλγόριθμο αν έχουν δικαίωμα πρόκρισης όσοι ισοβαθμούν με τον 5 ο, με την προϋπόθεση ότι οι συνολικά προκρινόμενοι αθλητές δεν ξεπερνούν τους 8; !Έχουμε αλλαγή μόνο στο πέμπτο ερώτημα !Αρχικά θα προκριθούν οι πέντε καλύτεροι ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5 ΓΡΑΨΕ “Στους αγώνες προκρίνεται ”, i, “ος ο”, Ο[i] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ Αθλητές

36 5. Τι θα αλλάξει στον προηγούμενο αλγόριθμο αν έχουν δικαίωμα πρόκρισης όσοι ισοβαθμούν με τον 5 ο, με την προϋπόθεση ότι οι συνολικά προκρινόμενοι αθλητές δεν ξεπερνούν τους 8; !Έχουμε αλλαγή μόνο στο πέμπτο ερώτημα !Αρχικά θα προκριθούν οι πέντε καλύτεροι ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5 ΓΡΑΨΕ “Στους αγώνες προκρίνεται ”, i, “ος ο”, Ο[i] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ !και ακολούθως όσοι ισοβαθμούν με τον 5 ο (ως, το πολύ, τον 8 ο ) j  6 ΚΑΙ j<9 ΟΣΟ ΜΟ[j]=ΜΟ[5] ΚΑΙ j<9 ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ “Στους αγώνες προκρίνεται ”, j, “ος ο”, Ο[j] j  j+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ Αθλητές


Κατέβασμα ppt "Επιμέλεια Π. Τσάκωνας. 1. Ποια από τα ακόλουθα αποσπάσματα αλγόριθμων πραγματοποιούν σωστά την ταξινόμηση του πίνακα Α; ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ Ν ΓΙΑ j ΑΠΟ."

Παρόμοιες παρουσιάσεις


Διαφημίσεις Google