Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Ταξινόμηση Φυσσαλίδας (bubblesort) Αλεξιάδης Γεώργιος ΕΠΠΑΙΚ Σαπών 2010-2011.

Παρόμοιες παρουσιάσεις


Παρουσίαση με θέμα: "Ταξινόμηση Φυσσαλίδας (bubblesort) Αλεξιάδης Γεώργιος ΕΠΠΑΙΚ Σαπών 2010-2011."— Μεταγράφημα παρουσίασης:

1 Ταξινόμηση Φυσσαλίδας (bubblesort) Αλεξιάδης Γεώργιος ΕΠΠΑΙΚ Σαπών 2010-2011

2 Που βρισκόμαστε; Κεφάλαιο 3: Δομές Δεδομένων και Αλγόριθμοι •Δεδομένα •Αλγόριθμοι + Δομές δεδομένων = Προγράμματα •Πίνακες •Στοίβα και ουρά •Αναζήτηση και Ταξινόμηση •Αναδρομή •Άλλες δομές δεδομένων

3 Τι εννοούμε με τον όρο ταξινόμηση; Τακτοποίηση των κόμβων μιας δομής με μία ιδιαίτερη σειρά (συνήθως αύξουσα τάξη της τιμής των μεγεθών προς ταξινόμηση) Σε τι χρησιμεύει η ταξινόμηση; Διευκόλυνση στην αναζήτηση των στοιχείων μιας δομής (π.χ. βιβλιοθηκονομικά συστήματα, λεξικά, τηλεφωνικοί κατάλογοι)

4 Ταξινόμηση Ευθείας Ανταλλαγής ή Ταξινόμηση Φυσσαλίδας •Σύγκριση και ανταλλαγή ζευγών γειτονικών στοιχείων, μέχρι την πλήρη διάταξη όλων των στοιχείων •Διαδοχικές προσπελάσεις στον πίνακα και μετακίνηση του μικρότερου στοιχείου στο αριστερό του άκρο •Πίνακας σε κατακόρυφη μορφή => Δεξαμενή νερού με φυσσαλίδες (ταξινόμηση φυσσαλίδας – bubblesort).

5 203761845 1 ο πέρασμα 203761845 203761845 203761845

6 203761845 1 ο πέρασμα 203761845 203761845 206371845 206371845

7 203761845 1 ο πέρασμα 203761845 203761845 206371845 620371845

8 620371845 2 ο πέρασμα 620371845 620371845

9 620371845 2 ο πέρασμα 620371845 620183745 620183745

10 620371845 2 ο πέρασμα 620371845 620183745 618203745

11 618203745 3 ο πέρασμα 618203745 618203745

12 618203745 4 ο πέρασμα 618203745 618203745 Τέλος ταξινόμησης

13 Αλγόριθμος bubblesort Αλγόριθμος Φυσσαλίδα Δεδομένα // πίνακας, Ν // Για Κ από 2 μέχρι Ν Για Λ από Ν μέχρι Κ με_βήμα -1 Αν πίνακας[Λ-1] > πίνακας[Λ] τότε αντιμετάθεσε πίνακας[Λ-1], πίνακας[Λ] Τέλος_αν Τέλος_επανάληψης Αποτελέσματα // πίνακας // Τέλος Φυσσαλίδα

14 Πλεονεκτήματα •Απλότητα στην κατανόηση •Ευκολία στην εφαρμογή Μειονεκτήματα •Δεν προβλέπει την περίπτωση πλήρης ταξινόμησης σε ενδιάμεσα περάσματα •Χαμηλή ταχύτητα εκτέλεσης

15 Ανακεφαλαίωση  Ορισμός ταξινόμησης  Χρησιμότητα ταξινόμησης  Ταξινόμηση ευθείας ανταλλαγής ή φυσσαλίδας: •Περιγραφή •Αλγόριθμος •Παραδείγματα •Πλεονεκτήματα – Μειονεκτήματα

16 Ευχαριστώ για την προσοχή σας!!!


Κατέβασμα ppt "Ταξινόμηση Φυσσαλίδας (bubblesort) Αλεξιάδης Γεώργιος ΕΠΠΑΙΚ Σαπών 2010-2011."

Παρόμοιες παρουσιάσεις


Διαφημίσεις Google