Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Γενική μορφή προγράμματος Pascal Program όνομα προγράμματος (παράμετροι) Uses δήλωση μονάδων (βιβλιοθήκες με συναρτήσεις & διαδικασίες Const δήλωση σταθερών.

Παρόμοιες παρουσιάσεις


Παρουσίαση με θέμα: "Γενική μορφή προγράμματος Pascal Program όνομα προγράμματος (παράμετροι) Uses δήλωση μονάδων (βιβλιοθήκες με συναρτήσεις & διαδικασίες Const δήλωση σταθερών."— Μεταγράφημα παρουσίασης:

1 Γενική μορφή προγράμματος Pascal Program όνομα προγράμματος (παράμετροι) Uses δήλωση μονάδων (βιβλιοθήκες με συναρτήσεις & διαδικασίες Const δήλωση σταθερών Type δήλωση νέων τύπων Var δήλωση μεταβλητών Procedure δήλωση και περιγραφή διαδικασιών Function δήλωση και περιγραφή συναρτήσεων Begin Εδώ ξεκινάει το κύριο μέρος του προγράμματος End.

2 Το πρώτο μου Πρόγραμμα Program athrisma; uses wincrt; var x, y, athr: real; begin read (x,y); athr := x+y; writeln ('Αθροισμα = ',athr:7:2) end. Πρόσθεση δύο αριθμών

3 Απλή Δομή επιλογής Σύνταξη ΑΝ συνθήκη ΤΟΤΕ εντολή- 1 εντολή- 2 - ΤΕΛΟΣ_ΑΝ Ψευδής Αληθής

4 Σύνθετη Δομή επιλογής Σύνταξη ΑΝ συνθήκη ΤΟΤΕ εντολή- 1 εντολή- 2 - ΑΛΛΙΩΣ εντολή- 1 εντολή- 2 - ΤΕΛΟΣ_ΑΝ Αληθής Ψευδής

5 Απόλυτη τιμή αριθμού ΑΡΧΗ ΔΙΑΒΑΣΕ α ΑΝ α<0 ΤΟΤΕ α  (-1) * α ΤΕΛΟΣ_ΑΝ ΤΥΠΩΣΕ α ΤΕΛΟΣ Program apol_timi ; uses wincrt; var a:real; begin read(a); if a<0 then a := (-1)*a; writeln('Απόλυτη τιμή του α = ',a:5:0) end.

6 Εύρεση μεγαλύτερου αριθμού ΑΡΧΗ ΔΙΑΒΑΣΕ α, β ΑΝ α>β ΤΟΤΕ max  α ΑΛΛΙΩΣ max  Β ΤΕΛΟΣ_ΑΝ ΤΥΠΩΣΕ max ΤΕΛΟΣ program megarit; uses wincrt; var a,b,max:integer; begin read(a,b); if a>b then max := a else max := b; writeln( 'Μεγαλύτερος αριθμός είναι το : ',max) end.

7 Δομή πολλαπλής επιλογής Ναι Όχι

8 Χαρακτηρισμός Φοίτησης Program epidosi ; uses wincrt; var bath:real; xarakt:string[15]; begin write('Πληκτρολόγησε το βαθμό : '); read(bath); if bath >= 18.5 then xarakt := 'ΑΡΙΣΤΑ' else if bath >= 15 then xarakt := 'ΠΟΛΥ ΚΑΛΑ' else if bath >= 12.5 then xarakt := 'ΚΑΛΑ' else if bath >= 10 then xarakt := 'ΜΕΤΡΙΑ' else xarakt := 'ΑΠΟΡΡΙΠΤΕΤΑΙ' ; writeln('Χαρακτηρισμός φοίτησης : ',xarakt) end.

9 Εντολές Επανάληψης Εντολή ΟΣΟ …ΕΠΑΝΕΛΑΒΕ η συνθήκη είναι αληθής Σύνταξη : ΟΣΟ συνθήκη ΕΠΑΝΕΛΑΒΕ εντολή - 1 εντολή – 2 … εντολή – ν ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Εντολή ΜΕΧΡΙΣ_ΟΤΟΥ η συνθήκη γίνει αληθής Σύνταξη : ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ εντολή - 1 εντολή – 2 … εντολή – ν ΜΕΧΡΙΣ_ΟΤΟΥ συνθήκη

10 Δομές Επανάληψης Αληθής Ψευδής Αληθής Ψευδής ΟΣΟ …ΕΠΑΝΕΛΑΒΕ ΜΕΧΡΙΣ_ΟΤΟΥ

11 Υπολογισμός Μέσου Όρου 10 αριθμών με WHILE Program mesosOros ; uses wincrt; var metritis:integer; athrisma, apotelesma, x : real; begin metritis := 1; athrisma := 0; While metritis < 11 Do begin write('Πληκτρολόγησε τον ', metritis, 'ο αριθμό : '); readln(x); athrisma := athrisma + x; metritis := metritis + 1; end; apotelesma := athrisma / 10; writeln('Ο μέσος όρος είναι : ', apotelesma : 5 : 1) end.

12 Υπολογισμός Μέσου Όρου 10 αριθμών με REPEAT Program mesosOros ; uses wincrt; var metritis:integer; athrisma, apotelesma, x : real; begin metritis := 1; athrisma := 0; repeat write('Πληκτρολόγησε τον ', metritis, 'ο αριθμό : '); readln(x); athrisma := athrisma + x; metritis := metritis + 1; until metritis > 10 ; apotelesma := athrisma / 10; writeln('Ο μέσος όρος είναι : ', apotelesma : 5 : 1) end.

13 Εντολή ΓΙΑ … ΑΠΌ … ΜΕΧΡΙ Σύνταξη : ΓΙΑ μεταβλητή ΑΠΌ τιμή1 ΜΕΧΡΙ τιμή2 ΜΕ ΒΗΜΑ τιμή3 εντολή - 1 εντολή – 2 … εντολή – ν ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

14 Υπολογισμός αθροίσματος άρτιων αριθμών έως και το 100 Program artioi ; uses wincrt; var athrisma,x : integer; begin athrisma := 0; for x := 1 to 100 do begin if (x mod 2) = 0 then athrisma := athrisma + x ; end; writeln('Το άθροισμα είναι : ', athrisma ) end.

15 Ελάχιστο κοινό πολλαπλάσιο δύο αριθμών Program ekp ; uses wincrt; var a, b, n, h :integer; begin write('Δώσε τους αριθμούς a & b : ' ); readln(a, b ); if a < b then begin h := a; a := b; b := h; end ; n := 1; while a * n mod b <> 0 do n := n +1; writeln('Ε. Κ. Π. είναι : ', a * n ) end.

16 Ε. Κ. Π. δύο αριθμών ΝΑΙ ΟΧΙ  0 = 0

17 Προπαίδεια μέχρι το 10 Program proped ; uses wincrt; var a, b, c :integer; stop:char; begin for a := 1 to 10 do begin for b := 1 to 10 do begin c := a * b; writeln(a,'Χ', b, '=', c); end; writeln('Πάτα Enter για συνέχεια'); while stop = ' ' do; read(stop); end; end.

18 Εύρεση μικρότερου και μεγαλύτερου αριθμού Program maxmin ; uses wincrt; var pinakas : array[1..100] of integer; plithos, mikro, mega, i :integer; begin write('Δώσε πλήθος αριθμών : '); readln(plithos); if plithos > 100 then begin writeln('Το πλήθος είναι εκτός ορίου'); plithos := 100 end; mega := -maxint; mikro := maxint; for i := 1 to plithos do begin write('Πληκτρολόγησε τον ', i, 'ο αριθμό : '); readln(pinakas[i]); if pinakas[i] > mega then mega := pinakas[i]; if pinakas[i] < mikro then mikro := pinakas[i]; end; if plithos <= 0 then writeln('Ο πίνακας είναι άδειος') else begin writeln('Ο μεγαλύτερος αριθμός είναι το : ',mega); writeln('Ο μικρότερος αριθμός είναι το : ',mikro); end end.


Κατέβασμα ppt "Γενική μορφή προγράμματος Pascal Program όνομα προγράμματος (παράμετροι) Uses δήλωση μονάδων (βιβλιοθήκες με συναρτήσεις & διαδικασίες Const δήλωση σταθερών."

Παρόμοιες παρουσιάσεις


Διαφημίσεις Google