Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

Η παρουσίαση φορτώνεται. Παρακαλείστε να περιμένετε

15/4/2015Γ' ΤΑΞΗ -- 15 -- ΔΟΜΕΣ1 Γλώσσα Προγραμματισμού LOGO.

Παρόμοιες παρουσιάσεις


Παρουσίαση με θέμα: "15/4/2015Γ' ΤΑΞΗ -- 15 -- ΔΟΜΕΣ1 Γλώσσα Προγραμματισμού LOGO."— Μεταγράφημα παρουσίασης:

1 15/4/2015Γ' ΤΑΞΗ ΔΟΜΕΣ1 Γλώσσα Προγραμματισμού LOGO

2 15/4/2015Γ' ΤΑΞΗ ΔΟΜΕΣ2 ΒΑΣΙΚΕΣ ΑΛΓΟΡΙΘΜΙΚΕΣ ΔΟΜΕΣ ΕΝΤΟΛΩΝ: 1.ΔΟΜΗ ΑΚΟΛΟΥΘΙΑΣ 2. ΔΟΜΗ ΕΠΙΛΟΓΗΣ 3. ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ

3 15/4/2015Γ' ΤΑΞΗ ΔΟΜΕΣ3 Για τετράγωνο :πλευρά σβγ στκ μπροστά :πλευρά δεξιά 90 μπροστά :πλευρά δεξιά 90 μπ :πλευρά δε 90 μπ :πλευρά δε 90 ανακοίνωση :πλευρά δείξε :πλευρά τέλος 1.ΔΟΜΗ ΑΚΟΛΟΥΘΙΑΣ Αρχή Χειροκίνητη εισαγωγή δεδομένων Απευθείας εισαγωγή δεδομένων Εκχώρηση τιμών Υπολογισμοί Απεικόνιση στην οθόνη Εκτύπωση στο χαρτί Τέλος

4 15/4/2015Γ' ΤΑΞΗ ΔΟΜΕΣ4 2. ΔΟΜΗ ΕΛΕΓΧΟΥ ΑΝ συνθήκη τότε Block εντολών_1 ΔΙΑΦΟΡΕΤΙΚΑ Block εντολών_2 ΑΝ συνθήκη τότε Block εντολών_1

5 15/4/2015Γ' ΤΑΞΗ ΔΟΜΕΣ5 Η Logo διαθέτει λογικούς τελεστές όπως οι :, =, Ή, ΚΑΙ, ΟΧΙ. Επίσης δομές ελέγχου όπως η Αν και η ΑνΔιαφορετικά. Π.χ. 1. Αν : A > :B [εντολές] 2. Αν και :A > :B :Α :B [εντολή 1] [εντολή 2] συνθήκη 2. ΔΟΜΗ ΕΛΕΓΧΟΥ

6 15/4/2015Γ' ΤΑΞΗ ΔΟΜΕΣ6 ερώτηση [Δώσε τιμή στη μεταβλητή χ] κάνε "χ απάντηση ανδιαφορετικά :χ > 10 [δε 90 μπ 100] [αρ 90 μπ 100] 2. ΔΟΜΗ ΕΛΕΓΧΟΥ

7 15/4/2015Γ' ΤΑΞΗ ΔΟΜΕΣ7 ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ u Επανάλαβε 4 [μπ 100 δε 90] u ΕκτέλεσεΦορές [χ 4] [μπ 100 δε 90]

8 15/4/2015Γ' ΤΑΞΗ ΔΟΜΕΣ8 ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ

9 15/4/2015Γ' ΤΑΞΗ ΔΟΜΕΣ9 Εντολές Επανάληψης (συνέχεια) Επιπλέον η εντολή Επανάλαβε μπορεί να χρησιμοποιηθεί επαναληπτικά. Π.χ. Επανάλαβε 4 [Επανάλαβε 2 [μπ 60 δε 90 μπ 30 δε 90] δε 90] Δύο βρόχοι: Ένθετος και Εξωτερικός Σειρά Εκτέλεσης: Πρώτα ο Ένθετος και μετά ο Εξωτερικός ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ

10 15/4/2015Γ' ΤΑΞΗ ΔΟΜΕΣ10 Εργασία Βιβλίο σελ u Δραστηριότητα για το σπίτι: u Πρόγραμμα που θα ζητάει το μήκος των πλευρών α και β και μετά θα υπολογίζει την υποτείνουσα ορθογωνίου τριγώνου Στη συνέχεια θα σχεδιάζει το τρίγωνο –Όσοι έχουν Logo στον υπολογιστή κλπ να εκτυπώσουν το πρόγραμμα και τα γραφικά –Οι υπόλοιποι μαθητές στο τετράδιο


Κατέβασμα ppt "15/4/2015Γ' ΤΑΞΗ -- 15 -- ΔΟΜΕΣ1 Γλώσσα Προγραμματισμού LOGO."

Παρόμοιες παρουσιάσεις


Διαφημίσεις Google